The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support Rix Racing
Please Support ExtremePSI

97 eclipse

JeffGS-T97

Supporting Member
846
521
Mar 22, 2019
Muncie, Indiana
The coil pack seems to be far enough out of spec to warrent getting a replacement. Hopefully my gut instinct is right. I ordered a pair of oem coils due to coil B 2-3 is close to the minimum ohm tolerance and 1-4 is at 8ohms. I think i possibly shorted a coil pack by it touching the manifold but not sure.
 

JeffGS-T97

Supporting Member
846
521
Mar 22, 2019
Muncie, Indiana
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.

All 4 primary ohms
 

JeffGS-T97

Supporting Member
846
521
Mar 22, 2019
Muncie, Indiana
If i read the sheet right the only ohm test within tolerance is secondary high output between cylinder 2-3
You must be logged in to view this image or video.
 

JeffGS-T97

Supporting Member
846
521
Mar 22, 2019
Muncie, Indiana
Working on a smaller project until i can get the new coils. I got some flexible braided wire loom and started installing it and its pretty nice stuff. Seems to be superior to the normal plastic wire loom.
You must be logged in to view this image or video.
 

JeffGS-T97

Supporting Member
846
521
Mar 22, 2019
Muncie, Indiana
This is from left to right facing the engine and removed. #3 is super carbon coated. Im thinking a possible stuck injector.
You must be logged in to view this image or video.
 

JeffGS-T97

Supporting Member
846
521
Mar 22, 2019
Muncie, Indiana
Thanks man but I already ohm tested, did a sound check. I need to pull them for sure to hear better since I don't have a stethoscope. Cars bogs bad after a few minutes of idle and some serious rich white gas smelling smoke once it gets going. I compression tested so the HG is still ok.
 

TK's9d2TSi

Supporting Member
5,523
2,615
Sep 11, 2017
Cincinnati, Ohio
This is one of my old injectors being stuck. You can clearly hear the difference.

You must be logged in to view this image or video.

I also had white smoke that smelled like fuel but I forget if it was from me installing injector wires to the wrong cylinder
 

JeffGS-T97

Supporting Member
846
521
Mar 22, 2019
Muncie, Indiana
Thanks tony for the video! I do hear one that is a bit louder but will hear better when its out. So it seemed to be shorter and louder opening is that correct?
 

JeffGS-T97

Supporting Member
846
521
Mar 22, 2019
Muncie, Indiana
I tested 2 sets of injectors. Both sets are at 2.0 ohms, and when energized they all sound the same except cylinder 3. This injector is very loud about triple the volume of the others. Not sure what that means.
 

JeffGS-T97

Supporting Member
846
521
Mar 22, 2019
Muncie, Indiana
The fueling issue has been resolved. Turns out the rebuilt 750 injectors i purchased back this spring were junk. They tested fine but all four of them were not closing properly.
You must be logged in to view this image or video.

I got out the green and black 750's i showed earlier that were donated to me by a fellow tuner that left the DSM platform. Installed them and turned it over instant start. Balanced AFR and 850-890 idle.
Still need some heat sink grease for the resistor pack but as suggestes to me made the metal mount plate surface the same size of the back plate of the resistor.
You must be logged in to view this image or video.

Hopefully the car is done for awhile im getting burnt out on this thing🥵
 

JeffGS-T97

Supporting Member
846
521
Mar 22, 2019
Muncie, Indiana
So my fuel gauge seems to be dead and driving around i started misfiring and bucking. Noticed a lean out in fuel when it happens which as the car pulls under load and the gas peddle is pushed in to accelerate 30%tps it doesn't like it. Does this gas level look low enough to cause this in motion because you can rev it high while parked with no issues no CEL except p1105 relating to fuel solnoid circuit fault. My guesses are this gas level being low or the pump is going out. The pump does seem to change sound every once in a while. I didn't make the whole trip to the gas station because i was afraid of needing a tow truck, my car sits way too low for that business.
You must be logged in to view this image or video.

You must be logged in to view this image or video.
 

DSMPT

DSM Wiseman
1,636
1,177
Jun 12, 2014
Japan / Mexico, Arizona
If you are logging the fuel pressure, you can see easily if it sucks the air. Usually if the pump is sucking the air, you hear the pump sound louder. If you are not logging the fuel pressure, maybe you can check it on the fuel pressure regulator's gauge by activating the pump in ECMLink, and ask someone to shake the car. If you see the fuel pressure gets dropped while shaking the car, probably the level is too low.
 

JeffGS-T97

Supporting Member
846
521
Mar 22, 2019
Muncie, Indiana
Good idea, and yep i have a pressure gauge its located here.
You must be logged in to view this image or video.

Still need to do another BLT too, maybe i have a IC joiner loose.
 

JeffGS-T97

Supporting Member
846
521
Mar 22, 2019
Muncie, Indiana
If you are logging the fuel pressure, you can see easily if it sucks the air. Usually if the pump is sucking the air, you hear the pump sound louder. If you are not logging the fuel pressure, maybe you can check it on the fuel pressure regulator's gauge by activating the pump in ECMLink, and ask someone to shake the car. If you see the fuel pressure gets dropped while shaking the car, probably the level is too low.
I'll tell you what Hiroshi im really starting to lose hope with this car. Fix 3 things and 1 more bad thing pops up on me its very frustrating. I really just want to enjoy the car. Especially after basically replacing every nut and bolt on it.
 

DSMPT

DSM Wiseman
1,636
1,177
Jun 12, 2014
Japan / Mexico, Arizona
I'll tell you what Hiroshi im really starting to lose hope with this car. Fix 3 things and 1 more bad thing pops up on me its very frustrating. I really just want to enjoy the car. Especially after basically replacing every nut and bolt on it.
Yeah I know how you feel. But just be patient. Once you make it perfectly running without any issue, it would be way easier to maintain and modify more.
 

TK's9d2TSi

Supporting Member
5,523
2,615
Sep 11, 2017
Cincinnati, Ohio
Looks like about a gallon or two left in the tank. I’m sure I’ve ran it that low a few times in my 2g and I’ve never had issues from that. Have you ran those injectors before? Maybe they flow different. They’re low impedance injectors. Were the ones you were running the same shape? High impedance injectors are much narrower.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com Raven Fabrication RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top