The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Please Support ExtremePSI
Please Support ExtremePSI

Orca - 11 sec street rippa

Year
1992
Model/Trim
Eagle Talon TSi AWD

TK's9d2TSi

Supporting Member
4,654
1,908
Sep 11, 2017
Cincinnati, Ohio
FMIC time

32E2C166-1A6D-4460-A9CC-18838D6ADB78.jpeg
 

TK's9d2TSi

Supporting Member
4,654
1,908
Sep 11, 2017
Cincinnati, Ohio
It’s been a long day, 12 hours in da garage to be specific. Couple of heli coils and finally figured out how to get the trans in and out without f%#€ing up the subframe. Tweaked the ac lines and we should stay cool when it’s hot. The FMIC was always slightly off so straightened that out and cleaned up the dull end tanks. Enjoy and thanks for following

FBE922CB-F148-4801-9CD5-44C73F797DA8.jpeg
0907E0DF-48DC-4FE7-B712-79E5B37A97F5.jpeg
15E21E4F-1844-4411-BC50-72C62D6FBDEC.jpeg
2EE91620-6A27-484D-80A5-57B363FBC4A4.jpeg
B41286C1-3146-4BBF-9F25-27D332245C6A.jpeg
 

Attachments

  • 12B9DFD6-F7DC-4370-8B7B-594ED9F0768F.jpeg
    12B9DFD6-F7DC-4370-8B7B-594ED9F0768F.jpeg
    1 MB · Views: 60

TK's9d2TSi

Supporting Member
4,654
1,908
Sep 11, 2017
Cincinnati, Ohio
Great build! Wish I had the patience and know-how to do all that. Side note. How the hell do you embed all the pics?

Thanks man! A wise man once told me it’s only nuts and bolts. Select add photo/file at the bottom, then select full or thumbnail.
 

TK's9d2TSi

Supporting Member
4,654
1,908
Sep 11, 2017
Cincinnati, Ohio
Since I had drained the brake fluid, I took apart the rear calipers to paint. Couldn’t just have the fronts painted yah know!!! Any who, the p/s was missing this spring retainer so I drilled a washer to make it work. These were remans that I bought from advance auto when I first got the car...WTF!!! Should have just kept the originals and rebuilt them. Everything is back together once I’m done with the rear calipers.

Prime oil
Bleed p/s
Bleed brakes
Bleed coolant
Remove ac evaporator to remove the oil-might wait on this one

One more weekend and I should be firing her up

image.jpg


0EB15E9F-18ED-4E8B-A0E4-7C46978F2095.jpeg
8559893F-ED35-4F29-AEAC-549FA4B9A688.jpeg
 

TK's9d2TSi

Supporting Member
4,654
1,908
Sep 11, 2017
Cincinnati, Ohio
After 12 hours in the garage, I was ready to fire her up. Added all fluids, primed oil system and I had to tighten a few bolts, zero leaks after that. Primed fuel system, and it’s leaking on the p/s of the rail. Pretty sure it’s the end cap of the rail so I have to take that apart tomorrow. Pretty sure it’s the oring inside.

D5163D2B-FDA6-4177-BA2F-C2D1001AA3DF.jpeg
B40DEB40-5EBB-42A7-8033-76272CC4F52B.jpeg
B15A1377-7511-42F4-A092-6040C64307D0.jpeg 58559EB5-A0AB-4BD6-AD48-C334FA68B5EE.jpeg
B8EBF390-C488-46FD-BE9A-191797FF8C58.jpeg
 

TK's9d2TSi

Supporting Member
4,654
1,908
Sep 11, 2017
Cincinnati, Ohio
Well I got everything back together but bad news. It’s pushing coolant. I thought since I had the head resurfaced last year it would be fine to use mls and even had the machine shop check trueness. It started smoking so I threw in a new oem composite hg and that didn’t fix the issue. I ordered a coolant pressure test kit and have a feeling there’s a cracked in the head or block. Hoping it’s a cracked head tbh

Majority of the stuff I’ve done you can’t see but I’m super happy how the bay look now. But we all know looks aren’t everything.

0424C1DE-EFD8-455C-952C-B73CC290203D.jpeg
8B9172B4-9293-4E8E-A0DB-648AE8F256A4.jpeg
 

TK's9d2TSi

Supporting Member
4,654
1,908
Sep 11, 2017
Cincinnati, Ohio
She keeps fighting me... Set base timing, set biss, tuned idle, ready for cruise tune and she’s pissing coolant from timing side. Removed the timing cover and this 2 year old (about 5k miles) Gates water pump is leaking from the weep hole. Not sure if it’s from starting it without coolant but that’s the only thing I can think of. New one is ordered. Please stop fighting me :pray:

571A1283-A1AD-4FE4-B8A7-B363550855DA.jpeg
 

TK's9d2TSi

Supporting Member
4,654
1,908
Sep 11, 2017
Cincinnati, Ohio
Just read the whole thread...good stuff! Did you find the cause for you pushing coolant? Was it the water pump or was that unrelated?

Thanks man! I had 3 & 4 injector wires crossed and just needed to drive it to seat the rings. It didn’t smoke after that. I don’t think it’s pushing coolant.

Got the wp off. Just waiting on Mr. Amazon to swing by

image.jpg
 

TK's9d2TSi

Supporting Member
4,654
1,908
Sep 11, 2017
Cincinnati, Ohio
Picked up a set of 1600 and ditched the Bosch 2200s. I’d tune the idle and the next time I came out, it wouldn’t start so I wasn’t sure if it was too much fuel or too little on startup. Luckily ecmlink has the answer, crank injector adjustment in da. Bumped it a few % and it started right up. Also degreed my cams without using test springs and solid lifters. I know, I know. I rotated the motor 10 times per cam and it’s on the money.

5A459B6B-3CBF-41B2-B6AB-25F24DC5C303.jpeg
 

Attachments

  • log.2021.01.21-05.elg
    53.5 KB · Views: 7
Last edited:
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com OHM Racing Raven Fabrication RixRacing RockAuto RTM Racing SouthBay Fuel Injectors STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Latest Classifieds

Top