1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

1G Cut out/backfire under load at 4000rpm

Posted by talon20g, Jul 10, 2020

Please Support Southbay Fuel Injectors
Please Support Morrison Fabrication
  1. talon20g

    talon20g Proven Member

    178
    2
    Joined Mar 21, 2007
    Leggett, North Carolina
    The car is a fairly new build although she sat for 4 years and is now being finished up. I'll give some info on the car when I start to list what has been checked and changed. The car had pulled all the way till redline and then during a pull I heard a pop at around 4200rpm's. There were a few things that I found after. First was the line going to the boost gauge that came off and was laying at my feet, I also found that I had forgotten to put a check valve in the brake booster line and the exhaust gasket was blown. The exhaust gasket was my fault, I had some how managed to leave a small washer between the head and manifold. Once all this was fixed I went back out and as soon as the car starts to build boost it backfires and cuts out at around 4000rpms. I can ease up past 4000rpms if Im light on the throttle.

    The head is rebuilt with new guides, springs, valves and cams for a previous car and has less than 50 miles on it. Also has a jmf intake manifold. The bottom end is a stock 6 bolt and all the timing components are new. The timing is correct. I've checked twice.

    I've done several boost leak test and the car only has a small leak at the throttle body. Takes almost a minute to drop from 20 psi.

    New parts:
    Aeromotive 340lph rewired fuel pump
    10 micron filter
    -6an from filter to rail
    FP red turbo
    front mount
    Key Diver chip
    Innovate wideband

    Other parts from older build:
    1000cc injectors
    Evo 8 maf
    rebuilt ecu
    coil on plug
    38mm tial
    tial bov


    Ive done multiple boost leak test and swapped out the ignitor,switched cop to the factory coils, different plugs (brp7es) gapped at .025, .022 and then .018. Gone through the fuel system and calibrated the wideband. I have dsmlink but I'm still learning. I got it running and cruising, seemly well but had the same results while under load.
    The compression was at 160-165psi on all cylinders. The base timing is set at 5 degrees and the cas isn't 180 out. I may be missing a few things but this about covers it. Any ideas?
     

    314  0

    1992 Eagle Talon TSi
    19 @ 149 · 1G DSM
    Loading...
  2. TheFlashDSM

    TheFlashDSM Supporting Member

    949
    161
    Joined Feb 18, 2010
    stony brook, New York
    sounds like fuel cut, check your boost level when you get fuel cut
     

    Drag Race Build 3K  25

    1999 Mitsubishi Eclipse GSX
    awd · automatic · 2G DSM
    Loading...
  3. talon20g

    talon20g Proven Member

    178
    2
    Joined Mar 21, 2007
    Leggett, North Carolina
    I was able to make several full pulls previous with the keydiver chip. Also does the same thing with dsmlink. The wideband doesn't go lean either. I may try adding some fuel and see what happens.
     
    Last edited: Jul 10, 2020

    314  0

    1992 Eagle Talon TSi
    19 @ 149 · 1G DSM
    Loading...
  4. Vegas Smith

    Vegas Smith Previously Vegas smith

    3,887
    1,734
    Joined Dec 2, 2002
    Houston, Texas
    It would be really helpful to see a log. It's possible that the bpr plugs aren't cutting it and you should try some br7es ones. It's possible you're running a sh**load of timing at 4200 and the plugs can't handle it.
     

    Street Build 4K  3

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
  5. DSMPT

    DSMPT Proven Member

    900
    460
    Joined Jun 12, 2014
    Japan / Mexico, Arizona
    To me, this ^ still sounds like a boost leak. You may have missed some leak. I had a similar issue, finally found out some leaks, it was from the throttle body shaft seal. It was leaking "only" when it was fully open (there was no leak when it was closed). And one more was from the brake booster. The check valve was weak and it started leaking at certain pressure but it wasn't hearable from outside, I could hear it only when I was in the car.
     

    Drag Race Build 2K  3

    1990 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM

    Street Build 2K  4

    1998 Mitsubishi Eclipse GSX
    awd · automatic · 2G DSM
    Loading...
    camocorvette likes this.
  6. talon20g

    talon20g Proven Member

    178
    2
    Joined Mar 21, 2007
    Leggett, North Carolina
    It will be a few days before I can get back out there. I haven't gotten very far with dsmlink but I will get some br7es and log a pull. The timing should be the factory timing map.
     

    314  0

    1992 Eagle Talon TSi
    19 @ 149 · 1G DSM
    Loading...
  7. talon20g

    talon20g Proven Member

    178
    2
    Joined Mar 21, 2007
    Leggett, North Carolina
    I have done probably a dozen boost leak test. I had the same thought as you. The boost takes almost a minute to drop from 20psi.
     

    314  0

    1992 Eagle Talon TSi
    19 @ 149 · 1G DSM
    Loading...
  8. talon20g

    talon20g Proven Member

    178
    2
    Joined Mar 21, 2007
    Leggett, North Carolina
    Vegas smith, here is a log from about a month ago.
     

    Attached Files:

    314  0

    1992 Eagle Talon TSi
    19 @ 149 · 1G DSM
    Loading...
  9. Vegas Smith

    Vegas Smith Previously Vegas smith

    3,887
    1,734
    Joined Dec 2, 2002
    Houston, Texas
    I suspect the tps is bad or there is a wiring issue as the tp signal is extremely erratic in the rpm range you mentioned.
     

    Street Build 4K  3

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
  10. talon20g

    talon20g Proven Member

    178
    2
    Joined Mar 21, 2007
    Leggett, North Carolina
    I don't remember the specific's of this run. I may be varying the throttle to see if I could rev any higher. This log was over a month ago. I have spare parts from other cars. I'm sure I have a tps, although it has probably been sitting for a decade. I'll put another on. Thanks
     

    314  0

    1992 Eagle Talon TSi
    19 @ 149 · 1G DSM
    Loading...
  11. Vegas Smith

    Vegas Smith Previously Vegas smith

    3,887
    1,734
    Joined Dec 2, 2002
    Houston, Texas
    Your afrest gets wacky around that area. Possibly an issue with the maf?
     

    Street Build 4K  3

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
  12. talon20g

    talon20g Proven Member

    178
    2
    Joined Mar 21, 2007
    Leggett, North Carolina
    That is something I had considered. I do have my original gm maf set up. May try to swap it out. The wideband stays between 11.5-12 to 1 when the cut out and backfire occur. The car is just starting to make boost when this happens. I just installed the wideband yesterday.
     

    314  0

    1992 Eagle Talon TSi
    19 @ 149 · 1G DSM
    Loading...
  13. motomattx

    motomattx Proven Member

    2,952
    1,014
    Joined Dec 9, 2010
    wampum, Pennsylvania
    You also might have blown the diaphragm in the brake booster since you had no check valve in there.
     

    Drag Race Build 4K  24

    1995 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM
    Loading...
  14. talon20g

    talon20g Proven Member

    178
    2
    Joined Mar 21, 2007
    Leggett, North Carolina
    I'm sure I did. I have a spare
     

    314  0

    1992 Eagle Talon TSi
    19 @ 149 · 1G DSM
    Loading...
  15. Buddy2

    Buddy2 Proven Member

    105
    24
    Joined Oct 7, 2013
    Helsinki, Europe
    I had exactly same issue 2 years ago when i went 10.5:1 compression on e85. Only thing that really fixed the problem for me was going much colder plug when my dyno guy told me to. Car is happy with br10es here.
     

    351  9

    1992 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM

    155  0

    1992 Mitsubishi Eclipse GSX
    manual · 1G DSM

    634  8

    1995 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM
    Loading...
  16. talon20g

    talon20g Proven Member

    178
    2
    Joined Mar 21, 2007
    Leggett, North Carolina
    I tried a set of lightly used bpr9es and had the same problem. I will be getting a new set of plugs to try. When I've encountered problems like this in the past it always seems to be a boost leak or ignition problems. Not looking like either currently but I will get a set of colder plugs as well.
     

    314  0

    1992 Eagle Talon TSi
    19 @ 149 · 1G DSM
    Loading...
  17. talon20g

    talon20g Proven Member

    178
    2
    Joined Mar 21, 2007
    Leggett, North Carolina
    I've installed a new set of plugs and also tried my old gm maft. About to go do a boost leak test. Usually I'm able to figure things out but this has me stumped.
     
    Last edited: Jul 16, 2020

    314  0

    1992 Eagle Talon TSi
    19 @ 149 · 1G DSM
    Loading...
  18. talon20g

    talon20g Proven Member

    178
    2
    Joined Mar 21, 2007
    Leggett, North Carolina
    Here is a log of a 2nd gear pull and a 3rd gear pull
     

    Attached Files:

    314  0

    1992 Eagle Talon TSi
    19 @ 149 · 1G DSM
    Loading...
  19. frosh29

    frosh29 Proven Member

    294
    29
    Joined Jul 29, 2004
    Wallington, New Jersey
    What’s the result of the BLT (latest one).

    Also have you ever hit fuel cut? I ask because you are saying when it starts to build boost it does something. What, exactly, it it doing?
     
    Last edited: Jul 16, 2020

    Street Build 270  1

    1995 Eagle Talon TSi AWD
    awd · manual · 2G DSM

    Street Build 465  1

    1991 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM
    Loading...
  20. talon20g

    talon20g Proven Member

    178
    2
    Joined Mar 21, 2007
    Leggett, North Carolina
    Fuel filter and strainer were clogged up. Both had less than 20 miles on them. Gas tank has rust in it.
     

    314  0

    1992 Eagle Talon TSi
    19 @ 149 · 1G DSM
    Loading...

Share This Page

Support Vendors who Support the DSM Community
ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory