1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Need help dialing in setup/troubleshooting

Posted by madmax4, Nov 11, 2019

Please Support ExtremePSI
Please Support Rix Racing
  1. madmax4

    madmax4 Probationary Member

    19
    5
    Joined Jun 21, 2011
    hartford, Connecticut
    Recently got the car back together and mobile, but im having trouble getting my baseline tune dialed in correctly using the basic info on the ecmlink wikki and from here. I have very limited experience so im not sure what to change to get smooth idle and free revs back inline.

    its struggling to idle, combined ft is out of wack as well as my fuel trims. under partial throttle out of gear it goes full rich throughout the rpm band but operates normally under load on the road. im not having success messing with deadtime or the mafcomp sliders. Any and all input would be helpful, here is a log of whats going on
     

    Attached Files:

    Street Build 113  1

    1997 Mitsubishi Eclipse GST
    awd · manual · 2G DSM
    Loading...
  2. Vdubzr32

    Vdubzr32 Proven Member

    335
    19
    Joined Nov 16, 2012
    Lake Hopatcong, New Jersey
    First thing anyone on here would tell you.

    Check for boost leaks

    And since you’ve watched the videos double check your work.

    Im limited as well but with the wiki info on ecmlink i was able to get my car dialed in. I wish i could help more.
     

    Street Build 3K  11

    1996 Eagle Talon TSi AWD
    awd · automatic · 2G DSM
    Loading...
  3. tk106

    tk106 Supporting Member

    1,759
    494
    Joined Sep 11, 2017
    Cincinnati, Ohio
    Your profile says you have link. Posting a log would help.
     

    169  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    172  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 2K  6

    1992 Eagle Talon TSi AWD
    12.625 @ 111.42 · 1G DSM
    Loading...
  4. madmax4

    madmax4 Probationary Member

    19
    5
    Joined Jun 21, 2011
    hartford, Connecticut
    thank you for the reply im not sure if a boost leak would cause this considering its occurring at idle/partial throttle at a stop but I do need to do a boost leak test for peace of mind. I originally uploaded a xl doc here is the correct one
     

    Attached Files:

    Street Build 113  1

    1997 Mitsubishi Eclipse GST
    awd · manual · 2G DSM
    Loading...
  5. tk106

    tk106 Supporting Member

    1,759
    494
    Joined Sep 11, 2017
    Cincinnati, Ohio
    You're on speed density, correct?
     

    169  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    172  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 2K  6

    1992 Eagle Talon TSi AWD
    12.625 @ 111.42 · 1G DSM
    Loading...
  6. madmax4

    madmax4 Probationary Member

    19
    5
    Joined Jun 21, 2011
    hartford, Connecticut
    Not on SD yet, need to get the sd bundle
     

    Street Build 113  1

    1997 Mitsubishi Eclipse GST
    awd · manual · 2G DSM
    Loading...
  7. tk106

    tk106 Supporting Member

    1,759
    494
    Joined Sep 11, 2017
    Cincinnati, Ohio
    Here are a couple of good threads.
    https://www.dsmtuners.com/threads/basic-dsmlink-tuning-guide.262460/
    https://www.dsmtuners.com/threads/tuning-with-ecmlink-v3.448002/
    https://www.dsmtuners.com/threads/the-big-book-of-random-tuning-tips.511262/

    There are steps before even touching any setting in link. As Vdubzr32 said, blt is a one of those.

    https://www.ecmtuning.com/wiki/baseinjectordata
    Set your global to -45 and deadtime to 420. Zero out your fuel slider.
    Under Maf Com, You only use the 0 & 50hz to get your airflowperrev to .25 on a fully warmed engine.
    Under misc, uncheck Disable airflow smoothing w sd op
    Under DTC's, you have code 1500. Might want to look into that.
    Set tps to .63v
    Make sure your throttle cable isn't too tight.

    Your temp gets pretty high, 226 at one point. That might be something to look into.

    Not sure if ECU inputs are correct. 2G guys will have to chime in on that one.
     

    169  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    172  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 2K  6

    1992 Eagle Talon TSi AWD
    12.625 @ 111.42 · 1G DSM
    Loading...
    1990TSIAWDTALON and GST with PSI like this.
  8. tk106

    tk106 Supporting Member

    1,759
    494
    Joined Sep 11, 2017
    Cincinnati, Ohio
    Stock throttle body?

    Idle is set to 750 but she’s idling around 900. So something is off. Might want to log iscposition to make sure biss is adjusted properly.
     

    169  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    172  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 2K  6

    1992 Eagle Talon TSi AWD
    12.625 @ 111.42 · 1G DSM
    Loading...
  9. madmax4

    madmax4 Probationary Member

    19
    5
    Joined Jun 21, 2011
    hartford, Connecticut
    Thank you for all the info I got frustrated and made a post when maybe more research and verification that everything is mechanically sound before tuning is what I need. I just didn’t understand why when I got everything back together it randomly started going rich like it is at idle and Revving but not under load when initially it was fine. I also suspect that the code p1500 is causing problems because my fuel pump is not rewired and I may have coil packs on the way out. Thanks again hopefully I figure it out tomorrow before work, don’t like pulling up to a stop light and seeing 10:1 afr scared I’m gonna wash the cylinders.
     

    Street Build 113  1

    1997 Mitsubishi Eclipse GST
    awd · manual · 2G DSM
    Loading...
  10. madmax4

    madmax4 Probationary Member

    19
    5
    Joined Jun 21, 2011
    hartford, Connecticut
    And yea stock TB witch is also possibly not sealing because it’s the oem unit
     

    Street Build 113  1

    1997 Mitsubishi Eclipse GST
    awd · manual · 2G DSM
    Loading...
  11. Vegas smith

    Vegas smith Proven Member

    2,788
    1,346
    Joined Dec 2, 2002
    Houston, Texas
    Car is running rich but isn't far off from running well. Do exactly what TK said and log iscposition etc. Your MAP is locked. I'm not familiar with the function of the map on 2gs but it would be nice to unlock that so you can see vacuum and boost.
     

    Street Build 3K  10

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
    1990TSIAWDTALON and madmax4 like this.
  12. madmax4

    madmax4 Probationary Member

    19
    5
    Joined Jun 21, 2011
    hartford, Connecticut
    Yea I locked it when I was trying to tune, unfortunately my Omni isn’t reading it stays at a fixed number so when I get the sd bundle I’ll be able to log vacuum and boost, I’ll log isc position after work tonight
     

    Street Build 113  1

    1997 Mitsubishi Eclipse GST
    awd · manual · 2G DSM
    Loading...
  13. tk106

    tk106 Supporting Member

    1,759
    494
    Joined Sep 11, 2017
    Cincinnati, Ohio
    I understand you want to get her going but being patient will pay off in the long run. Make sure everything is sound, then start tuning so you don’t chase your tail.

    If the seals haven’t been replaced, I’d bet they’re leaking.
     

    169  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    172  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 2K  6

    1992 Eagle Talon TSi AWD
    12.625 @ 111.42 · 1G DSM
    Loading...
    madmax4 likes this.
  14. madmax4

    madmax4 Probationary Member

    19
    5
    Joined Jun 21, 2011
    hartford, Connecticut
    so I was still driving it to work waiting until had money for an alternator, was running fine besides rich condition at idle. on a cold start up two weeks ago maybe 2 min into a cruise no longer could log WB and was running lean. limped it home and parked it till I replaced the alternator with a used one from rix racing today. on start up seemed fine still couldn't log WB so I think the voltage regulator (p1500) either damaged my WB or ecu, I think this is also why my omni stopped logging. was able to get ISC to 29 at one point then it kept fluctuating from there. it kept stalling after it was warmed up as well.

    ill take my ecu out tomorrow to check it over. im not sure if it will be visible damage or not.
    here are some logs of what its doing now
     

    Attached Files:

    Street Build 113  1

    1997 Mitsubishi Eclipse GST
    awd · manual · 2G DSM
    Loading...
  15. Vegas smith

    Vegas smith Proven Member

    2,788
    1,346
    Joined Dec 2, 2002
    Houston, Texas
    You're settings are still wrong. Go to "ecu inputs" and correct the map sensor. On the top you have the map set to baro but on the bottom you have it set to mdp.

    Go to "maf comp" and disable maf compensation and change base maf type to speed density. Report back.
     

    Street Build 3K  10

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
    1990TSIAWDTALON likes this.
  16. madmax4

    madmax4 Probationary Member

    19
    5
    Joined Jun 21, 2011
    hartford, Connecticut
    ok awesome didn't even notice I had it set for baro not MDP thank you its logging again. now I just have to figure out the WB, maybe it shorted out the gauge when my voltage spiked with the faulty alternator. it was oscillating around 14.7 before and going nicely between .20 and .80 but now it stays at .80

    I switched the other settings, did you want to see if it was my MAF that is on its way out? im still on the stock MAF, have to buy the IAT sensor to run SD. heres a couple logs with the corrected settings. my computer died in the middle of warming her up, she kept stalling again.
     

    Attached Files:

    Street Build 113  1

    1997 Mitsubishi Eclipse GST
    awd · manual · 2G DSM
    Loading...
  17. Vegas smith

    Vegas smith Proven Member

    2,788
    1,346
    Joined Dec 2, 2002
    Houston, Texas
    Sorry, it's hard to keep track of everyone's setup. I thought you were on SD.
     

    Street Build 3K  10

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
  18. madmax4

    madmax4 Probationary Member

    19
    5
    Joined Jun 21, 2011
    hartford, Connecticut
    No worries easy mistake with all the posts like this on here. What a relief I had those settings wrong and it’s not the sensor, thanks again for spotting that. My ECU May still be damaged unfortunately due to the alternator. my WB still reads A/F just fine on the gauge but cannot log in link.

    I think it’s still a combination of things. I need remove and test my IAC, and fix the seals in the throttle body. I need to figure out my 02 not swinging voltage and why I can’t log my AF now. One of the last things is the slight overheating and now stalling, witch may be the coolant not circulating enough due to denting my water pipe too far for my H1c compressor cover. My FIAV not getting coolant mixed with all the above problems especially since it’s so cold now are probably causing my new rough idle condition.
     

    Street Build 113  1

    1997 Mitsubishi Eclipse GST
    awd · manual · 2G DSM
    Loading...
  19. Vegas smith

    Vegas smith Proven Member

    2,788
    1,346
    Joined Dec 2, 2002
    Houston, Texas
    Why test the iac? You got it around 30 when warmed up. It looks good to me unless I'm missing something. Your big problem is your wideband isn't reading. I don't know what wideband you own but double check that the signal wire didn't come loose etc. recalibrate it etc. These things are finicky. Basically, the car is running without an o2 sensor right now because the wideband is your only sensor and its not reading correctly.
     

    Street Build 3K  10

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
    1990TSIAWDTALON likes this.
  20. 1990TSIAWDTALON

    1990TSIAWDTALON Moderator

    4,588
    2,018
    Joined Nov 14, 2013
    Independence, Kansas
    I think the global is off. His CombFT and STFT's are trying to lean the car out more and more as the logs go along. What do you think @Vegas smith ???
     

    Street Build 3K  27

    1992 Eagle Talon TSi AWD
    awd · automatic · 1G DSM

    543  14

    1990 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM

    450  18

    1967 Chevrolet Camaro RS
    rwd · automatic · Misc Vehicles

    Street Build 654  7

    1998 Eagle Talon TSi
    fwd · manual · 2G DSM

    Street Build 5K  11  25

    1990 Eagle Talon TSi AWD
    13.620 @ 108.460 · 1G DSM
    Loading...
  21. 1990TSIAWDTALON

    1990TSIAWDTALON Moderator

    4,588
    2,018
    Joined Nov 14, 2013
    Independence, Kansas
    I am tuning a 90 GSX on a MAF with cams in it, otherwise stock and I had to play with my Maf Comp to get her to idle good/at all. Try playing with it and see if the car reacts better or worse for the idling. You usually only have to fiddle with the 0, 50, 100 and 150hz area's but my car likes something like this.....Just something for you to try, you won't kill it!
    Marty
    MY MAF COMP table for a stock 90 GSX.png
     

    Street Build 3K  27

    1992 Eagle Talon TSi AWD
    awd · automatic · 1G DSM

    543  14

    1990 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM

    450  18

    1967 Chevrolet Camaro RS
    rwd · automatic · Misc Vehicles

    Street Build 654  7

    1998 Eagle Talon TSi
    fwd · manual · 2G DSM

    Street Build 5K  11  25

    1990 Eagle Talon TSi AWD
    13.620 @ 108.460 · 1G DSM
    Loading...
  22. madmax4

    madmax4 Probationary Member

    19
    5
    Joined Jun 21, 2011
    hartford, Connecticut
    Thank you for the example to shoot for, hopefully I can start to tune when I work out all these bugs. Im not sure if my ISC position swinging around is normal considering all the other problems with my 02, coolant temp and vacuum.

    I think I’m done with AEM WBs I’m ordering an innovate LC2 this week. Doing some Tb shaft seals and going to try to bleed my coolant system better. with the rather large dent I had to put in the water pipe for my H1c/DNP header combos fitment, I just can’t seem to get all the air out.
     

    Street Build 113  1

    1997 Mitsubishi Eclipse GST
    awd · manual · 2G DSM
    Loading...
  23. 1990TSIAWDTALON

    1990TSIAWDTALON Moderator

    4,588
    2,018
    Joined Nov 14, 2013
    Independence, Kansas
    Does your thermostat have the jiggle valve in it? It not drill a 1/8" hole in the flat portion to give it the ability to burp.
    I hope my AEM does better than yours, it came with my car (EUGO or something like that) and I have it wired up just no sensor installed yet but that MAY be today. You will love the LC2, that is what is in my other 2 DSM's and it plays well and works well with Link.
     

    Street Build 3K  27

    1992 Eagle Talon TSi AWD
    awd · automatic · 1G DSM

    543  14

    1990 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM

    450  18

    1967 Chevrolet Camaro RS
    rwd · automatic · Misc Vehicles

    Street Build 654  7

    1998 Eagle Talon TSi
    fwd · manual · 2G DSM

    Street Build 5K  11  25

    1990 Eagle Talon TSi AWD
    13.620 @ 108.460 · 1G DSM
    Loading...
  24. Vegas smith

    Vegas smith Proven Member

    2,788
    1,346
    Joined Dec 2, 2002
    Houston, Texas
    His wideband, that's also acting as his narrowband, is stuck at 9.6. I think that's causing his fuel issues.
     

    Street Build 3K  10

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
    1990TSIAWDTALON likes this.
  25. madmax4

    madmax4 Probationary Member

    19
    5
    Joined Jun 21, 2011
    hartford, Connecticut
    Hopefully you have better luck than I have, this is my second one that’s not working correctly. However it is possible that my voltage regulator burned out something in the gauge itself. It’s reading normally on the gauge display but as @Vegas smith Pointed out it’s pinned at 9.6 in link. Either way I’m tired of it not logging the true value and am looking forward to having the LC-2.

    Can’t wait to try that on my thermostat, thank you for the tip.
     

    Street Build 113  1

    1997 Mitsubishi Eclipse GST
    awd · manual · 2G DSM
    Loading...
    1990TSIAWDTALON likes this.

Share This Page

Support Vendors who Support the DSM Community
Archer Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory WheelWell.com