1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Resolved HELP ME get my car running right again

Posted by Luke_DSM, Sep 13, 2019

Please Support ExtremePSI
Please Support Southbay Fuel Injectors
  1. Luke_DSM

    Luke_DSM Probationary Member

    10
    1
    Joined Sep 12, 2019
    Winfield, Alabama
    So, i own a 1999 Mitsubishi Eclipse Gst Spyder with these mods done to it:
    (I'm just now getting into cars)
    Small 16g turbo with install kit

    Front mount intercooler

    Evo8 560cc injectors

    Fuel lab adjustable Fuel pressure regulator

    Walbro 255 fuel pump

    3 inch turbo back exhaust

    Greddy boost controller and turbo timer

    Prosport volt, oil pressure, fuel pressure, boost and wide band air fuel gauges.

    Evo valve cover.

    Injen air intake kit.

    Greddy type s blow off valve

    Ceddy mods flash tuning software on h8 black box ecu

    Taxtrics tuning cable for flat sh tuning




    My problem is, yesterday morning my exhaust came unbolted from the engine exit, and was pushing exhaust out of the engine rather than through the system. Since i am in high school, i didn't have time to go to a supply store and buy new bolts and nuts to put it back together, so i waited until after school to go to my house, change clothes the go to the supply store. At the only supply store that was open at the time (5pm) the didn't have the stuff i needed, so i decided to go home and wake up early in the morning to go to a different store. Well on the way back home my car spudered and killed out randomly, so i coasted to a nearby parking lot to see what had happened. I tried to crank it up again, and it cranked, ran for a couple seconds then killed out.

    I called my brother, got him to get some bolts and nuts from somewhere (he found a place that was opened) and put the exhaust back on.

    Problem solved right? Wrong.

    Now when i crank the car it idles normal, but when i touch the gas pedal, it throws my wideband gauge off and makes it go crazy and it kills out.

    My theory - Since i drove the car for a little bit without the exhaust passing by the Oxygen Sensor l, the sensor was telling my car that i wasn't pushing out any exhaust, and the car needed more gas in the engine, causing it to flood my engine.

    But get this... i left my car overnight to let the engine drain, so when i came back i could crank it and the sensor would see that everything is okay now. When i cranked it up, it idled perfect, until i pressed the gas and it flooded the engine again.

    I don't know what to do and this is my daily car to get to school and work so if you can help please do asap. i have the tuning software on a laptop just don't know how to use it.

    If you need videos to see what it's doing i will be more than happy to show you.

    Thanks!
     

    Attached Files:

    Street Build 210  6

    1999 Mitsubishi Eclipse Spyder GST
    fwd · automatic · 2G DSM
    Loading...
  2. BLACK'98DSM

    BLACK'98DSM Proven Member

    624
    188
    Joined Feb 9, 2019
    Hoover, Alabama
    Pull your battery cables for about 5-10 minutes, this will clear all codes and faults. If that doesn't work then there is something deeper happening here.
     

    Road Race Build 2K  15

    1998 Mitsubishi Eclipse N/T
    fwd · manual · 2G DSM

    290  3

    2012 Murray Explorer Dune
    rwd · automatic · Misc Vehicles

    203  6

    2009 Troy Bilt Bronco
    rwd · automatic · Misc Vehicles
    Loading...
  3. Luke_DSM

    Luke_DSM Probationary Member

    10
    1
    Joined Sep 12, 2019
    Winfield, Alabama
    pulled them and also touched them together so i could drain all the juice left over inside... still nothing, check engine light went off though
     

    Street Build 210  6

    1999 Mitsubishi Eclipse Spyder GST
    fwd · automatic · 2G DSM
    Loading...
  4. ChessmoDSM

    ChessmoDSM Supporting VIP

    198
    128
    Joined Apr 22, 2017
    Burlington, Vermont
    Try to replace or re-calibrate the 02 sensor..
     
  5. Mello

    Mello Proven Member

    927
    220
    Joined Jul 4, 2003
    Albuquerque, New Mexico
    Exhaust is hot. Was it pushing out around any wiring? Check for any melted wires if it was pushing out around any.
     
  6. motomattx

    motomattx Proven Member

    1,721
    527
    Joined Dec 9, 2010
    wampum, Pennsylvania
    Sounds like a boost leak OR the mass air sensor is not reading all of the air entering the engine for some reason,
     

    Drag Race Build 2K  16

    1995 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM
    Loading...
  7. d1prospect

    d1prospect Proven Member

    214
    27
    Joined Mar 14, 2004
    Glen Bunie, Maryland
    Do you have a cat? Happened to someone I know but his cat was completely clogged causing a restriction. Not saying that’s your issue but worth a shot(that is if you still have a cat on the car). :idontknow::confused:
     

    Drag Race Build 3K  15

    1995 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM
    Loading...
  8. Vegas smith

    Vegas smith Proven Member

    2,634
    1,217
    Joined Dec 2, 2002
    Houston, Texas
    Perhaps you’re right that the o2 was reading lean, therefore causing the car to push a lot more fuel. Just giving you ideas, but check your spark plugs for fouling and like previously stated, check for burnt wires and such. Report back.
     

    Street Build 3K  10

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
  9. Luke_DSM

    Luke_DSM Probationary Member

    10
    1
    Joined Sep 12, 2019
    Winfield, Alabama
    no animals
     

    Street Build 210  6

    1999 Mitsubishi Eclipse Spyder GST
    fwd · automatic · 2G DSM
    Loading...
  10. Luke_DSM

    Luke_DSM Probationary Member

    10
    1
    Joined Sep 12, 2019
    Winfield, Alabama
    no melted wires
     

    Street Build 210  6

    1999 Mitsubishi Eclipse Spyder GST
    fwd · automatic · 2G DSM
    Loading...
  11. Luke_DSM

    Luke_DSM Probationary Member

    10
    1
    Joined Sep 12, 2019
    Winfield, Alabama
    i think the guy who owned it before me left the housing but removed the inside
     

    Street Build 210  6

    1999 Mitsubishi Eclipse Spyder GST
    fwd · automatic · 2G DSM
    Loading...
  12. Luke_DSM

    Luke_DSM Probationary Member

    10
    1
    Joined Sep 12, 2019
    Winfield, Alabama
    no melted wires and plugs are fine
     

    Street Build 210  6

    1999 Mitsubishi Eclipse Spyder GST
    fwd · automatic · 2G DSM
    Loading...
  13. Vegas smith

    Vegas smith Proven Member

    2,634
    1,217
    Joined Dec 2, 2002
    Houston, Texas
    Are you saying that when you press the throttle, the wideband goes super rich?
     

    Street Build 3K  10

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
  14. Dusty Landrum

    Dusty Landrum Probationary Member

    24
    12
    Joined Jul 15, 2019
    San Francisco, California
    Mine did this EXACT same thing when I was working on the car and accidentally left the upper intercooler pipe disconnected so the MAF sensor had no idea what was actually entering the engine and same thing, my A/F gauge would go crazy. It would start and idle the same way, but die when I tried to move the car unless I really pushed the accelerator but it ran like crap. Not sure if this helps at all but it seems to be exactly what was happening to me and it was something to do with the MAFS not knowing what is going on.
     

    Street Build 242  3

    1999 Mitsubishi Eclipse GSX
    awd · manual · 2G DSM
    Loading...
  15. Luke_DSM

    Luke_DSM Probationary Member

    10
    1
    Joined Sep 12, 2019
    Winfield, Alabama
    it goes to up and down constantly at crank, steadys out at a normal level, then when i press the gas it shoots up then bottoms out
     

    Street Build 210  6

    1999 Mitsubishi Eclipse Spyder GST
    fwd · automatic · 2G DSM
    Loading...
  16. Luke_DSM

    Luke_DSM Probationary Member

    10
    1
    Joined Sep 12, 2019
    Winfield, Alabama
    will definitely be checking on that tomorrow
     

    Street Build 210  6

    1999 Mitsubishi Eclipse Spyder GST
    fwd · automatic · 2G DSM
    Loading...
  17. Luke_DSM

    Luke_DSM Probationary Member

    10
    1
    Joined Sep 12, 2019
    Winfield, Alabama
    UPDATE - took it to the shop and apparently i had an oil leak that got on my timing belt and caused it to slip... just ironic timing... thanks for the help guys!
     

    Street Build 210  6

    1999 Mitsubishi Eclipse Spyder GST
    fwd · automatic · 2G DSM
    Loading...
    BLACK'98DSM likes this.
  18. Dusty Landrum

    Dusty Landrum Probationary Member

    24
    12
    Joined Jul 15, 2019
    San Francisco, California
    Glad you found out what it was! Also glad nothing seems to have been bent from it slipping timing. I had a gs-t jump timing and bent all the valves as usual.
     

    Street Build 242  3

    1999 Mitsubishi Eclipse GSX
    awd · manual · 2G DSM
    Loading...
    Luke_DSM and BLACK'98DSM like this.

Share This Page

Support Vendors who Support the DSM Community
Archer Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory WheelWell.com