The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Please Support STM Tuned
Please Support VR-Speed Factory

2G Engine sounds done

DSMPT

DSM Wiseman
1,357
900
Jun 12, 2014
Japan / Mexico, Arizona
I did find the flex plate to be loose. Like all the bolts came out half a turn (for convo sake) and the flex plate will wiggle back and forth and hit the bolts (making a metal on metal striking sound)
So the cause of metal contact sound was the flexplate bolts.
Did you inspect the coils, spark plug cables etc etc, too? You don't see any physical damages on those?
 

kidmet

Supporting Member
219
20
Jul 23, 2012
Aurora, Colorado
So the cause of metal contact sound was the flexplate bolts.
Did you inspect the coils, spark plug cables etc etc, too? You don't see any physical damages on those?
Checked coils and spark plug wires. No damage at all. Checked starter, good. All grounds were in good shape.

The noise wasn't the bolts rubbing anything but the flex plate hitting the bolts, or so I hypothesize.
 

DSMPT

DSM Wiseman
1,357
900
Jun 12, 2014
Japan / Mexico, Arizona
Checked coils and spark plug wires. No damage at all. Checked starter, good. All grounds were in good shape.

The noise wasn't the bolts rubbing anything but the flex plate hitting the bolts, or so I hypothesize.
Well yeah I meant the bolts were loose. It's a common issue.
I am really concerned about the sparks on the engine. I hope that is just some sort of camera lens noise.
 

roadsalt

Proven Member
37
10
Sep 11, 2016
Milwaukee, Wisconsin
I’m no expert but it sounds like a blown throw out bearing

upon listening again I’m almost certain

start it and push the clutch in and out and listen to what happens
 
Last edited:

pauleyman

DSM Wiseman
6,462
1,675
Nov 19, 2011
oklahoma city, Oklahoma
I’m no expert but it sounds like a blown throw out bearing

upon listening again I’m almost certain

start it and push the clutch in and out and listen to what happens
Considering this is an auto car (see above) that seems unlikely. :)
 

kidmet

Supporting Member
219
20
Jul 23, 2012
Aurora, Colorado
To close this out as solved. It was the torque converter/flex plate bolts. Will need some thread locker on it. I'll be posting my next issue shortly! Haha. Last one to solve and I'll be super happy.
 

biglady112

Proven Member
1,726
268
May 20, 2004
Commerce City, Colorado
I also tack weld the flex plate bolts now as well. I have seen more than my fair share back out. Not what we like to see at 10,000rpm and 1000hp.
 

biglady112

Proven Member
1,726
268
May 20, 2004
Commerce City, Colorado
I spent 13 hours going through this car today. Among the many issues I found, no offense Sean, this turned out it was both the flex plate and torque converter bolts had come loose. I have it running very well now and will be tuning it tomorrow. I am also putting it on the Dyno on Monday as well.
 

kidmet

Supporting Member
219
20
Jul 23, 2012
Aurora, Colorado
None taken! Thanks for jumping in and saving me! Hahaha


I spent 13 hours going through this car today. Among the many issues I found, no offense Sean, this turned out it was both the flex plate and torque converter bolts had come loose. I have it running very well now and will be tuning it tomorrow. I am also putting it on the Dyno on Monday as well.
 

DSMPT

DSM Wiseman
1,357
900
Jun 12, 2014
Japan / Mexico, Arizona
I spent 13 hours going through this car today. Among the many issues I found, no offense Sean, this turned out it was both the flex plate and torque converter bolts had come loose. I have it running very well now and will be tuning it tomorrow. I am also putting it on the Dyno on Monday as well.
Well as you see he has clearly stated that it's solved above, so I still can't get this situation. But if it runs well now, that's a good news anyways.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com OHM Racing Raven Fabrication RixRacing RockAuto RTM Racing SouthBay Fuel Injectors STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top