The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support Rix Racing
Please Support STM Tuned

1992 Talon TSI 6/4 AUTO

rabenne

Proven Member
1,712
678
Apr 21, 2006
Racine, Wisconsin
All good just never seen that issue before. Test it at the outlet?

You could observe bov behavior if nothing else. My crushed 1g BOV would start opening at 25-27 psi. That's when I went to a turbosmart with easily adjustable spring preload. You could shim the spring in your tial, or use a stiffer spring, if its creeping open too early.
 

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
I am going to swap the TIAL BOV and UICP on next. I have never had a issue using just the top hat port but I am puzzled. I also have never had any problems with a 1g BOV and I have tried more than one and didn't notice any difference but I will get that TIAL unit on.
 

rabenne

Proven Member
1,712
678
Apr 21, 2006
Racine, Wisconsin
Are you saying you only use the top port on the wastegate?
How would that work? any pressure to the top holds the valve closed. I am confused how that would work.... I have run only the bottom port, but never the top only.

Here is how Tial says to route hoses: (am I still just confused? top only sure does not seem right)
You must be logged in to view this image or video.
 

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
Yep that's what I did on the red car and the TAIL 38mm. It worked fine with a bleeder valve for upping the boost from gate pressure. I guess that's why I plumbed the blue car that way to start with. I have some other gremlin tho, just haven't found it yet. On the red cars gate, I didn't have a ton of springs in it so I would bleed off any boost source to get the boost I wanted. I even had the control mounted under the dash where it sits today. May not have been right, but it sure worked good.
Here is a log from the Red Car a couple years ago on E.
 

Attachments

  • log.2017.04.17-04.elg
    303.8 KB · Views: 72

rabenne

Proven Member
1,712
678
Apr 21, 2006
Racine, Wisconsin
Okay if you were running the top only, you were holding it closed with boost and letting pressure bleed off to limit boost. That means the only driving force to open the wastegate valve is the backpressure caused by your turbine. While that may work out, entirely coincidentally, it is not correct. I think you got pretty lucky getting it to work that way.

Sounds like improper hose routing is your issue sir.

it could work on one setup and not another because the turbine drive pressure versus boost pressure changes with the setup....
 

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
Well, I pulled the line off Will and I got it to go up a pound or 2. But theres something up if I can run NO BOOST SOURCE and run only 35lbs. Hell I always ran boost to the top hat to hold it closed then bled it to make more boost. Maybe that wasn't right but it worked on the Red stick car. I tried bottom ports both ports and finally FULL SEND. It must be something with the gate in my opinion.
Thanks for asking because she wants 40 lbs of whup ass. :sneaky:
 

ThunderChild

Supporting VIP
3,762
1,121
Jan 5, 2012
Rathdrum, Idaho
Marty, it'd take some rigging, but might try building a bench test rig for the wg? It's unlikely it's opening, but that's the only thing I can think to do.

Also, anyone not a fan of piston type BOVs? I run the synapse synchronic bov, and have pulled it to bench test once, and it held 40psi (I'm still baby-turbo so no need to test higher) where as I couldn't get a 1g or greddy to hold more than 30. Just a question :idontknow:
 

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
Well Henry, it could be the BOV and I have a TIAL BOV that could go right on so that is a test I could do. I have tried several different 1g BOVs, crushed, even one off my other high boost car. Didn't SEEM to change but I could swap out the whole UICP with the TIAL on it and test again. Easier than taking the super spring WG off and trying to get it back on.
Its only 40 today but the car is in the shop (hiding from the romp with the NOS 'vette last week, we were on the popo scanner) so I could tackle that first.
I appreciate you guys and any tips you have besides a new $500 gate OMG (but I am open to that too).
Marty
 

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
Had a little fun running this in the Talon. I don't know if it will help me enough but it should.
The bad news, the new NOS valve is LEAKING ever so slightly so I'm thankful that we tested first. The purge, well I just had to do it for shits and "giggles"!!! ROFL
Thanks for following along on the journey.
Tuning has just started and I hope we can make some jam! :thumb:
Marty
You must be logged in to view this image or video.
 

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
Making a template for the old Pwr/Eco switch spot so the Arming switch will go in its place.
Letting the paint dry on it and then I will see how to hold it in.
More to come!
You must be logged in to view this image or video.
 

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
Good place for a remote bottle opener!!!
Just for those who get a kick out of switches and gadgets, when the Arm switch is OFF, my pushbutton on my steering wheel operates my EBC to hold it open for MAX boost if needed. Also made the Arm switch kind of failsafe so if you reach forward, you turn it off like in an emergency.
Just fun shit for me though!
:thumb:
Pictures, I promise, to come. Everyone loves pictures!
 

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
Just came from the speed shop a hr away to get a new NOS solenoid. Gonna see how it all works out but high hopes!
Big Thanks to Grand Prix Auto Sports Center in Tulsa OK for having what I needed on the shelf!
You must be logged in to view this image or video.
 

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
Semi installed Arming switch. Going to mount an LED somewhere to let me know POWER is on just in case I forget.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
 

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
What did I make the plate cover out of????
This....ROFL :shhh:

You must be logged in to view this image or video.
 

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
You must be logged in to view this image or video.
Ok, the EBC and Purge didn't like playing with each other so now I have a dedicated Purge button and left room for a bottle opener if I decide to put one in.
Maybe a SMALL NOS guage???
IDK but I left room for other "gizmos and gadgets" just in case.
Thanks @TK's9d2TSi for expanding my mind, that coin holder never got used!!!! :thumb:
Hope it isn't disappointing!
I will post more pics when it is all wired and operational. Maybe today, blistering hot outside tho.
Let me know how bad I fkd this up!
"Pops" :) :p
 

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
Video is better than pictures so here we go.....the NOS panel in operation.
Cost...about $20. :shhh:
You must be logged in to view this image or video.
 
Last edited:

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
Had a little fun repairing an old toy I got the boys along time ago so just sharing why my signature says "still PLAYS with blocks" for my grandson who is 4. Never to young and he LOVES to help put a wrench on anything! :D Had to share. Video wouldn't load for some reason.
It still functions but its out of time. CAS is adjustable LOL.
You must be logged in to view this image or video.
 

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
Got the video up on MY site, I'm still a kid at heart, (not body)! ;)

You must be logged in to view this image or video.
 

1990TSIAWDTALON

Moderator
8,458
4,344
Nov 14, 2013
Independence, Kansas
Fresh batteries, good to go :thumb::thumb::thumb:
I think its low on oil tho........OMG
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com Raven Fabrication RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top