The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Please Support VR Speed Factory
Please Support STM Tuned

fuel cut / detonation? at 5500 rpm and up

boosthead

Proven Member
37
0
Dec 13, 2009
greenfield, Wisconsin
Hey everyone im new to the forum, i just picked up my first dsm!
its a 90 tsi awd

anyways, ive been driving it around and in all gears besided 1st, when reaching 5500 rpm under boost, it feels like it all of a sudden looses power/jerks a bit.
otherwise 1st gear feels fine.

it has a 3 inch o2 housing back, test pipe
turbo xs mbc set at lowest setting
and hks ssqv bov, vented(this might be the problem)

thanks in advance
jon
 

kimcheefists

Proven Member
337
3
Nov 7, 2008
Las Vegas, Nevada
First thing I'm going to say is check for boost leaks. If that checks out, take a look at your spark plugs and boot. Do you have a CEL?
 

viperlp01

Proven Member
2,525
70
Oct 9, 2006
Kalamazoo, Michigan
Well 5500 is the sudden peak in the timing curve of the 1g ecu... Are you running premium gas??? Check for boost leaks and try to get that BOV recirced.. What boost level are you at? You say the lowest setting.. Are you sure you understand how a MBC works.. The looser the screw the less tension on the spring which will lower the boost. the tighter the screw the more boost...
 

boosthead

Proven Member
37
0
Dec 13, 2009
greenfield, Wisconsin
ok guys thanks for the help

no cels pop up, so idk if thats good thing or bad thing

my mbc is set all the way negative?

ill check for boost leaks and havent filled it up since i got it
so i will put premium in it

ill also look at the spark plugs and boot and wires

thanks
jon

and another thing i just went out and cranked the mbc the opposite way and the car started doing the same thing at 4000 rpm in all gears
hope that helps
 

kimcheefists

Proven Member
337
3
Nov 7, 2008
Las Vegas, Nevada
and another thing i just went out and cranked the mbc the opposite way and the car started doing the same thing at 4000 rpm in all gears

Try hooking up the vacuum hose from your wastegate actuator directly to your compressor housing with the MBC out of the car. If your car stops jerking then it could be a faulty MBC. However, I highly doubt it's the MBC that's causing this. You're probably getting multiple misfires. Just check for boost leaks and spark plugs/boots and let us know.

Here's a picture of what I mean by hooking up the hose directly from the wastegate actuator to your compressor housing.
 

Attachments

  • Turbo.jpg
    Turbo.jpg
    5.4 KB · Views: 167

boosthead

Proven Member
37
0
Dec 13, 2009
greenfield, Wisconsin
Try hooking up the vacuum hose from your wastegate actuator directly to your compressor housing with the MBC out of the car. If your car stops jerking then it could be a faulty MBC. However, I highly doubt it's the MBC that's causing this. You're probably getting multiple misfires. Just check for boost leaks and spark plugs/boots and let us know.


OK im going to go out and try that

and also it doesn't seem to me that the waste gate is actuating? when u rev in under the hood, should u be able to see the waste gate arm move? because its not

premium fuel didnt seem to help either

oh and another thing, with a mbc hooked up, are you supposed to just let the boost solenoid just sitting there or what?
 

wht 92 talon

Proven Member
77
0
Nov 6, 2008
Huron, Ohio
im having the same exact problem with my 91 tsi. and now its left me stuck again driving my 84 blazer mud truck as a dd :/ if you find out the prob let me know. and i have already tried taking my boost controller off and hooking just a vaccume line from waste gate to the compressor housing, and it didnt work.... well atleast for me. but i think i may just be running rich with a walbro 255 and stock injectors and stock fpr? i do have a vented bov if that makes a difference?
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com OHM Racing Raven Fabrication RixRacing RockAuto RTM Racing SouthBay Fuel Injectors STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top