The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support JNZ Tuning
Please Support ExtremePSI

New to me: 98 GS Spyder (4G64 Manual) Clutch no-start sensor? (and more)

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

MikeAutomotiveMayhem

Probationary Member
4
2
Jan 25, 2024
Richmond, BC_Canada
Hey Guys, Its January 25th, 2024. And yesterday I have fulfilled a childhood dream of buying a 2G eclipse.
Info about me and the car:
-I am in Vancouver BC, Canada
-The car is a 1998 Mitsubishi Eclipse GS Spyder
-4G64/5 Speed Manual
-Stock Car with no mods aside from an aftermarket radio and wheels from a 4g Eclipse
-152,xxx Miles (was imported from USA I suppose?)
-I am new to these cars aswell as tuner culture as I have usually only had American or English cars (Cadillac, Jaguar, Dodge, Land Rover)
-I am 23 yo so fairly new to car things as a whole, and this is why I am seeking info from the pros!!
___________________________________________________________________________________________________________________

Issues that I have so far discovered and am looking for help/tips on (In Priority Order)
-I think the clutch-start sensor is bad, I have to push the clutch in AS HARD AS I CAN to get the car to crank and start.

-The top Works perfectly and looks newer! But it does leak right at the windshield corners where the tops meets the body. I understand this could be way worse as some tops leak through?

-The car only warms up to the middle of the temperature Gauge when idling and not moving, Thermostat most likely I assume?

-My airbag light is on, and the previous owner said that it is because my passenger side airbag dash cover pad is warped badly, that this has tripped that sensor. Is that true?

-My door handles are both black plastic like they have been replaced. and I can only unlock and enter the car from the passenger side. (Yes, I know that I just need to replace them again. But maybe yall have some tips?).

___________________________________________________________________________________________________________________

Other Very minor Issues;

-Rear Defrost Doesnt Work

-Driver side foglight doesnt work

-Crack on the very lowermost part of the front bumper aswell as a mediocre dent on the right hand side fender

-Trim by the front wheel wells right before the doors on both sides seems a little wonky, driver side (LHD) door clips on the fender when opening/closing the door

-Headlight assemblies are dull and clouded, (would replacements from rockauto be good? orrr?)

-Passenger side interior door trim (the Plastic piece where the window switches and pull handle are) is very loose and cracked. (Cant wait to start looking for a replacement on that!)

-I Got 2 basic Keys with the car, both just simple metal and not what I would assume to be original... Did these come with key fobs?

-Ebrake works well, but seems very easy to engage, is this normal?

___________________________________________________________________________________________________________


I am not looking or even expecting an answer to most of these things!!! But I figured one GOOD introduction post might be better in alot of ways.
Any helps or insight is greatly appreciated. I have always LOVED these cars and I would really love to bring mine back to its former glory and learn more about them!

You can also add me on Instagram @Mikes_Autmotive_Mayhem where I will be posting about this car and the progress as we continue on!!


Thank you in advance,


Mike

You must be logged in to view this image or video.


You must be logged in to view this image or video.


You must be logged in to view this image or video.


You must be logged in to view this image or video.


You must be logged in to view this image or video.
 
Your clutch pedal position switch is probably adjusted wrong. It's above the pedal and activated when in full down position.

The temp gauge normally only goes to the middle. However if you're not getting cabin heat put cardboard in front of 1/2-3/4 of the radiator during cold months. Standard trick we do in Minnesota.

Just a thought but occasionally my red airbag wiring connector doesn't make good contact and I see this problem. Try unplugging it and re-plugging it.
 
Hey There! Thank you for the reply!

I have since had the car driver side (LHD) lower control arm/balljoint give up while driving even though it was brand new, (caused minimal damage but still did mess with my fender/cladding) I had it towed to a shop where I got Both inner and outer tie rods, Ball joints/LWR control arms, aswell as the axle shaft replaced. YAY SO CHEAP AND FUN *not*. I also got them to fix my driver exterior door handle and they will be replacing my clutch pedal bushings in a week once parts arrive to hopefully solve the clutch start issue.

Otherwise now I am in desperate search for OEM style front fender cladding piece!! (LHD driver side) but the car has been driving good at least since then LOL!

Though the rest of the issues I mentioned still remain!

You must be logged in to view this image or video.


You must be logged in to view this image or video.


You must be logged in to view this image or video.
 
Last edited:
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top