1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Electrical Issues please help!

Posted by dxxparsell, Jun 9, 2011

Please Support ExtremePSI
Please Support ExtremePSI
  1. blkgst97

    blkgst97 Proven Member

    273
    10
    Joined Aug 4, 2009
    Bonney Lake, Washington
    Palmetto you are my hero! I have had my dash lights on ever since I got my car, I could not figure it out. After testing and changing out batteries and alternators the problem never went away I couldn't figure it out. I never knew about that "relay" and it turns out there was a messed connection inside. No more dash lights!:D
     

    2K  0

    1997 Mitsubishi Eclipse GST
    manual · 2G DSM
    Loading...
  2. josh38127

    josh38127 Proven Member

    152
    1
    Joined Oct 2, 2009
    Memphis, Tennessee
    Your problem sounds like the same problem I had with a talon a while back. It turned out there was a problem with the wire that feed power the fuse block under the dash.You can check for power by finding the white in the top left corner of interior fuse block. It will be on the back of the block you might have to unbolt it from the dash. I put some pics up try to explain the location of the wire you need to find. But from what I have read I think is the problem.
     

    Attached Files:

  3. dxxparsell

    dxxparsell Proven Member

    58
    0
    Joined Apr 30, 2011
    Akron, Ohio
    Nice man Im going to try thiz right when I get my fuel filter done! and if anyone can find out this "relay under my intake" or a picture it will be greatly appreciated!
     
  4. blkgst97

    blkgst97 Proven Member

    273
    10
    Joined Aug 4, 2009
    Bonney Lake, Washington

    2K  0

    1997 Mitsubishi Eclipse GST
    manual · 2G DSM
    Loading...
  5. dxxparsell

    dxxparsell Proven Member

    58
    0
    Joined Apr 30, 2011
    Akron, Ohio
    Not sure what the boostcyl looks like either, Im still learning these things :(
     
  6. blkgst97

    blkgst97 Proven Member

    273
    10
    Joined Aug 4, 2009
    Bonney Lake, Washington

    2K  0

    1997 Mitsubishi Eclipse GST
    manual · 2G DSM
    Loading...
  7. dxxparsell

    dxxparsell Proven Member

    58
    0
    Joined Apr 30, 2011
    Akron, Ohio
    See I even looked at it yesterday LOL, didnt know what it was, Ill go look now, but what exactly should I look for on it? or just buy a new one?
     
  8. blkgst97

    blkgst97 Proven Member

    273
    10
    Joined Aug 4, 2009
    Bonney Lake, Washington
    I guess just make sure it has a good, clean connection. I took mine apart and saw that inside there was a missing connection. Dont know how it happened but it has been that way for the past six years I have owned this car until yesterday.
     

    2K  0

    1997 Mitsubishi Eclipse GST
    manual · 2G DSM
    Loading...
  9. dxxparsell

    dxxparsell Proven Member

    58
    0
    Joined Apr 30, 2011
    Akron, Ohio
    So it should be on the passenger side fender? like under the fuse box
     
  10. Palmetto_TSi

    Palmetto_TSi Supporting VIP

    181
    5
    Joined May 6, 2011
    Anderson, South Carolina
    yes, it is near the fuse box, but a little toward the front of the car. Probably about 3 inches below and forward of the box
     

    436  0

    1993 Eagle Talon TSi AWD
    · 1G DSM
    Loading...
  11. dxxparsell

    dxxparsell Proven Member

    58
    0
    Joined Apr 30, 2011
    Akron, Ohio
    Alright ill def check this out here shortly when it cools off alittle
     
  12. rvaughn

    rvaughn Proven Member

    164
    23
    Joined Apr 29, 2008
    Portland, Oregon
    Did you ever verify that the fuseable links are all good? I had a similar issue and it turned out to be one of my fuseable links. I would really suggest purchasing replacements and trying them, my issues were very similar to your own and I was sure I would never find it! Good luck!
     
  13. Palmetto_TSi

    Palmetto_TSi Supporting VIP

    181
    5
    Joined May 6, 2011
    Anderson, South Carolina
    yeah, he said he checked them all, that's why I kept digging. I don't know what method he used though. I know sometimes a visual check will not be enough on some of these things.
     

    436  0

    1993 Eagle Talon TSi AWD
    · 1G DSM
    Loading...
  14. dxxparsell

    dxxparsell Proven Member

    58
    0
    Joined Apr 30, 2011
    Akron, Ohio
    I checked well my buddys dad checked with a fancy meter that got grounded from the battery and stuff
     
  15. Palmetto_TSi

    Palmetto_TSi Supporting VIP

    181
    5
    Joined May 6, 2011
    Anderson, South Carolina
    that's what I was hoping. It would suck to find out that we were chasing our tails... LOL
     

    436  0

    1993 Eagle Talon TSi AWD
    · 1G DSM
    Loading...
  16. dxxparsell

    dxxparsell Proven Member

    58
    0
    Joined Apr 30, 2011
    Akron, Ohio
    Well Im takling my electrical stuff tomorrow. I found out my fuel filter was a pain in the rear, and purple power fouls out plugs to make you think its a fuel issue...
     
  17. Palmetto_TSi

    Palmetto_TSi Supporting VIP

    181
    5
    Joined May 6, 2011
    Anderson, South Carolina
    LOL!!!! Why is there Purple Power on your plugs?
     

    436  0

    1993 Eagle Talon TSi AWD
    · 1G DSM
    Loading...
  18. dxxparsell

    dxxparsell Proven Member

    58
    0
    Joined Apr 30, 2011
    Akron, Ohio
    Let a buddy detail my engine cmpt. and He went alittle overboard I guess
     
  19. H4G64T

    H4G64T Proven Member

    715
    9
    Joined Jul 18, 2008
    Providence, Rhode Island
    This entire thread was filled with advice, but since some things you needed to hear aren't allowed, then none of this information is needed.
     
    Last edited: Jul 22, 2011
  20. dxxparsell

    dxxparsell Proven Member

    58
    0
    Joined Apr 30, 2011
    Akron, Ohio
    Not sure what your saying here>?
     
  21. H4G64T

    H4G64T Proven Member

    715
    9
    Joined Jul 18, 2008
    Providence, Rhode Island
    Don't worry about it. I am not interesting helping you anymore. Good luck.
     
  22. dxxparsell

    dxxparsell Proven Member

    58
    0
    Joined Apr 30, 2011
    Akron, Ohio
    Well I pulled the sensor today, and it was bad one of the prongs was corroded off of it, I got a new one from pullapart, well a used one that has already been opened and slopped some sealer onto it.... and the new one didnt change anything so I think Im going to be ordering a new one tomorrow, any ideas what would be the fastest or easiest place?
     
  23. GSX401

    GSX401 Proven Member

    92
    4
    Joined Jun 5, 2011
    Cranston, Rhode Island
    Have you even tested the power window and seat relay?
     
  24. dxxparsell

    dxxparsell Proven Member

    58
    0
    Joined Apr 30, 2011
    Akron, Ohio
    Yes but its not just that thats not working
     
  25. GSX401

    GSX401 Proven Member

    92
    4
    Joined Jun 5, 2011
    Cranston, Rhode Island
    Okay, but no one said these issues were related, nor should you make the mistake in thinking they are. Did you have power going to the relay? The wire that provides power should be red and white.
     

Share This Page

Support Vendors who Support the DSM Community
ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory