The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support Rix Racing
Please Support ExtremePSI

Coolant temp sensor

98bluegsx

Proven Member
60
4
Feb 24, 2018
Kutztown, Pennsylvania
Hey have a question. I have a car that I have that will not start after a new build. Starts but shuts off. I aaa curious on if the coolant temp sensor will do this or if any other sensors will besides cps and cas. The car has no coolant in it which is why I ask. Any help or information is greatly appreciated!
 

609DSM

Proven Member
374
151
Aug 13, 2019
Langhorne, Pennsylvania
Not very familiar with the 4g63 platform but from my experience with the 420a engine if your coolant temp sensor is disconnected or faulty you will experience a hard time starting or rough starting.

I would assume it is similar with the 4g63, as a safety if it doesnt sense a connection it wont let the driver start the car because it can quickly overheat with no coolant. Just my .02
 

Lucky13

Supporting Member
159
46
Nov 20, 2002
Palm Beach Gard, Florida
When I was fighting frayed wiring to my coolant temp sensor it would read something like -130 in Link and would not stay running.
 

Vegas Smith

Proven Member
4,451
2,271
Dec 2, 2002
Houston, Texas
Okay sweet thanks did the info. Does it need to sense the coolant for it to run or will it be able to sense air temperature?
Hmm, I don't know the answer but I doubt it's helping. Do you have ecmlink by chance? When your cts goes bad, it reads a really low temperature as mentioned above^ and makes you run incredibly rich.
 

steve

DSM Wiseman
13,750
840
Feb 3, 2002
Boulder, Colorado
Okay sweet thanks did the info. Does it need to sense the coolant for it to run or will it be able to sense air temperature?

On a cold engine it senses ambient but that's what the the housing, air and coolant are at. I assume that in free air it would still measure ambient but the quick answer is log yours and see what it's reading.
 

93xsg

Proven Member
175
24
Jul 3, 2011
Sequim, Washington
My 1g wouldn't start one time because the coolant temp sensor had popped off.

OHM Racing sells the replacement plug with wire pigtail. I got from their ebay store for fast shipping along with a few other damaged connectors.
 

jpmxrider489

Supporting VIP
2,238
57
Apr 4, 2010
pittsburgh, Pennsylvania
Is there a reason that there is no coolant in the care. With my sensor disconnected I read -74. But yes it could cause it not to start and run. Your Tps sensor could also make it hard if its unplug.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com OHM Racing Raven Fabrication RixRacing RockAuto RTM Racing SouthBay Fuel Injectors STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top