The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support Feal Suspension
Please Support ExtremePSI

1G Chirping noise only at 3k rpms

TK's9d2TSi

Supporting Member
4,719
2,000
Sep 11, 2017
Cincinnati, Ohio
Hey guys! I have developed a chirping noise that I think is coming from the head and it only happens between about 2.5k to 3k. Thought it was a belt or a pulley but I’m pretty sure it’s in the head. It’s pointless to post a video/audio but you can imagine just a constant chirp between those rpms. I took the valve cover off and don’t see anything that sticks out. Head does have kiggly hla, k272 and Manley singles. Any thought what it could be?

Thanks Tony!

You must be logged in to view this image or video.
 

TK's9d2TSi

Supporting Member
4,719
2,000
Sep 11, 2017
Cincinnati, Ohio
Now that I have the upper timing cover, it sounds like it’s from the timing side. I think the noise is there at idle but really low and not sure if you’ll be able to hear it in the video. I’ll have to pull the cover off again. Ughhhh!!
You must be logged in to view this image or video.
 

Vegas Smith

Proven Member
4,443
2,262
Dec 2, 2002
Houston, Texas
Boy, those are tough noises to track down. I've had noises come from rubbing my timing cover and from my crank pulley separating. Your particular noise doesn't ring a bell though.
 

TK's9d2TSi

Supporting Member
4,719
2,000
Sep 11, 2017
Cincinnati, Ohio
Boy, those are tough noises to track down. I've had noises come from rubbing my timing cover and from my crank pulley separating. Your particular noise doesn't ring a bell though.
Yeah I know. Hopefully it’s just a bearing for one of the pulley. I’ll tear into it this week. Thanks Nick!
 

talonman1200

Supporting Member
15
5
Mar 23, 2018
Potterville, Michigan
Two possible issues pop into my head listening to your video. Hard to place and just a question but are spark plugs tight? Hopefully you can track it down. Good luck man
 

TK's9d2TSi

Supporting Member
4,719
2,000
Sep 11, 2017
Cincinnati, Ohio
Two possible issues pop into my head listening to your video. Hard to place and just a question but are spark plugs tight? Hopefully you can track it down. Good luck man
Hmm never heard what a loose plug sounds like but yeah I torque nazi so plugs are tight.
The noise that becomes more obvious at 8-10 second in the video? If so, it doesn't sound like it comes from the valve train components. It sounds more like some bolt is loose and vibrating.
Yup. When the cover was on, it sounded louder towards the intake manifold. With the upper cover off, it clearly on the front side. I’ll have to tear into it. Literally sounds like a chirping bird LOL
 

TK's9d2TSi

Supporting Member
4,719
2,000
Sep 11, 2017
Cincinnati, Ohio
Think I got it. The ac tensioner pulley was rubbing on the cover so took an exacto to it. Anyone know why all the 6 bolt covers gets chewed up by that pulley? Seems like every used one I see is like that. All the bolts for the cover are there

You must be logged in to view this image or video.
 

DSMPT

DSM Wiseman
1,398
934
Jun 12, 2014
Japan / Mexico, Arizona
Think I got it. The ac tensioner pulley was rubbing on the cover so took an exacto to it. Anyone know why all the 6 bolt covers gets chewed up by that pulley? Seems like every used one I see is like that. All the bolts for the cover are there

You must be logged in to view this image or video.
I don't know the exact cause of that, my guess would be by time or heat, or once it contacts with pulley or belt, the cover gets warped.
What I had done is loosen the cover's bolts (not removing) and push where the Interference occurred, and tighten all the bolts back. Sometimes it helped me to have some more clearance.
 

TK's9d2TSi

Supporting Member
4,719
2,000
Sep 11, 2017
Cincinnati, Ohio
I don't know the exact cause of that, my guess would be by time or heat, or once it contacts with pulley or belt, the cover gets warped.
What I had done is loosen the cover's bolts (not removing) and push where the Interference occurred, and tighten all the bolts back. Sometimes it helped me to have some more clearance.
You’re probably right. I have tried pushing the aluminum bracket back when I assembled it. Guess that wasn’t enough.

Thanks all!!
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com OHM Racing Raven Fabrication RixRacing RockAuto RTM Racing SouthBay Fuel Injectors STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top