The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support Fuel Injector Clinic
Please Support Rix Racing

Starting issues.. Help!

94_eclipse

Proven Member
153
1
Jan 19, 2007
Shelocta, Pennsylvania
Hey guys, im having starting problems with my car. It only happens about once a week. It will crank, fire, then die and will not start again unless i take off the battery terminal, put it back on and then use jumper cables. It will crank over fine but it just wont fire. I dont understand why it only does this once in a blue moon but its a pain. Im thinking that my computer mite be going out in it.. Would that make sence? Any advice would be great. Thanks
 

94_eclipse

Proven Member
153
1
Jan 19, 2007
Shelocta, Pennsylvania
Since this post, it did the same thing to me 3 times. I tried starting it with just getting a jump from a friends truck and no luck. Once i pulled the positve terminal off of the battery, waited a few min, then put it back on and it fired up.
 

untouchablecc

Proven Member
852
12
Mar 21, 2008
Mt. pleasant, Pennsylvania
Try pulling your ecu out an check for burn marks an a fishy smell. The capacitors might be leaking. Also cam sensor could be an issue. Have you checked the regular stuff making sure your battery is fully charger holding charge an alternator is charging. I know its little stuff but can sometimes be an issue. Also loose wiring is always a culprit. Coil packs an power transistors can sometimes be an issue with starting as well.
 

94_eclipse

Proven Member
153
1
Jan 19, 2007
Shelocta, Pennsylvania
Yeah i checked my battery charge and its fine, its charging at 14 volts and dosnt loose charge. I checked all of my wireing and its ok. The only thing i havnt looked at is the ecu. How much of a pain in the @$$ is it to pull?
 

untouchablecc

Proven Member
852
12
Mar 21, 2008
Mt. pleasant, Pennsylvania
Ecu is a cake walk dude. You pull off the gray panel on the passenger side theres like 4 screws that hold it in i think an three wire clips i believe to take off. There are a few screws on the case of the ecu itself pop em off an inspect it carefully its easy to overlook a burn mark but the smell should be distinct. If you cant smell anything its prob okay but sometimes they caps still leak.
 

untouchablecc

Proven Member
852
12
Mar 21, 2008
Mt. pleasant, Pennsylvania
Also incase you didnt know if you put a new cam sensor on you have to do the ignition timing with a timing light but its easy.
 

94_eclipse

Proven Member
153
1
Jan 19, 2007
Shelocta, Pennsylvania
ok sounds good. Ill give that a try when i go home this weekend. Im goin to college so thats why i want to get this fixed. I cant be drivin around and then not bein able to start it. Thanks
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Latest Classifieds

Top