The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support RTM Racing
Please Support Morrison Fabrication

1G losing power to ecu?

ShayneZ

Supporting VIP
14
1
Jun 27, 2018
Lincoln, Nebraska
I'm thinking my car's ecu is shutting off because at mid pull ( around 6600 rpm) it will stop logging on ecm link and it will cut spark for sure, maybe fuel and other things controlled by the ecu too, if it is the ecu. after this happens it will run very lean around 17 afr until I'm able to pull over and shut it off, wait 10 seconds and its ready to go again until I try to do a pull.

I have tried adding 2 grounds to the ecu thinking it might have something to do with that and the fact that it blows out spark gave me that idea. just wondering if anyone has ever ran into this problem thanks for taking the time to help guys!
 

ThunderChild

Supporting VIP
3,760
1,124
Jan 5, 2012
Rathdrum, Idaho
Never had that happen, how old is the ECU, or when was the last time it was serviced / looked at?

Also, does ecmlink actually disconnect from the ECU, or just stop the log?
 
Last edited:

ShayneZ

Supporting VIP
14
1
Jun 27, 2018
Lincoln, Nebraska
Welp the ECU has been to ECMLink and back in the most recent 3 years, so I assume it OK. Seems to only lose power after high boost and spark cannot keep up with fuel/air mix? Wonder if ECU is telling car to "Shut down power" somehow at that point?? Also you need to let it sit for bit before it will fireup and goes super lean for a few seconds after restart and idle?

Also ECMlink loses connection at that point so no log.
 
Last edited:
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top