The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support Rix Racing
Please Support Fuel Injector Clinic

Engine Wont Start Need Help!!

97GSX88

Probationary Member
15
0
Nov 26, 2005
Berwyn, Pennsylvania
I need help with my engine. For the past 45 mintues I have been trying everything I know to get it started and it just wont start. YEsterday I cranked it over and it started but it was all over the place on idle and unstable idle; it would end up killing itself in about 5-8 seconds. Now when I try and start it I its all the starter turning the engine over it will not fire. I have spark, I have compression and I have fuel. My o2 voltage at the front is reading 0.04v and I just put a brand new o2 sensor in. Unless that is always what it reads when the engine is not started or crnaking. I have a pocket logger so I can get other information for you guys neeed it to help me out but I have no idea. I think it is a fuel issue but I cannot fix it. I pulled a plug and it was drenched in fuel so obviously I thought way too much fuel I leaned it out but still nothing. I have a MAFT and SAFC that are both set now at 0% the whole way through right now. If you guys would like a list of my mods I can get my mod list. Somebody please help me out. I have been searching on this fourm for the past 5 hours and havent gotten anything so I figured I would make a post about it. Any help at all would be greatly appreciated!!


Chris
 

v2ner

Probationary Member
791
10
Feb 25, 2004
Madison, Wisconsin
Try starting it with the injectors unplugged to get the extra fuel out a couple of times. Then, plug em back and try to start it regularly.
 

97GSX88

Probationary Member
15
0
Nov 26, 2005
Berwyn, Pennsylvania
I have done that by accident. Right now I have the plugs pulled and letting the cylinder and plugs air out some.
 

GST with PSI

DSM Wiseman
2,672
1,379
Jul 27, 2005
San Diego, California
what is your BARO reading on the logger with the key on engine off? The reading should be steady AKA a straight green line when graphing. When you first key up the car should take one reading and keep that until the ignition is turned off and the car restarted. If you have some fluctuation you may have a bad ECU.
 

97GSX88

Probationary Member
15
0
Nov 26, 2005
Berwyn, Pennsylvania
I do not have a BARO reading I can select, or is it just called a different name?
 

DGK215

Probationary Member
66
0
Jan 20, 2006
Camden, New_Jersey
Check yuor coolant temp sensor. I had a very similiar issue and thats what it ended up being. Especially if your in PA, the colder it is, the longer it will take to start.
 

97GSX88

Probationary Member
15
0
Nov 26, 2005
Berwyn, Pennsylvania
The sensor according to the pocket logger is reading 50 Deg F.

What do you mean that ended up being it? As in I need a new sensor or that it is just very cold and I need to heat up the engine some?
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com OHM Racing Raven Fabrication RixRacing RockAuto RTM Racing SouthBay Fuel Injectors STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top