The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support STM Tuned
Please Support ExtremePSI

97 eclipse

TK's9d2TSi

Supporting Member
6,262
3,252
Sep 11, 2017
Cincinnati, Ohio
Yeah. He has a couple of videos doing the swap on his brothers car. I know, weird that fwd and awd is different but it’s not difficult. If you do need help w that part, I’ll drive over to help LOL
 

JeffGS-T97

Supporting Member
1,002
692
Mar 22, 2019
Muncie, Indiana
Yeah. He has a couple of videos doing the swap on his brothers car. I know, weird that fwd and awd is different but it’s not difficult. If you do need help w that part, I’ll drive over to help LOL
Thanks Tony that means a lot man. It might take some time to get started on, still got this turbo issue to sort through. I need to get it out and pull that huge wastegate out of there, see if that thing is stuck open because the turbo is still spooling it just can't maintain pressure and i think its because it's escaping at the wastegate. Could be a bad diaphragm or carbon build up holding it open. I've ran it pig rich quite a bit trying to sort other issues. Ive fouled two sets of plugs so far. It's probably why my AFR is going nuts too since the exhaust could be pouring out of the wastegate before the 02 housing. The front side of the exhaust is really loud. Since i dont have leaks on the mani, the t4 flange, and o2 housing i think its safe to say a bunch of exhaust gases and pressure is eacaping down and out the wastegate dump pipe. I should be able to pull it in the next couple days and see what needs to be done.
 

JeffGS-T97

Supporting Member
1,002
692
Mar 22, 2019
Muncie, Indiana
Sorry I was headed out to work when I posted about the YouTube videos, so I couldn’t look for them for you.

Here’s a link to the 8 part series, he uploaded the first video a year ago.

JD AWD Swap Videos
Awesome, i got alot of days off so this is the perfect time to check these out, thank you!
 

JeffGS-T97

Supporting Member
1,002
692
Mar 22, 2019
Muncie, Indiana
So I did some more digging on my turbo and found out i mislabeled my turbo type. I have corrected my engine info. This turbo is a big T28, now i just have to figure out the brand i just don't any identification labels anywhere. From what i have found a plus size t28 maxes around 500hp. Still haven't removed the turbo been getting the holiday lazies LOL
 

JeffGS-T97

Supporting Member
1,002
692
Mar 22, 2019
Muncie, Indiana
Bolt on t28 for the 2g is the FP big t28.
Forced performance big t28. I was gonna post the link but maybe they don't sell them anymore. ???
Did it have a 90° bend to the left right after the impeller? This turbo also has a 3"OD impeller inlet, then to a short down then 90° toward passanger side 2" outlet to first IC pipe. The 90 is really close to the engine cradle wheel.
The wastegate is in a weird spot too. Its massive and bolts directly to the bottom of the hot side and points down. Its an antique HKS WG NON recirculated and has a long exhaust dump tube attached to the base. I think it works rather well, i really don't get much boost spike at WOT.
 
Last edited:

Bud92gsx

Welcome Wagon
22,849
281
Jan 16, 2008
Wisconsin, Wisconsin
The turbo question is more for a guy like Justin. But on the turbine housing it should be stamped FP

It does look similar to the stock t25 compressor housing, because its bolt on.
 

JeffGS-T97

Supporting Member
1,002
692
Mar 22, 2019
Muncie, Indiana
The turbo question is more for a guy like Justin. But on the turbine housing it should be stamped FP

It does look similar to the stock t25 compressor housing, because its bolt on.
This turbo is from the early 2000s from what the previous owner said in 2018 that it hadn't been modified since 2004. So the engine had some seriously outdated performance parts on there when I bought it.
 

JeffGS-T97

Supporting Member
1,002
692
Mar 22, 2019
Muncie, Indiana
Been looking around on other members threads with issues with their cars. I am starting to get the idea that my ecu might be having issues. C-note said something that made a lot of sense. My turbo worked really good right before i changed the HG. The car was in serious down time and started having turbo like issues right off the bat once reassembly. The engine passed leak down, and comp test. I did clean the ecu and recoat it but that was before i pulled the head. I do have a 1g intake manifold with a port matched 2g head, so when i replaced that gasket i used a 1g MLS gasket between the intake and head. I hope that was the right choice for that.
I wish this car were closer to stock when i bought it. There are a lot of things i don't understand about standalone ECU's not to mention one from the Stone age like mine. I have had to self teach the whole way.
 

JeffGS-T97

Supporting Member
1,002
692
Mar 22, 2019
Muncie, Indiana
When I have mentioned my turbo issue a couple of people have mentioned a guy named Justin. That can identify and rebuilt turbos if i understood correctly. I'm not entirely sure who is being referred to. Im beginning to think a rebuild is my best option, i think going the different setup route might be too costly for me. A 16g would require a new manifold and intercooler piping and a few other small details.
 

JeffGS-T97

Supporting Member
1,002
692
Mar 22, 2019
Muncie, Indiana
Thought of another part to inspect for air leaks. I replaced the brake booster check valve hose earlier last year. I'm wondering if the brake booster itself is leaking. The brake peddle is very stiff with the engine off. Still haven't removed the turbo. As it stands the culprit for poor boost building is one of these I think.
1: brake booster leak
2: gas level too low
3: primary ECU malfunction
4: leak on Impeller housing.
5: jammed up WG stuck slightly open
Not sure if there is a cel for a brake booster malfunction...
 

JeffGS-T97

Supporting Member
1,002
692
Mar 22, 2019
Muncie, Indiana
Yeah i put it back together and got it all plugged in good. When i remove the check valve hose off the intake it doesn't run long at all. Should it be able to hold a bad idle even with that unplugged?
 

TK's9d2TSi

Supporting Member
6,262
3,252
Sep 11, 2017
Cincinnati, Ohio
Yeah i put it back together and got it all plugged in good. When i remove the check valve hose off the intake it doesn't run long at all. Should it be able to hold a bad idle even with that unplugged?
Are you plugging the hole on the IM?
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top