1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

2G Runs fine when cold but dies when warm

Posted by mitsumike0, Aug 4, 2018

Please Support Southbay Fuel Injectors
Please Support Feal Suspension
  1. mitsumike0

    mitsumike0 Proven Member

    187
    28
    Joined Oct 13, 2013
    Passaic, New Jersey
    Hey all, heres the scoop, post might be a little long so I apologize for that now. Last Friday, not yesterday, I drove my car to the store. It ran completely fine. I was in the store for a little while, long enough for the car to cool down. I then drove to a restaurant that was a short distance from the store. After eating my lunch, I turned on my car to go home. A little ways in to the drive, after my car is warmed up, I noticed something is a little off with the afr gauge. It starts to read super lean, my car loses throttle response and it stalls out. I pull over to try and start my car and it starts up fine but after 2 second it stumbles and dies. I had to get it towed home.
    So I thought it was maybe a bad cam angle sensor. I put a new one in on Monday and after installation I go on a test drive. Car started right up and it drive like normal, even building boost no problem. Then after about 10 minutes of driving, the afr goes lean and I lose throttle response again. This time I try to give it some gas, and the car accelerates, but then cuts and eventually ends up dieing again. This time I pulled it into a parking lot and had it cool for a little . The car started up fine again and I drove it down the street a bit for it to ultimately do the same thing its been doing.
    So now I'm at a stand still and I don't want to throw parts at it until I have a better understanding of whats going on. The car has a transistor thats 1 year old, ngk wires that are 1 year old, spark plugs maybe have 2k miles on them (br7es) and a new cam angle sensor. Im leaning towards a bad coil pack at this point. I bought it used about 3 years ago. Any one else have any ideas on what it can be ?
     

    Street Build 948  1

    1997 Mitsubishi Eclipse GSX
    12.32 @ 116.1 · 2G DSM
    Loading...
  2. 91tsiawdtalon4g63

    91tsiawdtalon4g63 Proven Member

    135
    17
    Joined Dec 24, 2013
    Brownsville, Pennsylvania
    Check coolant temp sensor also try pulling codes since it's obd2. If you have ecmlink then you'd know what's going on just by looking at your logs
     

    Street Build 3K  4

    1990 Mitsubishi Eclipse GSX
    437 whp · 325 lb/ft · 1G DSM

    Street Build 1K  0

    1991 Eagle Talon TSi AWD
    14.01 @ 103.76 · 1G DSM
    Loading...
  3. chrysler kid

    chrysler kid Proven Member

    1,631
    393
    Joined Dec 20, 2002
    Mckinney, Texas
    Check your fuel pressure at the rail when the car starts acting funny. I bet the pump is overheating and going out
     

    2K  15

    1998 Mitsubishi Eclipse GST
    fwd · automatic · 2G DSM

    2K  12

    1996 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM

    1K  0

    1996 Mitsubishi Eclipse GST
    14.1 @ 97 · 2G DSM
    Loading...
    tk106, dsm199994 and 10's or bust like this.
  4. mountainbike91

    mountainbike91 Proven Member

    547
    87
    Joined Feb 18, 2010
    stony brook, New York
    this happened to me a while ago, change your MDP sensor Untitled.png
     

    Drag Race Build 2K  0

    1999 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
    THEIFNDNIGHT likes this.
  5. mitsumike0

    mitsumike0 Proven Member

    187
    28
    Joined Oct 13, 2013
    Passaic, New Jersey
    Coolant temp sensor was reading fine in my car when it runs. It could still be faulty. I'll run the scanner through the car to see if I get anything. When I hooked up ecmlink fuel pressure seemed fine. I have fuel pressure hooked up to record in dsmlink so I can see what's happening. Mdp sensor has been replaced with a 4 bar sensor for speed density so it's definetly not that.
     

    Street Build 948  1

    1997 Mitsubishi Eclipse GSX
    12.32 @ 116.1 · 2G DSM
    Loading...
  6. mountainbike91

    mountainbike91 Proven Member

    547
    87
    Joined Feb 18, 2010
    stony brook, New York
    please listen... i changed mine out with omni 4bar, car ran fine cold then died when warm.... its a faulty map sensor... please trust meee...
     

    Drag Race Build 2K  0

    1999 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  7. mountainbike91

    mountainbike91 Proven Member

    547
    87
    Joined Feb 18, 2010
    stony brook, New York
    the omni is faulty... is what im saying
     

    Drag Race Build 2K  0

    1999 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  8. 91tsiawdtalon4g63

    91tsiawdtalon4g63 Proven Member

    135
    17
    Joined Dec 24, 2013
    Brownsville, Pennsylvania
    If you can, take a drive while taking a log, then post the log up here. Even if you'd take some pictures of your tune, that'd be cool too.
     

    Street Build 3K  4

    1990 Mitsubishi Eclipse GSX
    437 whp · 325 lb/ft · 1G DSM

    Street Build 1K  0

    1991 Eagle Talon TSi AWD
    14.01 @ 103.76 · 1G DSM
    Loading...
  9. mitsumike0

    mitsumike0 Proven Member

    187
    28
    Joined Oct 13, 2013
    Passaic, New Jersey
    Im definetly going to look into that as well. My apologies for not listening.

    After I fix this leaking power steering line I'll try to get a log on dsmlink and post it on here. Thanks everyone so far!
     

    Street Build 948  1

    1997 Mitsubishi Eclipse GSX
    12.32 @ 116.1 · 2G DSM
    Loading...
  10. mountainbike91

    mountainbike91 Proven Member

    547
    87
    Joined Feb 18, 2010
    stony brook, New York
    i had link in my car to... its very had to see omni fail on datalog....
     

    Drag Race Build 2K  0

    1999 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  11. mountainbike91

    mountainbike91 Proven Member

    547
    87
    Joined Feb 18, 2010
    stony brook, New York
    any luck?
     

    Drag Race Build 2K  0

    1999 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  12. mitsumike0

    mitsumike0 Proven Member

    187
    28
    Joined Oct 13, 2013
    Passaic, New Jersey
    Some bad luck LOL. In my attempt to locate the power steering leak, the lower nipple on the reservoir snapped. I ordered a new bottle so it should be arriving soon. After that's done, I'll post a log for everyone to see.
     

    Street Build 948  1

    1997 Mitsubishi Eclipse GSX
    12.32 @ 116.1 · 2G DSM
    Loading...
    mountainbike91 likes this.
  13. mountainbike91

    mountainbike91 Proven Member

    547
    87
    Joined Feb 18, 2010
    stony brook, New York
    okay cool!!!!
     

    Drag Race Build 2K  0

    1999 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  14. mitsumike0

    mitsumike0 Proven Member

    187
    28
    Joined Oct 13, 2013
    Passaic, New Jersey
    Alright guys, the new power steering bottle is in and bled. After i finished, i went for a little drive. Cold start was fine and warm cruising was great until i decided to hit some boost. After i went into some boost, the car bucked, it didnt like it at all. I turn right on a side street and the car starts acting up out of boost just like the symptoms discussed earlier.
    So after reviewing the log, i think i might have figured out my issue. Just like mountainbike mentioned, i think my omni is toast. If you jump to the 162 second in the log, you see me entering some boost. The omni is supposed to ideally increase , but it cuts in and out. To further back up my theory, jump to the 175 second in the log. Under normal cruising the omni is going nuts. It's cutting in and out even though i am applying steady throttle. So those are my thoughts, any else have ideas after seeing the log?
     

    Attached Files:

    Street Build 948  1

    1997 Mitsubishi Eclipse GSX
    12.32 @ 116.1 · 2G DSM
    Loading...
  15. 91tsiawdtalon4g63

    91tsiawdtalon4g63 Proven Member

    135
    17
    Joined Dec 24, 2013
    Brownsville, Pennsylvania
    Have you tried a good map sensor to see if any changes happened?
     

    Street Build 3K  4

    1990 Mitsubishi Eclipse GSX
    437 whp · 325 lb/ft · 1G DSM

    Street Build 1K  0

    1991 Eagle Talon TSi AWD
    14.01 @ 103.76 · 1G DSM
    Loading...
    PlanZero likes this.
  16. PlanZero

    PlanZero Proven Member

    1,376
    259
    Joined Aug 13, 2013
    Easton, Pennsylvania
    How about the connector itself? Maybe one of the wires is loose and cutting out sporadically. I had that happen on a MAP connector. Just a thought before you buy a new omni. Can you just stick the old sensor back on there and test it to verify the problem?
     

    Street Build 4K  8

    1996 Eagle Talon TSi
    fwd · automatic · 2G DSM

    Street Build 2K  0

    1997 Eagle Talon TSi AWD
    automatic · 2G DSM
    Loading...
  17. mountainbike91

    mountainbike91 Proven Member

    547
    87
    Joined Feb 18, 2010
    stony brook, New York

    yea, double check the wires, if it was wire it would happen hot or cold, but slap a new sensor on for now and the problem should go away!!!!
     

    Drag Race Build 2K  0

    1999 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  18. mountainbike91

    mountainbike91 Proven Member

    547
    87
    Joined Feb 18, 2010
    stony brook, New York
    also here is my thread, from the same problem, and you can see i kinda figured it out on my own---- http://www.dsmtuners.com/threads/2g-dsm-dies-when-warmed-with-ecmlink-logs.512948/#post-153656006
     
    Last edited: Aug 26, 2018

    Drag Race Build 2K  0

    1999 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  19. mountainbike91

    mountainbike91 Proven Member

    547
    87
    Joined Feb 18, 2010
    stony brook, New York
    update?
     

    Drag Race Build 2K  0

    1999 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  20. Aaron boger

    Aaron boger Probationary Member

    1
    0
    Joined Sep 29, 2018
    Auburn, Indiana
    Any thing going on with the Map I got a laser doing the same thing
     
  21. ErikTande

    ErikTande Proven Member

    841
    229
    Joined Dec 17, 2012
    Centennial, Colorado

    Street Build 779  1

    1997 Eagle Talon TSi AWD
    awd · manual · 2G DSM

    3K  7

    1990 Mitsubishi Eclipse GSX
    13.2 @ 105 · 1G DSM
    Loading...
  22. THEIFNDNIGHT

    THEIFNDNIGHT Proven Member

    33
    6
    Joined Nov 28, 2011
    NY, New York
    Any update on this?
    Did you ever get it running right?
     

    Street Build 5K  6

    1998 Mitsubishi Eclipse GSX
    awd · automatic · 2G DSM
    Loading...

Share This Page

Support Vendors who Support the DSM Community
Archer Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory WheelWell.com