The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Please Support ExtremePSI
Please Support VR-Speed Factory

engine shakes at WOT again!

alfred480

Proven Member
73
0
Oct 8, 2009
Mississauga, ON_Canada
Hey everyone,

So I changed my intake back to stock and have a 2g to 1g bov adapter, I have the stock airbox and hoses running from the intercooler to the throttle body. I used to have metal piping with the 1g bov mount welded on and an injen cone filter. I was also running 15lbs of boost before i took my boost gauge out and it was running fine. Now here is the problem I only changed the air filter and one side of the intercooler piping (intercooler to throttle body), but when I go to WOT past 3000 rpm my car starts to shake and NO more power is made, but the turbo continues to spool loudly, possibly a boost leak? Maybe too must boost for the stock intake setup and its running rich maybe? I have no idea, I have taken it back to the shop and they are working on it, but any ideas? Also, it is not a t25 turbo anymore i believe it is a 14b from a 1g. Also my mechanic said the old BOV was leaking and he put in a new gasket and it is fine now so maybe it is building a lot more pressure now causing it to run lean at higher rpms with WOT so probably try turning the boost down back to 12lbs or so but I also no longer have a boost gauge in anyone know another way to get a accurate reading?

Please any help is appreciated.
 

gofer

Moderator
8,076
1,177
Feb 18, 2006
South Gilbert, Arizona
damn thats a long ass sentence... throw a few comma's in there and give me a chance to breath! :D
you most definitely need to do a boost leak test because im sure you'll find something... if you don't have a boost gauge and want to run 12lbs remove your boost controller and hook the wastegate up like stock.
you cant confuse a t25 turbo and a 14b, its impossible. a 14b or any tdo5 turbo will have a j-pipe coming off the top of it and a t25 looks like this...

me_035.jpg


:dsm:
 

alfred480

Proven Member
73
0
Oct 8, 2009
Mississauga, ON_Canada
Ya that's what was done the boost controller was taken out and now it is hooked like stock. And yea I know it is not a t25 turbo. It is a td05 housing just not sure what kind of turbo it is, probably a 14g though. Also previous owner told me the turbo was from a supra a 2jz turbo or something I am not sure. Regardless, if i set it up stock now without the boost controller how many lbs of boost will it run on the stock setup?
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com OHM Racing Raven Fabrication RixRacing RockAuto RTM Racing SouthBay Fuel Injectors STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top