1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Crower stage 2 turbo grind cams

Posted by bmxunderground, Jan 14, 2011

Please Support Southbay Fuel Injectors
Please Support Morrison Fabrication
  1. bmxunderground

    bmxunderground Proven Member

    213
    3
    Joined Dec 11, 2007
    Bowling Green, Kentucky
    Has anyone here running the crower 2 turbogrinds experienced any oddities in vibration throughout the RPM band? Here's what I'm getting at.

    There is a very odd but distinct vibration at about 3k to 4k. I will try and articulate the sound being made by this vibration. driving with knobby dirt tires is all I can come up with. It makes the noise with no load and less with load.

    I cant find anything rubbing, the clutch being pressed or not doesn't make a difference. It's bugging me, because in all of my experience I've never had this type noise! There doesn't seem to be anything contacting anything, almost like the combustion alone is creating the noise. But then again, I don't think I've heard anything from peoples videos other than loping idle so I'm concerned.

    chime in if you have any information that could help me out. I'll keep inspecting as time permits tomorrow evening.
     
  2. CODE4

    CODE4 Proven Member

    416
    44
    Joined Jun 6, 2004
    Tampa, Florida
    You have isolated this noise to that it is from your cam swap? I assume there was no vibration prior to the cams? And immediately after the sound surfaced? There were no other modifications performed at the same time as the cams?
     

    1K  0

    1999 Mitsubishi Eclipse N/T
    manual · 2G DSM
    Loading...
  3. bmxunderground

    bmxunderground Proven Member

    213
    3
    Joined Dec 11, 2007
    Bowling Green, Kentucky
    well I added cams, cam gears, and different valve springs and retainers. My old set up though was out of time bad so I don't have a good marker to go by.

    If you guys are running these cams and have nothing but smooth acceleration then I'll have to do some looking around... its killin me though! I'll try to catch it on video. In the mean time, drop me some info.

    I was concerned about valve clearance, but I'm sure I would def have more problems than vibration if that were the case.
     
  4. RogueAngel

    RogueAngel Probationary Member

    13
    0
    Joined May 4, 2008
    Fife, Washington
    I'm using those cams and have no issues with them.
     

    408  0

    1995 Mitsubishi Eclipse N/T
    manual · 2G DSM
    Loading...
  5. bullettdsm

    bullettdsm N/T DSM Wiseman

    2,408
    30
    Joined Dec 17, 2004
    East Hampton, Connecticut
    Rest assured that unless you did something really radical (say took off .070 on the head, LOL), you'll have no clearance problem with these cams and 8.8 pistons; or 9.6 pistons; or 10.5 pistons for that matter.

    MB
     
  6. bmxunderground

    bmxunderground Proven Member

    213
    3
    Joined Dec 11, 2007
    Bowling Green, Kentucky
    I'll have more time Monday and Tuesday to both test things and take some video. I'll post my findings

    few pics to pass the time

    <a href="http://s216.photobucket.com/albums/cc154/bmxunderground/?action=view&amp;current=IMG_3015.jpg" target="_blank"><img src="http://i216.photobucket.com/albums/cc154/bmxunderground/IMG_3015.jpg" border="0" alt="Photobucket"></a>
    <a href="http://s216.photobucket.com/albums/cc154/bmxunderground/?action=view&amp;current=IMG_2076.jpg" target="_blank"><img src="http://i216.photobucket.com/albums/cc154/bmxunderground/IMG_2076.jpg" border="0" alt="Photobucket"></a>
    <a href="http://s216.photobucket.com/albums/cc154/bmxunderground/Sliver%20Eclipse/?action=view&amp;current=IMG_2048.jpg" target="_blank"><img src="http://i216.photobucket.com/albums/cc154/bmxunderground/Sliver%20Eclipse/IMG_2048.jpg" border="0" alt="Photobucket"></a>
     
  7. bmxunderground

    bmxunderground Proven Member

    213
    3
    Joined Dec 11, 2007
    Bowling Green, Kentucky
    After talking to a few friends from local shops, people believe that it is my clutch setup that is causing the vibration.

    I took off the aluminum flywheel on this last build since my pressure plate was toast, and put back on the starter flex plate deal and a modular centerforce clutch. Other than those crazy little weights they have on the pressure plate, could there be a possibility of the clutch unit itself to being misaligned?

    I'm actively working this issue out, actually have a SPEC stage 4 clutch on the way from another user here. But any prior experience any of you have had with this issue would be of interest to me for sure.
     
  8. GsXdSmKingGsX

    GsXdSmKingGsX Proven Member

    1,787
    29
    Joined Dec 13, 2008
    Plainview, Minnesota
    OMG @ your car.. That is the definition of a hawt setup man.
     
    Loading...
  9. bmxunderground

    bmxunderground Proven Member

    213
    3
    Joined Dec 11, 2007
    Bowling Green, Kentucky
    Thanks, but I would love to be driving it right now! haha. I've actually got a guy trying to trade me an RX8 for it this week after I get it back together.

    People saw me killing races at 18psi recently and they want it for themselves. I just need it to be user friendly and trouble free when I let it go.

    I hope later in the year to pick up an all black GSX. never owned a 4G63 car yet, owned over 30 420a's however.

    To be back on track however; anyone with info on my issue please post!
     
  10. aDee

    aDee Proven Member

    40
    0
    Joined Nov 30, 2006
    chicago, Illinois
    You might resolved it already but are you sure your balance shafts are in phase with the rest. Remember that having it on mark doesn't mean it's set right.
     
  11. Slo2gen

    Slo2gen Proven Member

    638
    15
    Joined Apr 26, 2005
    Spartanburg, South Carolina
    No balance shafts on a 420a. Do you have a sound clip of it doing this?
     

    2K  0

    1998 Mitsubishi Eclipse N/T
    420 whp · 365.0 lb/ft · 2G DSM
    Loading...
  12. bmxunderground

    bmxunderground Proven Member

    213
    3
    Joined Dec 11, 2007
    Bowling Green, Kentucky
    I forgot to end this thread. I found out that the Centerforce clutch I had installed did not self center like the OEM clutch. I had removed the aluminum lightweight flywheel since the Centerforce is modular like the OEM design. At any rate, the button on the back had play where it fit inside the crankshaft. Being off center made a hell of a vibration.

    Since then, the clutch was pulled, new lightweight flywheel reinstalled and the car is back on the street dominating.
     

Share This Page

Support Vendors who Support the DSM Community
Archer Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory