The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support Kiggly Racing
Please Support Morrison Fabrication

420A 95 talon esi auto stuck in limp mode

jesse12345

Supporting Member
250
148
Jul 30, 2014
Down the block, Minnesota
Hey all back again except with an unusual issue. I recently got my engine up and running in my talon, she's been sitting for 12 years. The car only has 79k miles, and I replaced literally everything you can on the engine and transmission. I even went through the valve body. If I leave the battery disconnected and then connect it the car will start out in 1st gear and shifts real ugly into 2nd and then it's in limp mode. It did all of this even before I swapped all sensors and solenoids so I'm at a loss. I really don't want to rebuild, and I can't seem to find anything to my issue. Thanks all for any help and im not ready to swap to manual quite yet.
 

jesse12345

Supporting Member
250
148
Jul 30, 2014
Down the block, Minnesota
obviously I don't read directions very well, on my application there's a plate that has to come off for the new solenoid pack to work. I was stumped for awhile and I assume 98 percent of you don't mess with the 41te auto and I don't blame you. The thing goes into limp mode if you look at it wrong.
 

1995TalonMT

Probationary Member
27
13
May 20, 2020
Walls, Mississippi
I also replaced the solenoid pack a few years ago along with the input and output sensors on the Transmission. Hopefully you fixed the problem and it is shifting correctly now.
 

1990TSIAWDTALON

Moderator
9,011
4,887
Nov 14, 2013
Independence, Kansas
A bad VSS or pulse generators will throw it into limp mode so if the speedometer is not working right or one or both pulse generators on the trans are not working, it will stay in limp.
Just some info.
 

jesse12345

Supporting Member
250
148
Jul 30, 2014
Down the block, Minnesota
Yeah I replaced both of those sensors right away because when I first took it out the speedometer wasn't working. I won't be able to test until I get it up on Jack stands but crossing my fingers that's all it was. I'll let you guys know otherwise I'll probably need a transmission unfortunately. Thanks for the replies.
 

1999RSfwd

Proven Member
164
90
Nov 24, 2016
Dresden, Tennessee
I have the same issue with my 420a auto, but only when the trans warms up. I replaced both sensors, the solenoid pack (removed the spacer), and the filter. At first I thought it was fixed, but the shifting was weird. I just figured it was relearning, but then it kept getting stuck in limp mode again. I even replaced my tcu and it does the same thing. Every time I come to stop sign or a red light or have to slow way down, I put it in neutral come to a stop and then put it back in drive. This seems to trick the tcu into letting trans shift properly, and not get stuck in limp mode.

I'm ready to manual swap the car, but my focus now is my GSX, so my RS is on the backburner.
 

jesse12345

Supporting Member
250
148
Jul 30, 2014
Down the block, Minnesota
I guess the 41te valve body gets super sludged up, when I contacted a transmission shop about my issue that was one of the big ones. I bought a transgo shift kit for it and super cleaned the whole valve body seems to shift very nice too. I also put a big transmission cooler on it and I have a trans temp gauge. I'm no expert in the transmission department but the valve body was very easy to tear down. Hopefully I was of some help.
 

jesse12345

Supporting Member
250
148
Jul 30, 2014
Down the block, Minnesota
Yeah man I want to manual swap but where I'm at right now I have to deal with my auto. All the research I've done on these autos makes me feel like mine isn't going to last very long with the setup i have, but who knows maybe the shift kit and cooler will prolong its life.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top