The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Update Your Password Today!

    We have implemented tools to identify member accounts using insecure passwords and will be locking those accounts until their passwords are updated. Don't get locked out of your account - update your password today, and ensure your account has a valid email address on file. Read more here...
Please Support JNZ Tuning
Please Support Fuel Injector Clinic

2G Which parts control spark to plugs?

v8s_are_slow

20+ Year Contributor
2,773
245
Sep 30, 2002
Panama City, Florida
So I'm searching but I don't have years for this. Short story, injector was leaking and had a nice little fire that I got out in a hurry. Repaired wires and car would fire up fine of the two times I tried. Third time on another day was a no-go. No spark on 2 and 3. Thought it was ptu so replaced with another. Still no spark. Tried the ptu on a friend's car, no issues and it ran. So that rules out ptu. Figured maybe I missed some wiring but all looks good. So aside from the ptu, coil pack, wiring, and maybe the ecu, I can't think of the parts that would control the spark for only cylinders 2 & 3. Maybe bad coil pack. But need the list of parts to be checking.

This is a 6 bolt motor in a 98 body. 95 ecu with Ecmlink. Kiggly 2-toothed crank trigger plate with the 98 cas so no base timing adjustments needed. Just plug and play and no 1g cas needed. Thanks y'all.
 

jed344

Supporting VIP
1,182
285
Jan 10, 2008
Waterville, Iowa
Look up wiring diagram. Remember 2 and 3 the color the wire is at the PTU input then changes color after it goes to diagnostic plug on fire wall. So if you look at wires at the coil you will see the red and blue wire as i recall that is 2 and 3 at the PTU. But that is NOT now 2 and 3 at the coil, as i recall the black and white wire is now 2 and 3 at coil. I have started at ECU before and checked for it out putting signal, then at PTU in and out, then at coil. You will find the issue by doing this.
 

v8s_are_slow

20+ Year Contributor
2,773
245
Sep 30, 2002
Panama City, Florida
About to be getting on this here shortly. Thanks y'all. Going to assume it's my cas wiring if anything because it got hit by the fire pretty good. I'll be taking a second look.

Only thing I've found so far is one cut wire (black) and one burnt wire (yellow which may or may not be good and making connection) to the tps. Not sure if I accidentally cut the black wire or if it was like that. Repairing that and then relocating my coil pack because it sits under the intake manifold which makes it a pain for sooooo many reasons.
 
Last edited by a moderator:

v8s_are_slow

20+ Year Contributor
2,773
245
Sep 30, 2002
Panama City, Florida
Update: Not sure if those wires tie into the circuit or not but it's all good now. Shew!!!
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top