1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

1G Need Some Direction

Posted by Uncle Jacks Hands, Jun 18, 2020

Please Support ExtremePSI
Please Support ExtremePSI
  1. Uncle Jacks Hands

    Uncle Jacks Hands Supporting Member

    29
    3
    Joined Sep 10, 2019
    Fairfax, Virginia
    So I have gotten to a point in my rebuild that I don't really know what to do next. I am very much an amateur in the car world. Just recently I got my car down to where I moved so I can work on it again and its been a handful. I just rebuilt my throttle body to finish fixing the boost leaks, and (to get an idea of the mess I was left with) replaced the injector wiring since it fell apart from being just taped together. I'm now stuck looking at my ECM Link logs not knowing what else to do, it is running pretty rough. It seems that my MAP sensor is acting up as if I barely touch it the cars characteristics seem to change immediately. I will post a log shortly from my laptop. Any input on what I should be working on next would be greatly appreciated. Thank you for your time!
     

    Attached Files:

    Street Build 274  2

    1991 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM
    Loading...
  2. Vegas Smith

    Vegas Smith Previously Vegas smith

    3,883
    1,731
    Joined Dec 2, 2002
    Houston, Texas
    Your TPS needs to be adjusted to hit 0.63 volts at idle. Your battery voltage is also low at 12.8v while the car is running. My car runs terribly at that voltage. There must be an issue with the battery or alternator. Fix those and report back.
     

    Street Build 4K  3

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
    TK's9d2TSi likes this.
  3. JeffGS-T97

    JeffGS-T97 Proven Member

    155
    44
    Joined Mar 22, 2019
    Muncie, Indiana
    Are you running an oem MAP?
     

    Street Build 1K  9

    1997 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM
    Loading...
  4. Vegas Smith

    Vegas Smith Previously Vegas smith

    3,883
    1,731
    Joined Dec 2, 2002
    Houston, Texas
    His log says Omni 4-bar
     

    Street Build 4K  3

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
  5. TK's9d2TSi

    TK's9d2TSi Supporting Member

    3,607
    1,249
    Joined Sep 11, 2017
    Cincinnati, Ohio
    Under ECU input, ecu side, change wideband to front O2 instead of Baro.
    Start here for Global -61 deadtime 330 for 1150 FIC https://www.ecmtuning.com/wiki/baseinjectordata
    Change your knock cel to 2 under dash
    Change your coasting fc to 0 https://www.ecmtuning.com/wiki/revlimiters

    If you're wiggling wires and the car acts differently, there's something wrong with wiring or connectors or sensor. You're not logging the map sensor. Capture then display the map sensor.

    You also have a pending code 0041 injector circuit malfunction
     
    Last edited by a moderator: Jun 19, 2020

    405  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    459  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 3K  6

    1992 Eagle Talon TSi AWD
    12.2 @ 120 · 1G DSM
    Loading...
  6. Uncle Jacks Hands

    Uncle Jacks Hands Supporting Member

    29
    3
    Joined Sep 10, 2019
    Fairfax, Virginia
    Thank you all very much for your input!

    Vegas smith, yes I noticed that too. I have a new alternator and this battery looks very cheap and old, I'll be replacing that and seeing what difference that makes.

    JeffGS, the car came with the MAP sensor installed (whoever installed it had the vacuum line attached to the cruise control... its that kind of car atm trying to track these issues down) and so far it looks identical to the MAP sensors on ECMs website which is the OMNI 4 bar.

    TK, ok I will make those adjustments, and good point about tracking the MAP so I know if I need to replace. As for the 41 code, I must have forgotten to clear. I had one injector not squirting as I came to find the ground wire was hand twisted together under tape and not soder together, it just came apart without my knowing. That was fixed and I will double check the code.

    Again thank you all. I will adress these ASAP, this will give me some goo work to do.
     

    Street Build 274  2

    1991 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM
    Loading...
  7. TK's9d2TSi

    TK's9d2TSi Supporting Member

    3,607
    1,249
    Joined Sep 11, 2017
    Cincinnati, Ohio
    Are you using ecmlink sd cable?

    If you are, input is wrong. I'm using links sd cable and this is how mine is set

    upload_2020-6-19_9-32-31.png
     
    Last edited by a moderator: Jun 19, 2020

    405  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    459  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 3K  6

    1992 Eagle Talon TSi AWD
    12.2 @ 120 · 1G DSM
    Loading...
    1990TSIAWDTALON likes this.
  8. Uncle Jacks Hands

    Uncle Jacks Hands Supporting Member

    29
    3
    Joined Sep 10, 2019
    Fairfax, Virginia
    No, its the pigtails that you have to splice into the harness (the green plug with the red blue and black wires). I did it about a year ago so I need to jog my memory and I followed a write up I believe I found on these forums, I can see if I am able to find it, but I believe I have everything assigned correctly. In regards to the front 02 assignment, does the WB need to be spliced into the front 02 wires to do that?
     

    Street Build 274  2

    1991 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM
    Loading...
  9. TK's9d2TSi

    TK's9d2TSi Supporting Member

    3,607
    1,249
    Joined Sep 11, 2017
    Cincinnati, Ohio

    405  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    459  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 3K  6

    1992 Eagle Talon TSi AWD
    12.2 @ 120 · 1G DSM
    Loading...
    1990TSIAWDTALON likes this.
  10. Vegas Smith

    Vegas Smith Previously Vegas smith

    3,883
    1,731
    Joined Dec 2, 2002
    Houston, Texas
    I didn't see that. That's a huge problem and most likely the main issue.
     

    Street Build 4K  3

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
    TK's9d2TSi likes this.
  11. jed344

    jed344 Supporting VIP

    862
    111
    Joined Jan 10, 2008
    Waterville, Iowa
    I see you are running what appears to be evo timing map. If the car is on e85 you can run much more aggressive then that. As well the fuel target map will be off quite a ways from what I would target. I just slapped this together. Something more along the lines of this is what I would start with.
     

    Attached Files:

    Last edited: Jun 19, 2020

    1K  38

    1997 Mitsubishi Eclipse GSX
    awd · manual · 2G DSM
    Loading...
  12. Uncle Jacks Hands

    Uncle Jacks Hands Supporting Member

    29
    3
    Joined Sep 10, 2019
    Fairfax, Virginia
    Quick update before the rain came. I purchased a new battery, this seemed to have helped slightly but it still looks low, I really hope its not the alternator as the current one hasn't even seen more than 30 miles (the battery is an AGM if that matters). I will see what I can address with this this weekend. ECU input side was changed to front 02 from Baro, knock CEL was changed to 2, coasting FC was changed to 0, MAP sensor is now being logged, Global fuel since running E85 I calculated it to be -41.7% with 330(micro?)seconds of deadtime. The MAP acted up again when it was physical touched as you can see in the log, I will keep digging into this, I still cant get any consistency. Thank you all for your help this is already a lot of progress.

    Jed, yes thats exactly it, it took and evo timing map because I didn't trust was I was originally given. Thank you very much for that map I appreciate that. I will upload that tomorrow.
     

    Attached Files:

    Street Build 274  2

    1991 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM
    Loading...
  13. Vegas Smith

    Vegas Smith Previously Vegas smith

    3,883
    1,731
    Joined Dec 2, 2002
    Houston, Texas
    TPS is still not set correctly. Still a charging issue.
     

    Street Build 4K  3

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
  14. Uncle Jacks Hands

    Uncle Jacks Hands Supporting Member

    29
    3
    Joined Sep 10, 2019
    Fairfax, Virginia
    Vegas smith, I ran out of time I will be fixing the TPS today and hopefully figuring out the charging issue as well.
     

    Street Build 274  2

    1991 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM
    Loading...
  15. Uncle Jacks Hands

    Uncle Jacks Hands Supporting Member

    29
    3
    Joined Sep 10, 2019
    Fairfax, Virginia
    Ok, so I fixed the TPS voltage issue and the car finally started trying to cycle the O2 simulation I think. I bought a voltmeter to test the alternator and battery etc, ecmlink is showing the battery being around 13.3V however my meter was showing that during idle the battery, alternator fuse, and alternator itself was showing 14.35V. Could that just mean the battery needs charged properly or something?
     

    Attached Files:

    Street Build 274  2

    1991 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM
    Loading...
  16. Vegas Smith

    Vegas Smith Previously Vegas smith

    3,883
    1,731
    Joined Dec 2, 2002
    Houston, Texas

    Street Build 4K  3

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
  17. Uncle Jacks Hands

    Uncle Jacks Hands Supporting Member

    29
    3
    Joined Sep 10, 2019
    Fairfax, Virginia
    Vegas smith, thank you very much for that direction, this seems to be where a few of my problems are, looks like I will be busy for a bit. My ISCPosition is pegged at 0 at idle regardless of the BISS location, and my RPMs have been the most controlled since the BISS was adjusted. Thank you again, I will update when I can.
     

    Street Build 274  2

    1991 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM
    Loading...
  18. Vegas Smith

    Vegas Smith Previously Vegas smith

    3,883
    1,731
    Joined Dec 2, 2002
    Houston, Texas
    Giant vacuum leak or broken isc or isc drivers.
     

    Street Build 4K  3

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
  19. Uncle Jacks Hands

    Uncle Jacks Hands Supporting Member

    29
    3
    Joined Sep 10, 2019
    Fairfax, Virginia
    Alright so he's the most recent update. I am having trouble getting the ISC position to 30. I tested the power to the ISC and it seems to be fine, it also does react to the BISS being adjusted. I did another BLT and I am not seeing any real leaks, the only leakage I am hearing is air going through the oil return on on the turbo from what I can tell, it easily gets into 20PSI before the tester launches off the turbo. Could the throttle body plate not be aligned properly or something? I feel like I am missing something right in front of my face. Here are the latest logs. Also, I noticed a small crack in the exhaust manifold has formed, but that should cause issues with the ISC position right? Thank you for your time.
     

    Attached Files:

    Street Build 274  2

    1991 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM
    Loading...
  20. Vegas Smith

    Vegas Smith Previously Vegas smith

    3,883
    1,731
    Joined Dec 2, 2002
    Houston, Texas
    The FIAV can leak air and it won't show up on a BLT. I had that happened for a couple of years until I finally figured it out.
     

    Street Build 4K  3

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
  21. Uncle Jacks Hands

    Uncle Jacks Hands Supporting Member

    29
    3
    Joined Sep 10, 2019
    Fairfax, Virginia
    So due to Covid, there seems to be quite the back order on FIAV gaskets as I have been waiting over a month for one. Is there anything else you would recommend I focus on in the meantime? Could I start adjusting the speed density tables a bit or would that be redundant until I fix the idle?
     

    Street Build 274  2

    1991 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM
    Loading...
  22. TK's9d2TSi

    TK's9d2TSi Supporting Member

    3,607
    1,249
    Joined Sep 11, 2017
    Cincinnati, Ohio
    I’d wait for the gasket or order it from somewhere else. I hate taking the tb on and off. You can throw a little rtv on it
     

    405  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    459  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 3K  6

    1992 Eagle Talon TSi AWD
    12.2 @ 120 · 1G DSM
    Loading...
  23. Uncle Jacks Hands

    Uncle Jacks Hands Supporting Member

    29
    3
    Joined Sep 10, 2019
    Fairfax, Virginia
    Ok, so I installed the new FIAV gasket and it seemed to make a pretty significant difference, however I cant get it to stay at 30 after fully warmed up, even with BISS adjustment, it's much closer but not quite there yet. I am going to go through the Sigma Six DSM Idle Control steps again, but is there something I am missing? I did yet another BLT and the only air escaping I can hear/find is when I put my ear to the oil cap opening. Also, should I just block off the FIAV or pull it off again and throw RTV everywhere? Attached are the two most recent logs. Thank you for your time yet again.
     

    Attached Files:

    Street Build 274  2

    1991 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM
    Loading...

Share This Page

Support Vendors who Support the DSM Community
ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory