1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

2G Idle surge now dies after start

Posted by Gordon King, Mar 29, 2020

Please Support Southbay Fuel Injectors
Please Support Fuel Injector Clinic
  1. Gordon King

    Gordon King Probationary Member

    15
    0
    Joined Mar 29, 2020
    mancelona, Michigan
    95 talon tsi awd
    Bought this car drove it home and threw a rod. So I bought a 96 eclipse for the motor, I swapped them out. First start up, was good besides a high idle surge, to get up to operating temp I took it around the block. Didnt neccesarily miss but more than 1/4 throttle was very sluggish. Pulled back into drive, idle surge still. So I swapped out the iac from other car. Starts and immediately dies, swapped back, still dies. Noticed the power steering leaking onto alternator and belts. But now I cant get it to run again. I was told the motor was just redone a month before the transmission went out in the eclipse. Please help
     

    Street Build 102  1

    1995 Eagle Talon TSi AWD
    awd · automatic · 2G DSM
    Loading...
  2. CAM280

    CAM280 Supporting Member

    16
    4
    Joined Oct 6, 2019
    BRISBANE, Australia
    maybe check your grounds??
     
  3. Gordon King

    Gordon King Probationary Member

    15
    0
    Joined Mar 29, 2020
    mancelona, Michigan
    The 2 grounds by the battery I redone, moved battery to back, there is 2 grounds back there as well.
     

    Street Build 102  1

    1995 Eagle Talon TSi AWD
    awd · automatic · 2G DSM
    Loading...
  4. Gordon King

    Gordon King Probationary Member

    15
    0
    Joined Mar 29, 2020
    mancelona, Michigan
    So I fixed the no start, I had the battery unplugged over night, put the other aic in. Starts fine now. Has a vacuum leak near the intake, which of course I cannot pin point. Was idling perfect, messed with the cold air intake and it started idle surging again. Unplugged the maf, idles fine but bad throttle response, changed maf to other one I had, still surges when plugged in. Another issue with car, is while driving around block if I ease into throttle it's fine, but when I go to give it more than 1/4 throttle it acts like it misses. Please help
     

    Street Build 102  1

    1995 Eagle Talon TSi AWD
    awd · automatic · 2G DSM
    Loading...
  5. Gordon King

    Gordon King Probationary Member

    15
    0
    Joined Mar 29, 2020
    mancelona, Michigan
    This was before I messed with the maf
     

    Street Build 102  1

    1995 Eagle Talon TSi AWD
    awd · automatic · 2G DSM
    Loading...
  6. motomattx

    motomattx Proven Member

    2,269
    914
    Joined Dec 9, 2010
    wampum, Pennsylvania
    You will want to fix the vacuum leak to start with.
     

    Drag Race Build 3K  24

    1995 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM
    Loading...
    ThunderChild likes this.
  7. Gordon King

    Gordon King Probationary Member

    15
    0
    Joined Mar 29, 2020
    mancelona, Michigan
    Fixed the vacuum leak
     

    Street Build 102  1

    1995 Eagle Talon TSi AWD
    awd · automatic · 2G DSM
    Loading...
  8. Gordon King

    Gordon King Probationary Member

    15
    0
    Joined Mar 29, 2020
    mancelona, Michigan
     

    Street Build 102  1

    1995 Eagle Talon TSi AWD
    awd · automatic · 2G DSM
    Loading...
  9. EShield

    EShield Supporting Member

    41
    25
    Joined Jan 14, 2020
    West Warwick, Rhode Island
    You said you have a vacuum leak around the intake? How are you determining that?

    One vacuum leak most people miss is injector o-rings.
     

    Street Build 173  1

    1997 Eagle Talon TSi AWD
    awd · manual · 2G DSM
    Loading...
  10. Gordon King

    Gordon King Probationary Member

    15
    0
    Joined Mar 29, 2020
    mancelona, Michigan
    By ear, I've done the brake clean spray while running. I didnt go anywhere near the injectors. My boost gauge is reading 17 on the vacuum as a constant. Don't know if that helps or not. This is my first turbo and first dsm. So I'm new to these cars but not new to turning wrenches. This car is weird, I checked and adjusted tps. Did the whole .63 reading, adjusted thr throttle cable, started it, everything was great, took for a 3 mile ride. Pulled hard, no issues, I didn't stomp on it, just a 1/2 throttle to 70. Shut it off, and now runs rich, has a miss, back to square one. So I took the iac off, checked the reading, I am pulling 39 on all 4, I know should only be 30, I have another one on the way. Put it back in, started car, idle surge, and while the car idle surges, I have great throttle response, doesn't miss, nothing. Shut it off, start again. Runs for a couple seconds and dies. Unplug battery, start again, will stay running, but will run really rich, misses, stutters, cant get car over 5k
     

    Street Build 102  1

    1995 Eagle Talon TSi AWD
    awd · automatic · 2G DSM
    Loading...
  11. motomattx

    motomattx Proven Member

    2,269
    914
    Joined Dec 9, 2010
    wampum, Pennsylvania
    Things to check: leak in piping between the maf and turbo inlet, piping between the throttle body elbow and the intercooler, adjust the biss screw to get a good idle.
     

    Drag Race Build 3K  24

    1995 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM
    Loading...
  12. Gordon King

    Gordon King Probationary Member

    15
    0
    Joined Mar 29, 2020
    mancelona, Michigan
    I was reading and watching videos on what to do next LOL. Figured I would take the throttle body off and clean it up, set the tps again, then go to the biss screw. But I'll do a BLT before I go any further, just to double check no leaks. I was also pondering to delete all unnecessary vacuum lines. Any suggestions. I'll update tomorrow after I get this finished
     

    Street Build 102  1

    1995 Eagle Talon TSi AWD
    awd · automatic · 2G DSM
    Loading...
  13. Gordon King

    Gordon King Probationary Member

    15
    0
    Joined Mar 29, 2020
    mancelona, Michigan
    Did a BLT, had a small leak at j pipe. Deleted all unnecessary vacuum lines. Cleaned the throttle body, reset tps to .63. Fixed exhaust leak. The only thing I didnt do was adjust biss screw. Cold start....idles at 3k then drops to 2k with idle surge, warms up to operating temp. No change in idle....shut off, restart, idles at maybe 1200 but will die within 2 seconds, will continue to die until I unplug battery, restart without a problem, will stay running, but now runs I'm guessing really rich as I can smell gas, stumbles when hitting throttle, just runs like dog sh**. Oh and while cold, will run like a raped ape. All this is in park, not driving down the road as I dont trust it to bring me back home. Just pulled the ecu, nothing wrong with it at all. The car will start like this every time. Cold=perfect Hot=crap. Any help would be great
     

    Street Build 102  1

    1995 Eagle Talon TSi AWD
    awd · automatic · 2G DSM
    Loading...
  14. SoCal420a

    SoCal420a Probationary Member

    2
    4
    Joined Nov 7, 2012
    San Diego, California
    The car runs rough when hot even without the MAF?
     

    Street Build 172  1

    1998 Mitsubishi Eclipse N/T
    fwd · manual · 2G DSM
    Loading...
  15. Gordon King

    Gordon King Probationary Member

    15
    0
    Joined Mar 29, 2020
    mancelona, Michigan
    Runs worse when I unplug maf
     

    Street Build 102  1

    1995 Eagle Talon TSi AWD
    awd · automatic · 2G DSM
    Loading...
  16. Gordon King

    Gordon King Probationary Member

    15
    0
    Joined Mar 29, 2020
    mancelona, Michigan
    Replaced the o rings on injectors, and just put a new o2 sensor in. Still same thing, I'm running out of ideas
     

    Street Build 102  1

    1995 Eagle Talon TSi AWD
    awd · automatic · 2G DSM
    Loading...

Share This Page

Support Vendors who Support the DSM Community
ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory