The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Please Support Fuel Injector Clinic
Please Support STM Tuned

1G Help Diagnosing No Start

Paul Nahas

Probationary Member
7
0
May 21, 2014
Calgary, AB_Canada
I recently installed a Walbro 525 fuel pump and -6AN feed line. The initial start-up was rough, so I shut down, and checked fuel pressure to be zero on the AFPR gauge. I assumed I had a leak somewhere in the new feed connections, so I turned on the pump via DSM Link, and checked under the hood to find fuel pouring out of the intake manifold. I assume this was ECU related, DSM Link "Copy to ECU" red asterisks appeared. I pulled the plugs to find the cylinders puddled with fuel. I cleaned up the fuel from the manifold and cylinders, installed new plugs, and tried to start, cranks but it wouldn't fire.

With key on, ECU seems to function as expected. Check engine light comes on for 5 sec, then turns off

What I've done, with no luck:
Replaced ECU
Verified I now have fuel pressure (holds as expected when FP is primed, bleeds off slowly with key off)
Verified spark on all 4 by manually rotating CAS
Verified all injectors are firing by manually rotating CAS
Compression test (135,135,125,145) on a cold engine
MPI fuse is good
MPI relay tested good
CAS installed with notches aligned, Cyl 1 at TDC (dowels @ 12 o'clock, crank notch at TDC)

I would appreciate any ideas or advice in getting the car running again. I don't know what else it could be.

I've attached a log while cranking the car.
 

Attachments

  • no start log.2021.04.08-02.elg
    11.6 KB · Views: 9

iugrad92turbo

Supporting Member
12,594
649
May 22, 2007
Kalamazoo, Michigan


any codes on the ecu, you never know, what it could be internally are the injectors firing pull out and turn cas by hand and see if you have fuel. Fuel should be spraying out, even i did that and i needed to add more fuel with ecmlink to start my car.
sounds like spark issue to me if you have everything else, the cts sensor could be fouled, a ground on the ecu could be bad on the ecu, . if you have the basic three it shoud fire, keep looking our cars are quite old anything couild be wrong or look ok, and be faulty, you just never know.
 

Paul Nahas

Probationary Member
7
0
May 21, 2014
Calgary, AB_Canada
High impedance FIC 2150.
I didn't have this issue prior to the 525 install. I just swapped a Walbro 450 for a 525, and installed a braided feed line.



any codes on the ecu, you never know, what it could be internally are the injectors firing pull out and turn cas by hand and see if you have fuel. Fuel should be spraying out, even i did that and i needed to add more fuel with ecmlink to start my car.
sounds like spark issue to me if you have everything else, the cts sensor could be fouled, a ground on the ecu could be bad on the ecu, . if you have the basic three it shoud fire, keep looking our cars are quite old anything couild be wrong or look ok, and be faulty, you just never know.
No codes on ECU. I do have fuel pressure, both on gauge and pressure sensor. I rotated the CAS by hand, and i do have pulse and spark. i pulled the rail, and visually see fuel spray from each injector. I pulled plug wires and verified spark.
The ECU i swapped in was inspected by ECM Tuning, and appears to be operational.
Seems to be a timing issue? I have spark, pulse and compression, but with timing marks at TDC, and CAS installed correctly, i can't get it to fire.

CTS appears to be reading correctly on the log.
 

iugrad92turbo

Supporting Member
12,594
649
May 22, 2007
Kalamazoo, Michigan
it has compression if timing is on it should start, gonna have to keep digging on it. Add more fuel to link play with it to see if it will start does it puff or like it wants too. If all three are there it has no choice but to start, on of those three things arent enough , enough fuel, spark issue still or compression is inaccurate. problems happpen when we upgrade these cars one thing gets changed then, oh we say it did have a issue before. Idk swap the 450 back in but you already have fuel at the rail, and injectors are spraying so rule t hat out, well spark, or compression.
 

iugrad92turbo

Supporting Member
12,594
649
May 22, 2007
Kalamazoo, Michigan
Yeah fuel is something you can see and hear to veryify its working, seems fuel related since you changed fuel out, ,are the injectors cleaned or new if i missed it. They could be stuck or closed, i had 3 that were closed i had to get cleaned out.
 

Paul Nahas

Probationary Member
7
0
May 21, 2014
Calgary, AB_Canada
If you turned the pump on via link and you see fuel in the intake manifold, you have a stuck open injector or leaking fpr as mentioned above.
With pump activated in Link, fuel rail pulled, injectors are not stuck open. I also pulled the reference line from FPR, and no leaks.
 

TK's9d2TSi

Supporting Member
4,683
1,937
Sep 11, 2017
Cincinnati, Ohio
With pump activated in Link, fuel rail pulled, injectors are not stuck open. I also pulled the reference line from FPR, and no leaks.
You have no fuel pressure? There’s no other way for the fuel to get in your manifold. Is it possible you have the injector wires crossed? What does the gauge read when you turn the pump on?

Check over your work. Maybe you forgot to connect something.
 

Paul Nahas

Probationary Member
7
0
May 21, 2014
Calgary, AB_Canada
You have no fuel pressure? There’s no other way for the fuel to get in your manifold. Is it possible you have the injector wires crossed? What does the gauge read when you turn the pump on?
I do have fuel pressure now. the issue with fuel getting into the manifold has been resolved. i believe my old ECU must have grounded out, leaving the injectors stuck. I replaced the ECU, and now holding pressure. Both the gauge and fuel pressure sensor read around 43 Psi with pump activated.
 

TK's9d2TSi

Supporting Member
4,683
1,937
Sep 11, 2017
Cincinnati, Ohio
So your issue now is crank, no start and you have fuel pressure and spark? After you crank the engine, smell the plugs. It should smell like fuel. Try spraying starter fluid in the IM to see if it starts.

Do you have another CAS you can try? In your log, timing is stuck at 5* but I'm not sure if that's because the idle is so low.
 

Paul Nahas

Probationary Member
7
0
May 21, 2014
Calgary, AB_Canada
So your issue now is crank, no start and you have fuel pressure and spark? After you crank the engine, smell the plugs. It should smell like fuel.

Do you have another CAS you can try? In your log, timing is stuck at 5* but I'm not sure if that's because the idle is so low.
Yes, plugs smell of fuel. these are new BR8ES plugs. # 1, 2 and 3 still look new. #4 has evidence of combustion.

I installed another CAS, with same results.
Also replaced PTU, plug wires and coil pack.
 

Paul Nahas

Probationary Member
7
0
May 21, 2014
Calgary, AB_Canada
could be something simple but did you align the cas 180. with the crankshaft dowel.
It's gotta be. Car was running just fine before the fuel upgrades. Only issue was base fuel pressure dropping at 35 psi boost, as the 450 couldn't keep up. I'll check the CAS again, but I'm positive I installed with #1 cylinder at TDC, cam dowels at 12'oclock, crank notch at TDC mark, and notches on CAS aligned. I even marked position of CAS on head before removing it.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com OHM Racing Raven Fabrication RixRacing RockAuto RTM Racing SouthBay Fuel Injectors STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top