1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

2G Starts and runs for 30 seconds, then dies

Posted by ohlegend, Dec 26, 2013

Please Support STM Tuned
Please Support Southbay Fuel Injectors
  1. ohlegend

    ohlegend Proven Member

    551
    41
    Joined Apr 2, 2012
    Pemberville, Ohio
    After I found a massive air leak between my header and turbo, the car has made some progress. (FYI I bought a 2G the sat for 2 years and needed to be put back together. ) The problem is I cant keep it running. I will start it up, it will idle great for 30 seconds, then die. I am able to start the car right up again.
    Each time I do it, it is 30 seconds, then it dies.

    I have replaced:
    Spark plugs
    alternator
    spark wires
    blocked off the fiav
    new tps
    fuel filter
    fuel pump
    injectors
    fixed and ported the head (had 6 bend valves)
    The motor has 0 miles on it
    Turbo is new
    I cleaned the throttle plate and body
     

    Street Build 6K  14  6

    1998 Mitsubishi Eclipse GST
    fwd · automatic · 2G DSM
    ohlegend

    820  0

    1998 Mitsubishi Eclipse GST
    automatic · 2G DSM
    Loading...
  2. squid267

    squid267 Proven Member

    107
    2
    Joined Jan 14, 2012
    Worcester, Massachusetts
    Just fixed this on mine. Ended up being a boost leak. Are you postive its not a leak? Otherwise check ISC. Maybe you have a kaput sensor.
     
  3. Jay Cooper

    Jay Cooper Probationary Member

    15
    0
    Joined May 8, 2013
    Pittsburgh, Pennsylvania
    Sounds like a post maf vacuum leak. The car will fire up on base values and then tries to idle down. Its probably going super lean do to unmetered air flow and konking out.
     
  4. ohlegend

    ohlegend Proven Member

    551
    41
    Joined Apr 2, 2012
    Pemberville, Ohio
    Would it help if I uploaded a video when I get home tonight?
     

    Street Build 6K  14  6

    1998 Mitsubishi Eclipse GST
    fwd · automatic · 2G DSM
    ohlegend

    820  0

    1998 Mitsubishi Eclipse GST
    automatic · 2G DSM
    Loading...
  5. thomcasey

    thomcasey Proven Member

    777
    25
    Joined Dec 16, 2009
    Indianapolis, Indiana
    Yes it would. Definitely sounds like a bad/disconnected MAF or a post MAF boost/vacuum leak.
     

    Street Build 237  2

    1992 Mitsubishi Galant VR-4
    awd · manual · Galant VR-4
    Loading...
  6. ohlegend

    ohlegend Proven Member

    551
    41
    Joined Apr 2, 2012
    Pemberville, Ohio

    Street Build 6K  14  6

    1998 Mitsubishi Eclipse GST
    fwd · automatic · 2G DSM
    ohlegend

    820  0

    1998 Mitsubishi Eclipse GST
    automatic · 2G DSM
    Loading...
  7. bw2277

    bw2277 Proven Member

    30
    0
    Joined Mar 18, 2013
    north bend, Oregon
    Did you have the throttle body off? Mabye need to reset tps and biss screw?
     
  8. tomsoftail

    tomsoftail Probationary Member

    6
    0
    Joined Dec 22, 2013
    No Shore, Massachusetts
    The idle seems higher than 1000 rpm, at least from my couch. Leak after MAF would make the mot sense.
    I would ohm out the sensor. Put your testers to 10000 then see if your reading is okay. If it gives you infinity resistance then you know your sensor crapped the bed.
     
  9. untouchablecc

    untouchablecc Proven Member

    693
    7
    Joined Mar 21, 2008
    Mt. pleasant, Pennsylvania
    I would start here. Tps has a voltage range/sweep for it to work properly. For the biss screw I ususally screw it all the way in and then back it out 3 complete turns and use that as my base point for idle.
     

    647  0

    1996 Eagle Talon TSi AWD
    manual · 2G DSM
    Loading...
  10. ohlegend

    ohlegend Proven Member

    551
    41
    Joined Apr 2, 2012
    Pemberville, Ohio
    I have an update.
    The MAF sensor was bad and I found a big leak at the Intake manny.
    Apparently the gasket was not the right size, and it was paper.
    I have a new felpro gasket that I am going to be putting on it tomorrow.

    BTW: Boost test passed, Vac test failed at the intake manifold.
     

    Street Build 6K  14  6

    1998 Mitsubishi Eclipse GST
    fwd · automatic · 2G DSM
    ohlegend

    820  0

    1998 Mitsubishi Eclipse GST
    automatic · 2G DSM
    Loading...

Share This Page

Support Vendors who Support the DSM Community
ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory