1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

wally 255 malfuction?

Posted by NewTurboTuner, Jun 18, 2008

Please Support STM Tuned
Please Support STM Tuned
  1. NewTurboTuner

    NewTurboTuner Proven Member

    385
    19
    Joined Jul 21, 2006
    Rslv, Arkansas
    Something is going on with my fuel pump, or fuel pump relay? ....I don't know? Maybe ECU?

    When I turn my key to the ON position, my fuel pump does not turn on to prime the motor.
    BUT when I try to start the car, the pump turns on for the initial start-up, but then turns off after about 5-10 seconds.... then the car dies from lack of fuel. I can try to start the car over and over, and the pump still only turns on for the initial start-up, then turns off. I can hear a click or switch when it switches on/off. The click is coming from somewhere near the driver side dash.

    Has anyone had this happen before?

    I didnt have time to look the car over last night. I pulled the battery, checked the relay, and my ground wires but everything looked good. I plugged it all back together and nothing changed ....still the same thing. I did not check any fuses yet.... I didnt have time.

    I'll look everything over later today. It'd be nice if someone could give me a hint, or something
     

    855  6

    1991 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  2. Rob10_99

    Rob10_99 Proven Member

    1,659
    3
    Joined May 22, 2005
    Ptown, Arizona
    That sounds like an issue with Nissans or any other car with a security keychip.
    But your car obviously doesnt have that.
    Where did you get the power for the relay?
    My guess is off the "start" wire on your ignition?
     

    1K  0

    1998 Eagle Talon TSi AWD
    29.320 @ 55.000 · 2G DSM
    Loading...
  3. 1992awdlaser

    1992awdlaser Proven Member

    2,731
    17
    Joined Dec 5, 2004
    Wallace, North Carolina
    On 1g's the fuel pump does not turn on until the engine is cranking. No 1g came from the factory with a fuel pump that turns on when the key is in the on position. The fuel pump turns on when the cas turns.

    Is the clicking constant or does it do it at certain times?
     
  4. NewTurboTuner

    NewTurboTuner Proven Member

    385
    19
    Joined Jul 21, 2006
    Rslv, Arkansas
    I have AEM EMS.
    The clicking is consistant, and regular.
    Its the same sound, at the same time, all the time.
     

    855  6

    1991 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  5. NewTurboTuner

    NewTurboTuner Proven Member

    385
    19
    Joined Jul 21, 2006
    Rslv, Arkansas
    I located the clicking sound ....its the big relay under the radio, near the floor.

    Usually when I turn the ignition on, I hear this relay click on, and the pump primes the motor before I start the car. Now it dosent click on and prime the motor when I turn the ignition on.

    The odd thing is though.... when I try to start the car, the pump turns on for the start-up, but then I hear the switch click off (pump turns off) and the car dies due to lack of fuel. Each time I try to start the car, It starts for a few seconds, the switch clicks off, and the car dies. It happens in a consistent manner too.... The switch always turns off at the same time after I start the car (like 5 seconds after):confused:
     

    855  6

    1991 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  6. Rob10_99

    Rob10_99 Proven Member

    1,659
    3
    Joined May 22, 2005
    Ptown, Arizona
    My car starts the fuel pump with key "on".
    What sensor are you using for aem? the stock cas sensor?

    I'm asking if your using the 'plug and play' replacement version of AEM, and not a hackjob standalone from years ago.
     

    1K  0

    1998 Eagle Talon TSi AWD
    29.320 @ 55.000 · 2G DSM
    Loading...
  7. 1992awdlaser

    1992awdlaser Proven Member

    2,731
    17
    Joined Dec 5, 2004
    Wallace, North Carolina
    And you have a 2g. No 1g came from the factory set up like that.


    I would have to suspect something with the ecu if it is a plug in one.
     

Share This Page

Support Vendors who Support the DSM Community
Archer Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory WheelWell.com