The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

  • Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;) It will also allow you to view images in threads.

Please Support ExtremePSI
Please Support STM Tuned

2G Power door lock issue

Jesse breezy

Probationary Member
4
0
Mar 17, 2019
Columbus, Indiana
So I have had a python security system in the car scince I've had. It. And all of the sudden a few days ago the driver side will not unlock with the power locks but will lock just fine. But now the stock security system will not show as disengaged so when I unlock it manually. The car alarm will go off so I have to put the key in the trunk. And idea on why it stopped working. Do I have to replace the actuator the relay I already took everything off and followed the harness. No damage no corrosion and it's been bothering me for days thanks in advance
 

AWDPetmitsu

Proven Member
1,044
11
Jan 26, 2003
., Pennsylvania
Check for power to the lock actuator when unlocking. If there is power, then your lock actuator is probably defective. But first, remove the door panel and observe the linkages as you unlock it. Check for anything jamming the rod or linkages or for any seizing and try lubing every part that moves first ad recheck.
 

Jesse breezy

Probationary Member
4
0
Mar 17, 2019
Columbus, Indiana
So far I've got a new actuator still the same thing. The relay behind the radio was not clicking for unlock tried swapping with a new one and the one from the back drivers panel still didnt work my Freind in maintenance at my job says it might be a ground but I havent had time to check where the ground goes and I have a factory service manual and it isnt to specific about locations either. Do you think it could be a ground or something different
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned VR Speed Factory

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top