1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

ECMlink Check engine light on, no codes

Posted by Trooth420, Mar 31, 2020

Please Support STM Tuned
Please Support Rix Racing
  1. Trooth420

    Trooth420 Probationary Member

    5
    0
    Joined Mar 5, 2014
    Central, New Jersey
    I recently having a problem with check engine light staying on. Before this problem I accidentally wired my wideband to knock sensor to the ecu. I disconnected the wire to the wideband output. Run DTC on ecmlink and not detecting any codes. I had swap out ecu and CAS still having same issue with engine light staying on on every startup. Light cycles though when flip the key on to second position like normal but soon as you start it light stays on with no codes. Anyone experience this car seems to be running fine but can't seem to figure out what happen. Thanks for any help.
     

    Street Build 605  0

    1996 Eagle Talon TSi AWD
    manual · 2G DSM

    302  0

    1995 Eagle Talon TSi AWD
    · 2G DSM
    Loading...
  2. TK's9d2TSi

    TK's9d2TSi Supporting Member

    2,846
    1,056
    Joined Sep 11, 2017
    Cincinnati, Ohio
    In link there’s a “dash” tab, what do you the cel set to?
     

    341  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    369  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 3K  6

    1992 Eagle Talon TSi AWD
    12.625 @ 111.42 · 1G DSM
    Loading...
  3. Trooth420

    Trooth420 Probationary Member

    5
    0
    Joined Mar 5, 2014
    Central, New Jersey
    Knock CEL set 3 degree
    Boost gauge set to knock
     

    Street Build 605  0

    1996 Eagle Talon TSi AWD
    manual · 2G DSM

    302  0

    1995 Eagle Talon TSi AWD
    · 2G DSM
    Loading...
  4. TK's9d2TSi

    TK's9d2TSi Supporting Member

    2,846
    1,056
    Joined Sep 11, 2017
    Cincinnati, Ohio
    Did you hook the knock sensor wire back up? Boost gauge sits at zero? Try disconnecting the knock sensor and see what happens
     

    341  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    369  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 3K  6

    1992 Eagle Talon TSi AWD
    12.625 @ 111.42 · 1G DSM
    Loading...
  5. Trooth420

    Trooth420 Probationary Member

    5
    0
    Joined Mar 5, 2014
    Central, New Jersey
    Yes boost gauge sits at zero I double check the wires all connected, all I did was tap a wire from knock sensor, even cut the wire and redid the wiring to knock sensor. If I disconnected the knock sensor in the engine bay, i get a knock sensor 1 circuit malfunction code. Reconnect clear codes light still on with no codes
     

    Street Build 605  0

    1996 Eagle Talon TSi AWD
    manual · 2G DSM

    302  0

    1995 Eagle Talon TSi AWD
    · 2G DSM
    Loading...
  6. TK's9d2TSi

    TK's9d2TSi Supporting Member

    2,846
    1,056
    Joined Sep 11, 2017
    Cincinnati, Ohio
    Also try clearing it through link. Looks like pin 36 green/red wire triggers the light when it’s grounded. See if that wire is grounded.
     
    Last edited: Mar 31, 2020

    341  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    369  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 3K  6

    1992 Eagle Talon TSi AWD
    12.625 @ 111.42 · 1G DSM
    Loading...
  7. Trooth420

    Trooth420 Probationary Member

    5
    0
    Joined Mar 5, 2014
    Central, New Jersey
    I will check that in a few and report back thanks
     

    Street Build 605  0

    1996 Eagle Talon TSi AWD
    manual · 2G DSM

    302  0

    1995 Eagle Talon TSi AWD
    · 2G DSM
    Loading...
  8. Trooth420

    Trooth420 Probationary Member

    5
    0
    Joined Mar 5, 2014
    Central, New Jersey
    Updated: check all wiring everything was fine. Started the car and took a few more cranks then normal to start, notice the light blinking and flickering then stay on solid, I went to front of the car and disconnect my coolent temp sensor and check engine light and it was off, shortly after went for a spin, and got a code for coolent temp. Replaced the temp sensor light went away, and got no codes now, just weird because I never had one die out on me without throwing a code. Guess it was dying slowly
     

    Street Build 605  0

    1996 Eagle Talon TSi AWD
    manual · 2G DSM

    302  0

    1995 Eagle Talon TSi AWD
    · 2G DSM
    Loading...
  9. TK's9d2TSi

    TK's9d2TSi Supporting Member

    2,846
    1,056
    Joined Sep 11, 2017
    Cincinnati, Ohio
    Good that you got it figured out. Never heard a cts do that.
     

    341  3

    2000 Jeep Cherokee Sport - Classic
    awd · automatic · Misc Vehicles

    369  4

    93 Civic 4 Door -sold-
    fwd · manual · Misc Vehicles

    Street Build 3K  6

    1992 Eagle Talon TSi AWD
    12.625 @ 111.42 · 1G DSM
    Loading...
  10. jed344

    jed344 Supporting VIP

    666
    70
    Joined Jan 10, 2008
    Waterville, Iowa
    Many years ago I had a dying coolant temp sensor not throw a code but cause car to run like crap from it randomly reporting different temps.
     

    1K  26

    1997 Mitsubishi Eclipse GSX
    awd · manual · 2G DSM
    Loading...

Share This Page

Support Vendors who Support the DSM Community
ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory