1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

ECMlink Car runs lumpy ...see anything outta wack in my files?

Posted by NewTurboTuner, Feb 6, 2013

Please Support Feal Suspension
Please Support Feal Suspension
  1. NewTurboTuner

    NewTurboTuner Proven Member

    385
    19
    Joined Jul 21, 2006
    Rslv, Arkansas
    I recently upgraded to a Walbro 450, 2150cc injectors, New AFPR, JMF Drag Intake, and Taylor 10.4mm wires.

    Car runs very lumpy!
    At 1st I really thought one cylinder was not firing (Sounds like a subaru). But each cylinder "seems" to be getting fuel, and spark.

    All Spark plugs seem to show indication of fuel delivery (slightly wet, and all are getting fouled)

    All wires are delivering spark (I can get spark to jump through the wires onto the valve cover)

    Coils seem to be firing (although coil on 2-3 seem to be easier to get spark jumping through the wires)

    If I pull one wire on any one cylinder the car runs ruff'r. Never does it sound the same if I pull any plug wires off (which would seem to indicate that each cylinder is firing)

    Cold Compression check shows 167 across all 4 cyls.

    Each Spark plug fouls very quickly and very dirty.
    I clean the plugs very clean, and after just 2-3 minuets of the car running they are all equally very black. (picture is attached).

    Turning the fuel pump on with ECMlink... Fuel Pressure Regulator is set at 42.6psi

    Here's a video of it running
    [ame=http://www.youtube.com/watch?v=j8-UlejoE-k]Funny business - YouTube[/ame]
    Looking at this it really seems to look and sound like its running on 3-cyl.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Can ya'll look at my log and settings to see if anything is really out of place???


    Someone mentioned I may have the injectors wired wrong?
    When wiring the connectors on... I was under the impression it did not matter which wire I wired (plus and negative).


    What else can I check?


    This is becoming very frustrating
    ..................Any Help would be greatly appreciated!
     

    Attached Files:

    855  6

    1991 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  2. renovatdkitchen

    renovatdkitchen Proven Member

    495
    22
    Joined Sep 25, 2011
    Toronto, ON, Canada
    Check your TPS settings. Seems in your log, it never hits zero
     

    Street Build 684  4

    1999 Mitsubishi Eclipse Spyder GST
    awd · manual · 2G DSM

    Street Build 5K  15

    1998 Mitsubishi Eclipse Spyder GST
    11.568 @ 123.87 · 2G DSM

    Street Build 2K  5

    1992 Eagle Talon TSi AWD
    12.790 @ 105.14 · 1G DSM
    Loading...
  3. NewTurboTuner

    NewTurboTuner Proven Member

    385
    19
    Joined Jul 21, 2006
    Rslv, Arkansas
    TPS is good from 0-100%

    Log doesnt show anything at 0% because car won't idle very good. I gave it some gas.
     

    855  6

    1991 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  4. renovatdkitchen

    renovatdkitchen Proven Member

    495
    22
    Joined Sep 25, 2011
    Toronto, ON, Canada
    Hmm. I had a problem very similar. Unfortunately I changed a couple things and dont quite remember what did the trick.

    I know I adjusted:
    TPS
    That screw that stops the throttle body from fully closing
    Throttle Cable (the tension)
    ISC settings in the "direct access" tab
    The BISS screw
    Injector deadtime

    Hopefully someone else with more experience will chime in.
     
    Last edited: Feb 6, 2013

    Street Build 684  4

    1999 Mitsubishi Eclipse Spyder GST
    awd · manual · 2G DSM

    Street Build 5K  15

    1998 Mitsubishi Eclipse Spyder GST
    11.568 @ 123.87 · 2G DSM

    Street Build 2K  5

    1992 Eagle Talon TSi AWD
    12.790 @ 105.14 · 1G DSM
    Loading...
  5. Lou98GSX

    Lou98GSX Proven Member

    663
    47
    Joined Mar 13, 2004
    Carmel, New York
    looks like your runing very rich . you should go over all your settings and make sure they are right .
     
  6. NewTurboTuner

    NewTurboTuner Proven Member

    385
    19
    Joined Jul 21, 2006
    Rslv, Arkansas
    looking over all my settings is what Im asking help with.

    I've done and checked about everything I can think of
     

    855  6

    1991 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  7. renovatdkitchen

    renovatdkitchen Proven Member

    495
    22
    Joined Sep 25, 2011
    Toronto, ON, Canada
    What brand are your injectors?
     

    Street Build 684  4

    1999 Mitsubishi Eclipse Spyder GST
    awd · manual · 2G DSM

    Street Build 5K  15

    1998 Mitsubishi Eclipse Spyder GST
    11.568 @ 123.87 · 2G DSM

    Street Build 2K  5

    1992 Eagle Talon TSi AWD
    12.790 @ 105.14 · 1G DSM
    Loading...
  8. snowborder714

    snowborder714 Moderator

    12,071
    223
    Joined Oct 15, 2006
    Mechanicsburg, Pennsylvania
    ^FIC, according to his profile.


    I'm curious how your car is running with basically no deadtime adjustment.

    Your SDAirflowPerRev is sky high. That value should be down around .25, just as normal AirflowPerRev should be when using a MAF/MAS. You need to address your idle tuning (see the videos on ECMTuning's website).
     

    3K  0

    1995 Mitsubishi Eclipse GST
    12.529 @ 110.820 · 2G DSM
    Loading...
  9. renovatdkitchen

    renovatdkitchen Proven Member

    495
    22
    Joined Sep 25, 2011
    Toronto, ON, Canada
    That's what I was wondering about not seeing any deadtime. Found this log on the ecmlink forums. He is also running FIC 2150cc injectors. I'd say use his deadtime settings and give it a try. (Just a suggestion)
     

    Attached Files:

    Street Build 684  4

    1999 Mitsubishi Eclipse Spyder GST
    awd · manual · 2G DSM

    Street Build 5K  15

    1998 Mitsubishi Eclipse Spyder GST
    11.568 @ 123.87 · 2G DSM

    Street Build 2K  5

    1992 Eagle Talon TSi AWD
    12.790 @ 105.14 · 1G DSM
    Loading...
  10. NewTurboTuner

    NewTurboTuner Proven Member

    385
    19
    Joined Jul 21, 2006
    Rslv, Arkansas
    My Global dead time has been from 450 (where it was with my 1000's) down to 170 where someone else with 2150's had it, and now down to zero... which someone said global dead time is controlled in the injector battery adjustment (InjBatteryAdj in Direct Access) settings.
     

    855  6

    1991 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...
  11. renovatdkitchen

    renovatdkitchen Proven Member

    495
    22
    Joined Sep 25, 2011
    Toronto, ON, Canada
    Ah, okay. Well, those points there are the only ones I could think of. Took me a while to adjust my 1450cc's and my S90 TB.
     

    Street Build 684  4

    1999 Mitsubishi Eclipse Spyder GST
    awd · manual · 2G DSM

    Street Build 5K  15

    1998 Mitsubishi Eclipse Spyder GST
    11.568 @ 123.87 · 2G DSM

    Street Build 2K  5

    1992 Eagle Talon TSi AWD
    12.790 @ 105.14 · 1G DSM
    Loading...
  12. Calan

    Calan DSM Wiseman

    6,015
    268
    Joined Jan 16, 2007
    OKC, Oklahoma
    Actually, OP is running PIG rich...to the point that his wideband is pegged as low as it will read. Based on that and the way those plugs look, I'm surprised the car will idle at all.

    ***

    http://www.dsmtuners.com/forums/ecm...efore-you-ask-ecmlink-dsmlink-log-advice.html

    BTW - Why do you have the ECU locked in open loop?
     

    3K  0

    1992 Eagle Talon TSi AWD
    15.2 @ 89.300 · 1G DSM
    Loading...
  13. c2ypt1c

    c2ypt1c Proven Member

    934
    73
    Joined Dec 5, 2009
    Southern, California
    Correct, it doesn't matter which way you wire them. However, and this is a shot in the dark but I just want to rule it out, did you eliminate/bypass the resistor pack?
     

    2K  18

    1997 Mitsubishi Eclipse GSX
    awd · manual · 2G DSM
    Loading...
  14. NewTurboTuner

    NewTurboTuner Proven Member

    385
    19
    Joined Jul 21, 2006
    Rslv, Arkansas
    Just wanted to update this (although I'm a bit embarrassed about it)

    Boost line from the bottom if my Intake Manifold to the MAP sensor had come undone. I couldn't see it because all my wiring and sensors are hidden under the intake. Only way I found it was by getting frustrated enough that I decided to take everything out so I could check my wiring/sensors. A pain in the butt and I get real dumb once I saw the boost line off the MAP sensor.

    Anyways thanks to everybody who helped. & Add check MAP sensor to the reasons why a 4g63 might sound like a Subaru LOL
     

    855  6

    1991 Mitsubishi Eclipse GSX
    automatic · 2G DSM
    Loading...

Share This Page

Support Vendors who Support the DSM Community
Archer Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory WheelWell.com