1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

bad engine oil cooler?

Posted by lycan1385, Jul 11, 2010

Please Support ExtremePSI
Please Support STM Tuned
  1. lycan1385

    lycan1385 Probationary Member

    6
    0
    Joined Jul 9, 2010
    Edison, New Jersey
    Hi, i'm new to this forum. I own a 99 Eclipse GST auto. My car is pretty stock, with bolt on's like a turboback exhaust and an airfilter.
    A few months ago i noticed the oil sign coming on when i was idling or in slow moving traffic. It would disappear when i started driving. My car has a rebuilt head, stock bottom end with 158 k miles on it and a factory turbo with about 10 k miles on it. So my friend (a suburu mechanic) suggested i use non synth thick oil in it, and he added some 15w-40. When i saw the oil sign coming on, i thought it was because it was non synthetic and as far as i know, this car needs synthetic. So i got some castrol edge 10w-30 and got an oilchange. But the oil sign started coming on at idle and in traffic even then. And when the oil sign comes on, it flashes on and off for the most part, then stays on all the time at idle.
    My friend thinks its the engine oil cooler, its unable to cool the engine oil when my car is idling. Last 2 weeks apart from the oil sign my engine temperature is rising to 3/4ths up the gauge and even if i let the car idle for 10 mins before shutting it down, it doesnt cool down. The temperature only comes down while driving at speeds over 50 mph with no car in front of me. If there were traffic or a car in front of me(even if it were 40-60 ft away), temp reaches 3/4th of the gauge even while driving.
    A second problem is that about 10 minutes of driving my battery and brake sign come on; they both keep disappearing and reappearing for a few seconds and finally come back on and then stay on till car is turned off. A few months ago my friend had mentioned that my battery cable was corroding and he fixed it temporarily. Could that be it or is it something else.

    i dont know if this is related, but at low speed when the auto transmission shifts from 1st to 2nd or 2nd to 3rd, i hear and feel a loud "thud" noise from the floor of the car. i know my transmission is not in good shape, but does this have anything to do with the oil sign on dashboard and the engine temp rising so high?
     
  2. lq1driver

    lq1driver Proven Member

    158
    0
    Joined Dec 17, 2007
    painesville, Ohio
    you need to check the oil pressure with a mechanical gauge at the head and at the oil filter housing
     

    283  0

    1997 Mitsubishi Eclipse Spyder GST
    manual · 2G DSM
    Loading...
  3. LiquidX

    LiquidX DSM Wiseman

    6,607
    106
    Joined Sep 19, 2008
    Anywhere, Pennsylvania
    The oil light doesn't come on with temperature. Either the sender is failing or or it's a wiring issue. For your over heating issue, is your radiator full and is your resivore filled up properly too? Do your fans turn on at all?

    What color is the fluid in your radiator and with the car on do you see any bubbling in it?
     

    Street Build 3K  0

    1997 Eagle Talon TSi AWD
    manual · 2G DSM
    Loading...
  4. lycan1385

    lycan1385 Probationary Member

    6
    0
    Joined Jul 9, 2010
    Edison, New Jersey
    lq1 driver : i'll have to get back to you on that. i dont have the tools for it, i'll ask my friend to check it out.

    liquidx : what is the "sender"? My friend who did my oil change last, did say that my coolant was low and he refilled it. I'll have to get back to you on the color of the fluid in radiator and if it bubbles. But the car doesnt cool down even when the radiator fans are on. the temp keeps rising at idle, reaches 3/4th gauge and returns to a bit above half of the gauge, then rises again.
     
  5. lycan1385

    lycan1385 Probationary Member

    6
    0
    Joined Jul 9, 2010
    Edison, New Jersey
    radiator fluid looked like it had a green tint to it. It was filled till the cap. Is the reservoir the white can (looks like a half gallon milk can) behind and to the left of the radiator? It looked like it had the same greenish fluid like in the radiator, it was filled halfway.
     
  6. LiquidX

    LiquidX DSM Wiseman

    6,607
    106
    Joined Sep 19, 2008
    Anywhere, Pennsylvania
    Well it doesn't seem that your coolant system has any oil or exhaust (head gasket) which is good. It is possible that there is a blockage and I would start at the thermostat and go from there.

    There are 2 senders attached to the OFH. One looks like a bell and that connects to the factory gauge. The other sensor is a flatish round sensor and that is for the oil light.
     

    Street Build 3K  0

    1997 Eagle Talon TSi AWD
    manual · 2G DSM
    Loading...
  7. lycan1385

    lycan1385 Probationary Member

    6
    0
    Joined Jul 9, 2010
    Edison, New Jersey
    okay so i took my car to an autoshop (im to newb to diagnose stuff myself without tools or knowledge).
    And the list of parts needed are :-
    1) Oil Pressure sender unit
    2) Thermostat and gasket
    3)Alternator (the one in the car is not discharging)
    4) Front motor mount, even though only 2 months old, is not working correctly. A loud banging sound when driving at low speeds(2nd gear -> 3rd and vice versa and when reversing) is heard at the floor of the car.
    I told the guy at the shop i'll get the parts myself cos i didnt wanna get ripped off. Now that im looking online i cant find an " oil pressure sender unit", i can only find an "oil pressure switch".
     
  8. kimcheefists

    kimcheefists Proven Member

    308
    3
    Joined Nov 7, 2008
    Las Vegas, Nevada
  9. Colt4G63 also

    Colt4G63 also Proven Member

    2,674
    48
    Joined Jul 23, 2008
    Tonawanda, New York
    The sending unit is for the gauge, the switch is for the light. I believe you want the switch.
     

    Street Build 2K  0

    1990 Dodge Colt
    manual · 4G63t Swapped

    Street Build 1K  0

    1992 Mitsubishi Galant VR-4
    manual · Galant VR-4
    Loading...

Share This Page

Support Vendors who Support the DSM Community
ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory