The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support ExtremePSI
Please Support STM Tuned

420A 1998 Mitsubishi Eclipse GS lost power

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

AndrewAmezcua

Probationary Member
1
0
Oct 2, 2022
Hollister, California
Hi so I drive a automatic 1998 eclipse GS and was taking a trip to San Diego from up north. The car drove fine but as soon as we got to the grape vine the rpms were around 4x and I was having to floor it up the hill. The gauges then all dropped and there was no power going to the engine.

The electrical part was still on but now it just cranks over and doesn’t start. I’ve changed the fuel pump, spark plugs, coil pack and wires but still nothing.
 
Last edited by a moderator:
Set up a vehicle profile. I'm assuming this has the 420A engine? Have you verified the battery is good? Have you verified its actually getting fuel to the engine? Possible clogged fuel filter?
 
Last edited:
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top