The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support STM Tuned
Please Support Morrison Fabrication

2G speedometer isn’t reading speed accurately or at all

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

Mikey_Dsm

Probationary Member
20
7
Nov 1, 2021
Layton, Utah, Utah
I’ve looked all over the place on here and can’t seem to find a thread where it tells me what the issue could be. But what I’ve come down to is the speed sensor doesn’t work or the whole gauge cluster might be bad or, it’s something mechanical. The issue is it doesn’t read my speed accurately at all. Like it will immediately go to 60 mph and hover there no matter the gear I go into. I’m just stumped on what the issue is and how to fix it. I want to avoid taking it to a shop if I can fix it myself. Any and all help will be appreciated!
 
If its a 1g they are cable driven. 2g is a electrical component which could be wiring,cluster,vss or the vss gear. You can remove the vss and inspect the gears. On older hyundais the gear is plastic and the teeth would wear or crack.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top