The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support ExtremePSI
Please Support ExtremePSI

spark or fuel problems? Please help.

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

95burgundyesi

15+ Year Contributor
816
9
Feb 8, 2006
Rockford, Illinois
Last night I was driving and at 14 psi I felt a cut and a light poping while in boost. Almost like antilag, not fuel cut. Then this morning it turned over witha small back fire and sounded like it had a dead cylinder.

I thought maybe the plugs, so I pulled them and all 4 look to be fine but I changed them anyway. I pulled wires one at a time to cylinder 4 and 3 resulting in no change. Cylinders 2 and 1 however when pulled the engine killed. But eachw ire had enough spark to arc in the well.

Did a boost leak test and zero leaks :cool:

So I did a compression test and on a cold motor i got 152 across.

So I pulled the injectors off and im wondering what I should do next. Any ideas? I am about to put in my second set of 450s
 
Buy an additive that will clean your entire fuel system. It may solve the problem but if not at least you will have done something that's good to have done anyway.
 
You should check for spark at the plug of those two cylinders. If you have spark, unbolt the cas and turn it by hand and listen to the injectors of those two cylinders to see if they are clicking.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top