1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

No crank. Fuel relays? [video/pics]

Posted by MrNeedles, Feb 22, 2013

Please Support ExtremePSI
Please Support ExtremePSI
  1. MrNeedles

    MrNeedles Proven Member

    79
    0
    Joined Jan 17, 2009
    Chicago, Illinois
    Please help me out here guys.

    I just finished my auto 2g. When I turn the key to the accessory position I can here the fuel pump kick on, along with a loud clicking from some relays located on on the passenger side. I think they are the fuel pump relays. It will do this 3 times and then stop. I try to start the car but it wont even crank. I notice when I try to crank my car, the tach jumps slightly to 1000 and the fuel pump kicks on while i'm turning the key. Maybe grounding issue?

    I relocated the battery to the trunk, but other than that everything is the same. To relocate the battery, I ran 0 gauge from the starter> harness> 150a breaker> battery. The negative it grounded to the rear strut tower. My dash lights work and so do all of my accessories.

    I also don't know where this plug into:
    IMG_5248_zpsc1c688b3.jpg

    This is how I grounded these:
    IMG_1511_zpsf41697d1.jpg

    This is what is clicking:
    IMG_7666_zps171b6cbe.jpg

    Here is the video:

    [ame=http://youtu.be/VJ0aKny4alw]DSM relay clicking - YouTube[/ame]
    You can here the clicking clearly but the fuel pump is also kicking on in the same intervals as the clicking.
    any advice is appreciated.
     
    Last edited: Feb 22, 2013
  2. 1995silvergst

    1995silvergst Proven Member

    288
    1
    Joined Apr 21, 2010
    Cocoa, Florida
    That's the fuel and mpfi relays since the fuel pump is running may be the mpfi relay. Also the ground needs to be really well connected I would make sure your ground wire is bolted through the main unibody and the paint is stripped so the wire is on metal.
     
  3. crazyquik22023

    crazyquik22023 Proven Member

    641
    5
    Joined Sep 14, 2008
    Akron, Ohio
    Check to make sure you have no shorts in your battery wires. The same thing happened to my buddy's 2g last year. We originally thought it was a bad relay b/c it was clicking just like yours is, but it turns out his positive wire from his battery was rubbing against a corner of the body and the wires were exposed and shorting out.
     

    858  0

    1998 Mitsubishi Eclipse GST
    12.900 @ 115.000 · 2G DSM
    Loading...
  4. MrNeedles

    MrNeedles Proven Member

    79
    0
    Joined Jan 17, 2009
    Chicago, Illinois
    Alright, I got it fixed. I'm an idiot and didn't run an engine ground.
     
  5. 1995silvergst

    1995silvergst Proven Member

    288
    1
    Joined Apr 21, 2010
    Cocoa, Florida
    Glad it is fixed ant thanks for posting the fix!
     

Share This Page

Support Vendors who Support the DSM Community
ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory