1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Misfire at higher rpm idle?

Posted by volcomsnow245, Jul 14, 2011

Please Support Kiggly Racing
Please Support Rix Racing
  1. volcomsnow245

    volcomsnow245 Proven Member

    492
    0
    Joined May 4, 2011
    chicago, Illinois
    Hey guys just a little confused to why when I let my car warm up on hotwire on my safc, that it idles at about 1500 and you can here an occasional misfire but when I switch it back over to karmen the idle goes back down to 700 with no misfire. Also when I don't shift right away out of 1st gear (when i'm giving it a little gas) it feels like fuel cut it's weird.
     
    volcomsnow245

    432  0

    1992 Eagle Talon TSi AWD
    manual · 1G DSM
    Loading...
  2. joseph95

    joseph95 Probationary Member

    7
    0
    Joined Dec 6, 2009
    antioch, Tennessee
    have you checked anything out? plugs, wires, coil
     
  3. fast90eclipse

    fast90eclipse Proven Member

    229
    0
    Joined Jul 3, 2007
    OLYMPIA, Washington
    Or could b ## ignition too. Is ## timing dead on. Have u slowly pulled ## spark plugs up when its idling an see if all 4 r getting strong spark.
     

    300  0

    1992 Mitsubishi Galant VR-4
    manual · Galant VR-4
    Loading...
  4. jambro

    jambro Proven Member

    44
    0
    Joined Jul 18, 2011
    connellsville, Pennsylvania
    My 97 rs did this i checked everything and it turns out it was the fuel pump wasn't putting out enough pressure give that a look
     

    280  0

    1999 Mitsubishi Eclipse GST
    · 2G DSM
    Loading...
  5. volcomsnow245

    volcomsnow245 Proven Member

    492
    0
    Joined May 4, 2011
    chicago, Illinois
    Well I changed the spark plugs and noting changed the idle is still terrible and missfires at idlle. How would I take the wires off as it's idling will I damage something?
     
    volcomsnow245

    432  0

    1992 Eagle Talon TSi AWD
    manual · 1G DSM
    Loading...
  6. Nasty Dream

    Nasty Dream Proven Member

    455
    2
    Joined Aug 30, 2011
    Alexandria, Virginia
    Are you certain you gaped them correctly?

    Has this problem gotten progressively worse over a long period of time?
     

    778  0

    1995 Mitsubishi Eclipse GST
    manual · 2G DSM
    Loading...
  7. volcomsnow245

    volcomsnow245 Proven Member

    492
    0
    Joined May 4, 2011
    chicago, Illinois
    Yes I gapped them .28 and its stayed the same.
     
    volcomsnow245

    432  0

    1992 Eagle Talon TSi AWD
    manual · 1G DSM
    Loading...
  8. Nasty Dream

    Nasty Dream Proven Member

    455
    2
    Joined Aug 30, 2011
    Alexandria, Virginia
    I mean, what kind of juice are you getting to the plugs?

    I was just going to suggest something simple like replacing the 18 year old ground wires with something thicker. And add ground wires to a couple of other things. Total cost would be about $30 at worst if you hit up walmart for 6 or 4 gauge copper wire and lugs and cut them yourself.

    At the very least, it will help, and give you something to do while you wait for answers from the pros. :)

    I know you're supposed to replace ignition wires like every few years. Can't imagine ground wires would fair any better, especially with all that corrosion they are subject to.
     

    778  0

    1995 Mitsubishi Eclipse GST
    manual · 2G DSM
    Loading...
  9. volcomsnow245

    volcomsnow245 Proven Member

    492
    0
    Joined May 4, 2011
    chicago, Illinois
    which ground wires because my battery ground is in very good condition and my lights don't dim.
     
    volcomsnow245

    432  0

    1992 Eagle Talon TSi AWD
    manual · 1G DSM
    Loading...
  10. scott90gsx420

    scott90gsx420 Proven Member

    606
    3
    Joined Sep 25, 2010
    nampa, Idaho
    I also have a ""misfire"" Im starting to think mine is from either a bad injector or more likely a boost/vacuum leak as my wideband jumps lean when it ""misfires"".. It does it pretty consistently at idle or if im revving at a light or when im decelerating it does it too.. But cruising and boosting it doesn't do it that i can notice.. My lights dim when blinkers are on and stuff so im going to add a few grounds and see if that helps any advice is much appreciated..

    Sorry not trying to thread jack just need help also and figured id just add it hear and follow the thread..
     

    579  0

    1990 Mitsubishi Eclipse GSX
    · 1G DSM
    Loading...

Share This Page

Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing Raven Fabrication RixRacing RockAuto RTM Racing SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory