1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

ECMlink Fuel Pumps Cut Off With Throttle!?

Posted by tdykes1234, Dec 8, 2019

Please Support Southbay Fuel Injectors
Please Support VR-Speed Factory
  1. tdykes1234

    tdykes1234 Proven Member

    70
    0
    Joined Feb 12, 2013
    Columbus, Indiana
    So I installed my new throttle body today and while doing my tps adjustment with link, I discovered another issue the car seems to be having. With both fuel pumps running, when I would ease the throttle in and tps would read 3.6v, both pumps would shut off!? Now if I eased up on the throttle, the pumps would kick back on. If I tried to go past 3.6v, the pumps would start to come back on closer to WOT (5.00v). Battery was at 11.8v during the test, but would jump to 12.1 when the pumps kicked off. I'm at a loss here so any ideas would be great! Thanks everyone!!!
     
  2. motomattx

    motomattx Proven Member

    3,116
    1,106
    Joined Dec 9, 2010
    wampum, Pennsylvania
    It sounds like you have some parameter in the Link setup wrong, nothing should shut your pumps off at any time unless you set something to shut them off.
     

    Drag Race Build 4K  10  24

    1995 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM
    Loading...
    1990TSIAWDTALON and tdykes1234 like this.
  3. tdykes1234

    tdykes1234 Proven Member

    70
    0
    Joined Feb 12, 2013
    Columbus, Indiana
    Where would I look to find that?
     
  4. motomattx

    motomattx Proven Member

    3,116
    1,106
    Joined Dec 9, 2010
    wampum, Pennsylvania
    I'm not a link owner or user, so that question would be better answered by others on the site or at the Link forums, it may do that to go into the clear flood mode or something, how does it drive? it might not effect how it drives once it see's actual rpm's.
     

    Drag Race Build 4K  10  24

    1995 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM
    Loading...
  5. tdykes1234

    tdykes1234 Proven Member

    70
    0
    Joined Feb 12, 2013
    Columbus, Indiana
    I haven't driven it yet but before my throttle body blew I couldn't go full throttle. It would pull up to a point, but the minute I pushed the throttle in too far it would just stop like it was hitting fuel cut. Im thinking that its been doing this the whole time and I've just now discovered the actual issue. I was thinking it was a boost leak or something, but now I know that's not the case
     
  6. wrencher

    wrencher Proven Member

    360
    40
    Joined Nov 20, 2005
    Chicago, Illinois
    This is engine off?
    Obviously not stock configuration maybe a little info into how the pumps are wired?

    Link did add the fuel pump prime feature with the last firmware update.
    Are the pump(s) is wired to run engine off?
     
    1990TSIAWDTALON likes this.
  7. tdykes1234

    tdykes1234 Proven Member

    70
    0
    Joined Feb 12, 2013
    Columbus, Indiana
    The pumps are activated via key then switch
     
  8. Vegas Smith

    Vegas Smith Proven Member

    4,034
    1,884
    Joined Dec 2, 2002
    Houston, Texas
    Post a log.
     

    Street Build 4K  4

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
    1990TSIAWDTALON likes this.
  9. 1990TSIAWDTALON

    1990TSIAWDTALON Moderator

    6,881
    3,044
    Joined Nov 14, 2013
    Independence, Kansas
    TB seals could be shot.
    Log if you can.
     

    Street Build 5K  29

    1992 Eagle Talon TSi AWD
    14.74 @ 117.04 · 1G DSM

    2K  15

    1990 Mitsubishi Eclipse GSX
    awd · manual · 1G DSM

    932  18

    1967 Chevrolet Camaro RS
    rwd · automatic · Misc Vehicles

    Street Build 1K  7

    1998 Eagle Talon TSi
    fwd · manual · 2G DSM

    Street Build 6K  15  25

    1990 Eagle Talon TSi AWD
    13.620 @ 108.460 · 1G DSM
    Loading...
  10. wrencher

    wrencher Proven Member

    360
    40
    Joined Nov 20, 2005
    Chicago, Illinois
    Well if you wired a dual pump set up directly with a relay and switch, I find it hard to find a correlation to throttle input?

    Unless the relay circuit is activated by an ECU controlled output controlled by link?

    On a different note, not a big fan of running pumps entirely on physical switch input.
    What I'm meaning there is no safety built into the fuel pump control.
    OEM's wire electric fuel pumps in a certain way for safety.
    God forbid something happens but if an accident/wreck occurs the last thing needed is a fuel pump staying on to feed a potential fire.
     
  11. tdykes1234

    tdykes1234 Proven Member

    70
    0
    Joined Feb 12, 2013
    Columbus, Indiana
    Thanks for the responses guys! I am unfortunately unable to post a log because the laptop I own does not have a network card installed. Like you guys, this confuses the hell out of me. What information from link were you guys wanting to see or what else should I log to give you guys more input when I try to look at it again?
     
  12. Vegas Smith

    Vegas Smith Proven Member

    4,034
    1,884
    Joined Dec 2, 2002
    Houston, Texas
    Shell out the $50 it costs to get a laptop. It's too much energy to try and guess at what your setup is. How are the pumps powered?
     

    Street Build 4K  4

    1993 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
    tdykes1234 likes this.
  13. motomattx

    motomattx Proven Member

    3,116
    1,106
    Joined Dec 9, 2010
    wampum, Pennsylvania
    I 100% agree with this as far as safety goes, you really should allow the ecu to control the pump if you street drive the car, my goal over the winter is an on board fire suppression system in fact, I have wanted one forever but had other things that needed the cash at the time on the car, hopefully I can grab one over the winter and get it installed.
     

    Drag Race Build 4K  10  24

    1995 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM
    Loading...
    tdykes1234 likes this.
  14. tdykes1234

    tdykes1234 Proven Member

    70
    0
    Joined Feb 12, 2013
    Columbus, Indiana
    The pump in the tank and the inline pump are both activated by a single switch. Im working being able to do just that but money is tight at the moment after purchasing the new throttle body :(
     
  15. tdykes1234

    tdykes1234 Proven Member

    70
    0
    Joined Feb 12, 2013
    Columbus, Indiana
    UPDATE: I used the "Activate Fuel Pump" in link and when I hit the button, it shut off my inline fuel pump and turned on my intank fuel pump? So I unhooked the inline wondering if it was just too many amps or something. Deactivated the fuel pump on link, hit the switch, and only the intank pump came on as it should. Started to press the throttle and got to a certain point and the pump cut off. I could hear the relay powering off with the pump. So, out of curiousity, I reactivated the pump using link, flipped the switch, pump comes on, I press the pedal all the way to the floor and no cut off!? This is crazy!!!
     
  16. Murdertalon

    Murdertalon Proven Member

    346
    50
    Joined Jul 7, 2016
    East side, Washington
    Do you have a low battery? Maybe hook up a trickle charger or main charger bring battery voltage up.

    Is the inline pump wired to the same relay as the main?

    Mayby your drawing too much power from the battery and not enough left to run the inline pump or drawing too much amperage through relay and its failing.

    Did you do a rewire? I assume you did because you state running off a relay, but the factory fuel pump wire doesn't even support the factory pump with enough amps.
     

    432  1

    1991 Eagle Talon TSi AWD
    awd · manual · 1G DSM

    Street Build 3K  24

    1995 Eagle Talon TSi AWD
    awd · manual · 2G DSM
    Loading...
    tdykes1234 and lglracer like this.
  17. tdykes1234

    tdykes1234 Proven Member

    70
    0
    Joined Feb 12, 2013
    Columbus, Indiana
    I am thinking that may very well be the issue! I haven't checked to see if doing a different wiring setup will fix this issue or not but it's in the plans for this weekend! Battery was good during the tests I performed and I actually had a charger on it just to keep charge in the battery. Thanks for the idea my man!
     

Share This Page

Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing Raven Fabrication RixRacing RockAuto RTM Racing SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory