1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

ECMlink 2G Idle issues after converting from MAF to SD

Posted by adrian2627, May 24, 2020

Please Support VR Speed Factory
Please Support STM Tuned
  1. adrian2627

    adrian2627 Proven Member

    143
    4
    Joined Jul 13, 2005
    Hattiesburg, Mississippi
    Hi. Converted from factory 2g maf to speed density using aem 5 bar and gm iat sensor. My MAF tune was solid and idle was perfect. Upgraded turbos so decided to go SD and now during warm up, idle would start surging say 2-3 mins after starting in conjunction with O2 starting to cycle. Wb would read lean then rich back and forth to the point of car would sometimes stall. Would only stop as the car got warmer. This condition is worst during winter or when really cold outside. I’ve gone through the idle surge checklist and this isn’t it. I am fairly sure there is something in the tune I’m missing. Cruise and wot are great, idle once warm is perfect, just kind of annoying during warm up. I will include a log later I just figured to post now and see what’s out there. Mods as follows:

    20g mits on external wg
    Tial bov 50mm
    Fmic
    Aem 5 bar
    Gm iat
    Ecmlink v3
    Lc1 wb
    Mbc
    Evo3 intake manifold
    Hafe exhaust manifold
    Turbo back exhaust
    6 bolt lower, 7 bolt head
    Stock cams

    3287miles on rebuild, compression test 150 +/- on all four. boost leak test done and no leaks

    any help would be appreciated. I’ve searched and could find one that matches my case with a solution
     

    990  3

    1997 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM
    Loading...
  2. adrian2627

    adrian2627 Proven Member

    143
    4
    Joined Jul 13, 2005
    Hattiesburg, Mississippi
    here is the log. Didn't do it as bad on this log but the AFR target is off from what the wideband is displaying. Also you can see the lean-rich-lean oscillation on the wideband.
     

    Attached Files:

    990  3

    1997 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM
    Loading...
  3. adrian2627

    adrian2627 Proven Member

    143
    4
    Joined Jul 13, 2005
    Hattiesburg, Mississippi
    fully warm log with AFRatioEST and WB not lining up. Exhaust pops could be hear as well, WB correlates with popping
     

    Attached Files:

    990  3

    1997 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM
    Loading...
  4. Archer Fabrications

    Archer Fabrications Proven Member

    9,959
    962
    Joined May 9, 2011
    Scottsdale, Arizona
    (Without actually looking at your log) You most likely need to adjust the VE in the idle area, track datalog and see if the cells it’s using have a wide variance, if so make them closer together which ever direction your afr target likes
     

    986  17

    2006 Evo 9 MR
    awd · manual · Lancer Evolution
    Loading...
  5. adrian2627

    adrian2627 Proven Member

    143
    4
    Joined Jul 13, 2005
    Hattiesburg, Mississippi
    I did that once the car was fully warmed up and it did start matching up with the AFRest but couldn't get it to matchup during warm-up. Also, that wouldn't fix the lean-rich-lean oscillation I get during warm-up. Thank you for the reply and advice
     

    990  3

    1997 Mitsubishi Eclipse GST
    fwd · manual · 2G DSM
    Loading...

Share This Page

Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing Raven Fabrication RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory