1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Wont start for nothing..Everything replaced

Posted by kenuwine4g63, May 13, 2011

Please Support STM Tuned
Please Support Feal Suspension
  1. kenuwine4g63

    kenuwine4g63 Proven Member

    474
    31
    Joined May 26, 2009
    Charlotte, North Carolina
    Jesus!!! This car will not start to save humanity. It is a 95 talon with the original 7bolt block. The head has been rebuilt no leaks no nothing. Im using a 1g green top cas(jnz tuning-harness) head gasket is fresh. I have replaced the MPI fuse, engine coolant sensor, fuel pump, injector resistor box, transistor, coil pack, anything u can think of. I have compression, i have spark on all four, i have fuel to the rail. :banghead::banghead::banghead:. I can not figure this one out. my injectors has been inverted at the ecu(no link, no chip) my firing order is 2314
    4321. I Honestly do not know what to do. my mechanical timing is dead on not even half a tooth off. When i try to crank it, the rpm needle jumps as if its going to start but it never starts EVER. Should my firing order be 3241
    4321.
    I am completely lost and definetely need some guidance. :cry::cry::cry::cry:HELP!!!
     
    kenuwine4g63

    435  0

    1995 Mitsubishi Eclipse GST
    000.0 whp · 000.0 lb/ft · 2G DSM
    Loading...
  2. dragonov_elite

    dragonov_elite Proven Member

    224
    5
    Joined Jul 14, 2005
    La Crosse, Wisconsin
    I would check your cam angle sensor and try flipping the magnetic piece that goes into the cam. Just a thought.
     

    Street Build 1K  3

    1997 Mitsubishi Eclipse GSX
    awd · manual · 2G DSM

    707  0

    1997 Mitsubishi Eclipse GSX
    manual · 2G DSM
    Loading...
  3. kenuwine4g63

    kenuwine4g63 Proven Member

    474
    31
    Joined May 26, 2009
    Charlotte, North Carolina
    But i didnt install it 180* out
     
    kenuwine4g63

    435  0

    1995 Mitsubishi Eclipse GST
    000.0 whp · 000.0 lb/ft · 2G DSM
    Loading...
  4. zanderson

    zanderson Proven Member

    137
    1
    Joined Nov 21, 2010
    Brookings, South Dakota
    I would double check the CAS, never hurts. Hate for it to come down to something your swore was right. If that is wrong it would be trying to fire at the wrong time. Posibably fuel related, when we brought my friends 90 talon home it had a no start issue and we went through everything, had spark, fuel to the rail, injectors were good, good plugs, right firing oreder. Ended up being a piece to the fuel pump was missing and he wasn't able to get enough pressure to run on. Do you have a FPR?
     

    413  0

    1992 Mitsubishi Galant VR-4
    · Galant VR-4
    Loading...
  5. saechao04

    saechao04 Proven Member

    375
    3
    Joined Aug 8, 2006
    portland, Oregon
  6. kenuwine4g63

    kenuwine4g63 Proven Member

    474
    31
    Joined May 26, 2009
    Charlotte, North Carolina
    Yes I have the stock fpr. What peice to the fuel pump are you refering to.

    Which way did you turn the cas? Im going out today to turn the cas by hand and pull my injectors out to see if they fire. I have spark all day(strong spark way better than i had when i had the 95 sensors in). Today is trouble shooting
     
    kenuwine4g63

    435  0

    1995 Mitsubishi Eclipse GST
    000.0 whp · 000.0 lb/ft · 2G DSM
    Loading...
  7. 96WhiteTSi

    96WhiteTSi Proven Member

    106
    4
    Joined Mar 6, 2009
    Reno, Nevada
    Well.. on my 96 talon I know the exhaust cam gear has 2 timing marks.... Maybe you lined up the timing marks 180 out?? I did... and had the same problem as you are having.
     

    647  0

    1996 Eagle Talon TSi AWD
    manual · 2G DSM
    Loading...
  8. Maverick4g63

    Maverick4g63 Proven Member

    357
    1
    Joined Feb 28, 2011
    Laurel, Mississippi
    Do you have a way to verify your numerical fuel pressure value?
     
  9. kenuwine4g63

    kenuwine4g63 Proven Member

    474
    31
    Joined May 26, 2009
    Charlotte, North Carolina
    But theres only 1 dowel pin and its suppose to be facing 12'o clock. So nope thats not it.

    No way at all.

    OK,:ohdamn::cry::banghead:.....Made a mistake, Took the injectors out hook the harnesses back up took the spark plugs out and wires. i started turning the cas and BOOM!!! Car caught on fire. But with that being said, i didnt see any fuel coming out my injectors. The car caught fire because the injector blew off the fuel rail and gas started going everywhere. Im really sick of this sh**. Wut other car besides the evo and other dsms can i swap injectors with. Im asking because there is hardly no DSMs in these junk yards and definetely no Evos. I dont know if the rail has to build up a certain amount of pressure before the injectors fire or what. With it installed the injectors soaked my spark plugs. Could they just be stuck open?? Im just goin to sell it, i cant take it anymore
     
    kenuwine4g63

    435  0

    1995 Mitsubishi Eclipse GST
    000.0 whp · 000.0 lb/ft · 2G DSM
    Loading...
  10. Maverick4g63

    Maverick4g63 Proven Member

    357
    1
    Joined Feb 28, 2011
    Laurel, Mississippi
    Calm down man. I know its frustrating but hang in there. I seriously doubt you have four bad injectors. Your injectors should click when you spin the cas. If not then you need to check the incoming power to the cas and the output signal. I use an led test light to verify 5v sensor pulses.
     
  11. kenuwine4g63

    kenuwine4g63 Proven Member

    474
    31
    Joined May 26, 2009
    Charlotte, North Carolina
    when i turn the cas none of them clicked. The only thing that click is the spark plugs firing. But even with the original sensors it did the same exact thing. Couldnt hear them click. Its just pitiful man
     
    kenuwine4g63

    435  0

    1995 Mitsubishi Eclipse GST
    000.0 whp · 000.0 lb/ft · 2G DSM
    Loading...
  12. Maverick4g63

    Maverick4g63 Proven Member

    357
    1
    Joined Feb 28, 2011
    Laurel, Mississippi
    You need to verify that your getting the cas trigger pulse to the ecu on pin 88 with that led test light.

    tapatlak_1300365002868.jpg
     
  13. kenuwine4g63

    kenuwine4g63 Proven Member

    474
    31
    Joined May 26, 2009
    Charlotte, North Carolina
    how would i go about that i only have a volt/ohm meter
     
    kenuwine4g63

    435  0

    1995 Mitsubishi Eclipse GST
    000.0 whp · 000.0 lb/ft · 2G DSM
    Loading...
  14. Tyeler18

    Tyeler18 Proven Member

    2,070
    79
    Joined Dec 16, 2008
    Casa Grande, Arizona
    If they're not clicking then your problem is your injectors not firing. Go to your local autoparts store and buy a noid light (return it when you're done if you don't plan on using it again). Plug it into your injector harness and crank the car. That'll tell you if the injectors are actually pulsing.

    I'm the one who had the no start on the 90 talon. It ended up being the retaining cap in the fuel pump neck. Previous owner put a new pump in but only put the oring and plastic spacer on the pump, not the retainer cap. All my fuel pressure would bleed back into the tank without it, even though I was getting fuel inititally up to the rail, it wasn't enough to even spray out of the injectors (and trust me, it LOOKED like it had good fuel pressure).
     

    Drag Race Build 825  1

    1991 Eagle Talon TSi AWD
    awd · automatic · 1G DSM

    Road Race Build 804  0

    1990 Eagle Talon TSi AWD
    manual · 1G DSM

    Autocross Build 1K  0

    1998 Mitsubishi Eclipse GSX
    manual · 2G DSM

    Road Race Build 1K  0

    1991 Mitsubishi Galant VR-4
    manual · Galant VR-4
    Loading...
  15. Maverick4g63

    Maverick4g63 Proven Member

    357
    1
    Joined Feb 28, 2011
    Laurel, Mississippi
    Buy the noid light.
     
  16. kenuwine4g63

    kenuwine4g63 Proven Member

    474
    31
    Joined May 26, 2009
    Charlotte, North Carolina
    just forget it, injectors are working...compression is beyond repair. Im selling it. Im going to come back a little later, when funds are right

    heres the conclusion. I have fuel, spark, injectors are clicking..The only thing i havnt mentioned is compression. Im going to leave it at that. it was 60-50-50-50 before i changed the headgasket. the HG was the cause of those numbers. It acts a little better now, but still wont start
     
    kenuwine4g63

    435  0

    1995 Mitsubishi Eclipse GST
    000.0 whp · 000.0 lb/ft · 2G DSM
    Loading...
  17. zanderson

    zanderson Proven Member

    137
    1
    Joined Nov 21, 2010
    Brookings, South Dakota
    Its a DSM, going into any project your ALWAYS expect dificulty especially with a DSM there a headache and a half when the don't work right! a good way to check if the injectors are working properly is to get a 9 volt batery and a a set of aligator clips. Fill your fuel rail with fuel and give the injectors power. You will burn through the batery prety quick though if you don't get one of the big 9 volts. This is what we did on Tyeler18's car, then when we figured out they were firing we go a noid light and made sur they were getting powered by the car. if all that is good it is no doubt fuel pressure if everything you stated before is true. Sounds like compression could definately be the problem, if so put it aside for a while if need be and build it or find a used motor.
     

    413  0

    1992 Mitsubishi Galant VR-4
    · Galant VR-4
    Loading...
  18. kenuwine4g63

    kenuwine4g63 Proven Member

    474
    31
    Joined May 26, 2009
    Charlotte, North Carolina
    I understand that these cars are old. What i dont understand is that as soon as i broke those valves on my old head and put this head on, it dosnt want to start. Let me give you a run down. I drilled a hole in the original head, i bought another head i didnt take it to a machine shop or anything(previous owner did). i had everything except valves, springs, rocker arms and cams. I swapped everything over and the car started right up. I didnt torque the tensioner pulley bolt:ohdamn:, i rev the car and it jumped timing. Broke valves, i bought a entirely new head had everything done at the machine shop. Now it just gave way on me.
     
    kenuwine4g63

    435  0

    1995 Mitsubishi Eclipse GST
    000.0 whp · 000.0 lb/ft · 2G DSM
    Loading...
  19. Maverick4g63

    Maverick4g63 Proven Member

    357
    1
    Joined Feb 28, 2011
    Laurel, Mississippi
    Ever consider that your timing is causing low compression across the board?
     
  20. kenuwine4g63

    kenuwine4g63 Proven Member

    474
    31
    Joined May 26, 2009
    Charlotte, North Carolina
    My mechanical timing is dead on.

    I "THINK" I may have found out the problem. Not really sure though. i have a dead cell in my battery. So when i take it to O'reilly's and they charge it, it still dosnt have full charge:banghead:..I will be troubleshooting tomorrow(monday) too. So going to test my luck with battery and everything else
     
    kenuwine4g63

    435  0

    1995 Mitsubishi Eclipse GST
    000.0 whp · 000.0 lb/ft · 2G DSM
    Loading...
  21. Maverick4g63

    Maverick4g63 Proven Member

    357
    1
    Joined Feb 28, 2011
    Laurel, Mississippi
    Good luck man. Im still grinding my gears on this one. A perplexing problem indeed.
     
  22. kenuwine4g63

    kenuwine4g63 Proven Member

    474
    31
    Joined May 26, 2009
    Charlotte, North Carolina
    LOL..me too man. I hope this is the problem, along with those injectors too. I had it making black smoke, then i found out my injectors were'nt clicking. I believe they were stuck open, along with a dead cell in my battery. So i've been doin this lately:pray::pray::pray::pray:. We'll see!!
     
    kenuwine4g63

    435  0

    1995 Mitsubishi Eclipse GST
    000.0 whp · 000.0 lb/ft · 2G DSM
    Loading...
  23. robs90tsi

    robs90tsi Proven Member

    536
    13
    Joined Jan 26, 2006
    grayslake, Illinois
    did you ever fix this problem?
     
  24. FearlessNick

    FearlessNick Proven Member

    425
    1
    Joined Jan 3, 2011
    Casa Grande, Arizona
    Yea, I would like to know. This is making my head spin.
     

    336  0

    1998 Mitsubishi Eclipse N/T
    manual · 2G DSM
    Loading...

Share This Page

Support Vendors who Support the DSM Community
ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory