The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support JNZ Tuning
Please Support Fuel Injector Clinic

Warning Lights Not Turning on, Car won't start

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

Jackson

20+ Year Contributor
101
0
Jan 10, 2003
Victoria_BC_Canada
Okay, when you but the key to the "On" position all those great waring lights turn on..... well normally. Mine are not and my car isn't turning over. Checked fuses, they all looked good so any suggestions on whats going down (besides is a DSM and its expected)? I am running an EMS so I can't pull codes if there are any.
 
Allow me to elaborate more. Head lights are on, car cranks but the warning lights in the dash (IE battery, E Brake, Check engine) are not turning on as they usally do when you put the key to the on position. Battery is charged and good to go.
 
So does the car crank or not??? you first post said it doens't turn over your last post said it cranks?? This is going to sound weird but pull out your ecu and see if it smells like bad fish. I am 100% serious on this. When my ecu went bad in my 1g it wouldn't crank, I didn't get any off the dash lights on so this could be the problem.
 
cars can crank but not turn over. AND in my first post I am running an EMS not a stock ECU, no fishy smells ;)
 
First off, hook up the logger and check for codes, if you are too cheap and dont have a logger O'Rileys and or Autozone has scan tools you can loan.

Check to see if you are getting spark...its easy, if you dont go from there

If you have spark, check to see if you are getting fuel...a little more complicated but you can do it. If you are getting fuel then theres something weird going on because it should start
 
Good call on the data logger if I was running a stock ECU and not a AEM EMS........
Its electrical somewhere either a ground, power wire or fuse that looks good but is fried I guarantee.
 
Okay, when you but the key to the "On" position all those great waring lights turn on..... well normally.

I hate to bring back the dead, but any updates on this problem? I'm dealing with a similar no start issue.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top