The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support RTM Racing
Please Support STM Tuned

Turbo And Boost Problems !HELP!

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

ZeroZ95TSI

Probationary Member
20
0
Feb 13, 2005
Detroit, Michigan
Ok... i recently bought a 1990 Eclipse GSX i have had DSMs in the past but never played with boost or anything. when i got this car i didnt know what to look for beside for potential but my buddy just got a 95 GSX and its all stock and u can really feel the boost in his car and i dont even think i have any boost. i have the older style Blitz BOV and it Blows Off and sounds fine its just i cant feel the turbo spool at all... this is my first time with 1Gs and there in an oil leak somewhere on the turbo and i dont know where from but i dont think that would cause a great lose in boost. it just feels nothing like my 2G talon and it was an automatic. When it gets to like 4500 the turbo is loud as a jet and it feels like my car just gives up like after 4500 im still putting out the same speed... i dont know if this is a crappy BOV symptom or if its a wastegate system or a going turbo. I really need help here so if u got any ideas on y my car is sucking tell me... Thanks :dsm:
 
No I Have Not But I Just Realized How Easy It Is To Do So Im Off To Do That... :coy: Im Retarded...
 
ZeroZ95TSI said:
No I Have Not But I Just Realized How Easy It Is To Do So Im Off To Do That... :coy: Im Retarded...

lay of the shift key , eh? WTF

anyway, when you have time pull off the intake pipe [accordian] and check the turbo for shaft play. It can be possible that the old turbo is shot. also check to see if there is any oil blow-by in the intake pipe. Check for cracks in the turbine housing also.

more than likely your turbo is tired and is ready to quit. also, do the proper maintenance on the car before you go ahead and buy a new turbo. It will be a headache if the turbo ISNT the problem

also check boost leaks, compression test, and a leak down tester to check on the health of your motor.
 
Okay... So i have just recently check for a boost leak and guess what... there was one at the intercooler so yea... i fixed that right and a... im still havin the exact same problem... when at like 4000 it just seems like it punks out and doesnt get faster... i just have a question, could having i bad BOV create absolutely no boost? the turbo is fine and has no shaft play and the BOV is a older style Blitz. the stock boost gauge says its making boost but i feel no difference and i know its supposed to do something even with a stock turbo. and the is like crazy loud! im so confused... HELP ME OUT!!!
 
i have to agree w/ the posts above. 1. check for boost leaks 2.have the timing belt replaced 3. change all fluids 4. buy an aftermarket boost guage so you can see what the turbo is actually putting out. after you have done that you can start modding/fixing other problems that will arise. and have you ever thought that your clutch might be slipping? our cars make more power @ higher rpms so that might be your problem.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top