The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support Fuel Injector Clinic
Please Support Morrison Fabrication

loud thud under heavy load durring acceleration something disengaging?

smurph314

Probationary Member
3
0
Nov 23, 2011
Fremont, Michigan
Yes I see that my post is similar to the Galant, but only in the noise during acceleration (like hitting a wall) the problem is dif. bought a 97 GST FWD turbo 5spd with a 6bolt swap 16gturbo, upgrades large intercooler, piping, injen intake, atmospheric bov. Ngk plugs and msd wires. under normal driving conditions car runs perfect, great start, idle, revs to readline without load(neutral). As it should, spent 3months in a shop fixing a bouncing idle and stall issue. Smoke tested, all (11 vacuum leaks fixed) No vacuum leaks anywhere or oil, fluids. Fixed noise from exhaust (new hangers) new ECU(had blown circuit) , throttle body, idle air control motor had gone bad. And new engine and tranny mounts. (thought the mounts were the cause at first)Under a “medium to heavy” load, half to WOT(driving in 2nd -5th gear) once the turbo starts spooling and the car starts hauling, BOOM a loud thud (feels like the whole car moves) with surprisingly no feeling of movement in the shifter (where I thought at first it was a gear issue).Its Hard to explain, it started 2 weeks after I got the car and was on the highway when I felt it. This was before getting the massive vacuum leaks fixed. It never happened if I could press the pedal ½ to ¾ down throttle and gave the turbo a little time to build boost then press to the floor and as long as I wasn’t going WOT the noise wouldn’t happen. (once the loss of vacuum was fixed) Now the car has more power it makes a hard thud and it also almost feels like the gear is disengaging slipping off but not completely (not as loud since the mounts and exhaust got fixed) because if I let it thud and coutinue to hold throttle the rpm drops a little and feels almost like a bad clutch. Everyonce in a while I can accelerate through the gears without it happening now and it isn’t a sputter or stall. (but not….complicated) is it possible it’s the clutch slipping, or a bad flywheel, or tranny? Also only once the clutch pedal lost pressure for 5 mins while on the hghwy but poped back shortly and still would shift through the gears fine.( Has had ecu, TB, plugs, plgwires, pcv, vacuum leaks, exhaust leaks) inspected and replaced?
Any ideas? clutch, flywheel, differential
 

Prib9671

Proven Member
123
5
Jun 9, 2009
Rathdrum, Idaho
Fuel Cut kind of sounds like that but usually it does it a couple of times and feels like the car is hitting a wall. It scared me the first time I experienced it. Might need more fuel if not that then if you have a stock MAF it might be bad or it is being overrun(ecu thinks its running too lean). Hope that helps.
 

smurph314

Probationary Member
3
0
Nov 23, 2011
Fremont, Michigan
How much boost are you running on that 16g? What fuel mods to you have?

around 15psi and essentially stock, just a heavier fuel pump.


Fuel Cut kind of sounds like that but usually it does it a couple of times and feels like the car is hitting a wall. It scared me the first time I experienced it. Might need more fuel if not that then if you have a stock MAF it might be bad or it is being overrun(ecu thinks its running too lean). Hope that helps.

I think i can describe the wall hit that's happening a little clearer as to why I thought drivetrain, when I start to accelerate everything runs great, then thud and the nose of the car drops like I hit the brake and I almost slow down that much (worse than if I was WOT then just hit the clutch between gears) like something is binding up in the gearing somewhere or disengaging (the noise was almost gone to since the new mounts.
that's wild it only does it under load too because I can rev it up all the way while parked with no issue I just had the ECU replaced, and with the sometimes inconsistency of the pressure in the clutch pedal (also has me a little scared it maybe its a sign of the dreaded (C.W. words) I thought they were related. I had thought if it was fuel and of air related it would start funny, smell weird, sputter, and hesitate during anytime before or after the "THUD" Im not closed to any possibility at this point.
Wouldnt normally there

I have a stock MAF, And I thought it was more to do with the drivetrain because a while back I had the ECU blow part of its "throttle circuit" and found out the throttle body was shot, and it developed 11 vacuum leaks I had to replace the ECU, the and TB funny part was even though it idled funny and had less power 9lbs psi, it stopped "hitting the wall" even wot. So the car felt like it ran faster on the highway because I could actually open it up. I did notice one day when it was cold after the car had sat a week or so that when I first started driving it, it felt like I was taking off in the wrong gear i.e. 3rd instead of 1st 2nd and 4th etc there was almost no power (no stutter, noises, or stalling) almost like there was something slowing the gears or differential poor levels of fluid build up etc, because after the car warmed up, it was fine except for the wall hit

if its air fuel related would swaping the old turbo help, or whats the fix since the ECU is new n good? a new MAF, new fuel rail? trying to tune it with an apexi SAFC? The car ran fine with the upgrades before.

I've already put 2Grand into her and another 300 for new mounts all over im praying its an easy cheap fix :pray:

Thanks for the feedback!!!!
 

airmail96

Proven Member
1,077
3
Mar 28, 2005
Virginia Beach, Virginia
Your problem sounds a lot like fuel cut. You have an upgraded turbo, upgraded intercooler piping and a bigger fuel pump. Usually a bigger fuel pump helps if you want to up the boost on the stock turbo, but the 16g is a decent upgrade from stock. If you want to keep the 16g on I would lower the boost to like 12 or you could get some cheap 550s and a SAFC.
 

smurph314

Probationary Member
3
0
Nov 23, 2011
Fremont, Michigan
Your problem sounds a lot like fuel cut. You have an upgraded turbo, upgraded intercooler piping and a bigger fuel pump. Usually a bigger fuel pump helps if you want to up the boost on the stock turbo, but the 16g is a decent upgrade from stock. If you want to keep the 16g on I would lower the boost to like 12 or you could get some cheap 550s and a SAFC.

Thanks for the help, Turns out some how my wastegate had closed virtually shut, quick fix, problem is gone, however obviously I dont have the power i did but oh well.. in doing so however now i have a check engine light and threw a couple egr codes and an evap code... Murphy's law fix one thing 2 more pop up
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Top