The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support ExtremePSI
Please Support ExtremePSI

lots of little problems with new car(well 95, new to me)

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

awdEAGLEtsi

15+ Year Contributor
85
0
Feb 10, 2004
Syracuse, New_York
ok i just got a 95 awd tsi talon, and the check engine light keeps coming on. no one has the right machine to tell exactly what the problem is, but its probably the O2 sensor, in the exhaust. i know hte check engine light comes on when there is emissions stuff. but the car is also running lean cause of it, so i need to take car of it soon, especially before it warms up.

also, the car is idling at just under 2k, the dealer suggested a new throttle body, but i heard that the talons have a ISC which goes, but that is in the throttle body. can you buy the ISC seperate, cause throttle bodies a not really cheap. the dealer did reset the idle and its idling lower like around 1k which is closer to what it should be, but i am guessing it should be down even more, like around 750. any idea would be great thanks!

there are some other small problems too, but i can deal with those. ohh also, the stock boost gauge, what are about the psi, for each line and what does my car usually boost up to? 12, 13, 14ish?

ohh here are the notes from the mechanic, hard to read.
 

Attachments

  • small carinfo.jpg
    small carinfo.jpg
    81.9 KB · Views: 160
I wouldn't mess with anything until you find out the codes. The factory boost gauge is only a rough estimate of what's being delivered. It's electronic, actual air isn't going to that gauge.
 
Stock boost is around 10-11psi...if you have no means of finding the codes and diagnosing the problem Id recomend to get the codes pulled at the dealer.
Andrew
 
LOL get the codes from the dealer...thats the funny part...i tried, and they didn't have the right program to do it. damn Eagles! any other advice?
 
Want my guess? I bet you have a leaking intake manifold gasket if your car is running lean. If that is the case, your car is sucking in unmonitered air, causing the a/f ratio to be way off. There is my $.02
~Mark
 
Go to AutoZone, buy a beeper, and count the codes. Get two peices of wire, and put it wherever it goes in the fuse box kick panel on the driver side. Turn the key over, but not necessary to start. It will do a long beeb for every first digit, like two longs beeps would be two. IF it would follow with let's say three short beeps you would have the code twenty three. If you want to do that, and tell me what the codes are, I will tell you what the CEL is saying.
 
sweet your the man, now that different than what they do with their computer, cause they got some code but it wasn't specific, but this code would be different?
 
Hey if your willing to drive to maryland you can bring your car to the ford dealership and Ill pull the codes for you....its really sad a mitsu or chrysler dealer cant pull codes but I can at my work...go figure
Andrew
 
Originally posted by awdEAGLEtsi
sweet your the man, now that different than what they do with their computer, cause they got some code but it wasn't specific, but this code would be different?

It just sounds like these guys are a bunch of tools. (no pun intended since they are "mechanics") Just buy a beeper, and find out where the wires go, count the codes, and post what numbers it throws, and I will deliver the news. Peace
 
i will get the number tomorrow(friday), cause i am busy till then. try to look here before like noon, cause i have an appointment with another mitsu dealer who can supposedly do it, but i doubt they can and its 65 bucks. thanks.
 
anyone know about the idle part? i was idling around 2k, then the dealership reset it or something, and now it idles around 1k, but it sounds like it almost stalls. any idea what it could be?!?!?
 
hey gsx, i went to autozone and they had no clue what a beeper was or whatever, so i think i might have to resort to the dealer. my idle isn't right cause it never goes below 1k, and it sounds like it might stall, but that could be cause its running lean or something, i don't know, but i bet its the O2 sensor, and possibly the ISC deal, or whatever in the throttle body.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Latest Classifieds

Back
Top