The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support Fuel Injector Clinic
Please Support Rix Racing

Installing CAS backwards, now can't boost past 2psi

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

Imp Pwr Online

20+ Year Contributor
127
0
Jul 26, 2002
concord, North_Carolina
It's on a 3000GT but same deal, I put it on 180 degrees backwards and went from boosting at 30psi to 2. Even after I put it back in right. What did it break? Comp is 155 on all 6. Timing is dead on. Engine was even rebuilt, and turbos rebuilt. Same problem.
 
Did your wastegate arm fall off or freeze open? Only thing I can think off except blowing an IC pipe but then you wouldn't even be able to make 1 PSI
 
Make sure to check all of your boost source's for leaks. Also if the timing was 180 off check your plugs for fouling really bad or even to be closed. I had a friend who couldn't boost more than 2-3 psi and it ended up being a closed spark plug. I'm sure you check them when you compression tested but I thought I would throw that out. Also unhook your battery for about 10-15 minutes and your ECU then plug them back in and start the car. It might have to relearn some stuff from running so bad it probobly tried to advance and retard timing so much that it messed itself up.
 
turned out one of the 14bs was blown, so it would stall and allow the compressed air from teh good 14b to come out it's inlet.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top