1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

Grr. "Serial Comm Error"/MMCD Issues

Posted by femmeDSM, Feb 18, 2006

Please Support Fuel Injector Clinic
Please Support Rix Racing
  1. femmeDSM

    femmeDSM Proven Member

    864
    62
    Joined Oct 31, 2004
    D/FW, Texas
    I have a logger cable (made by the wonderful Steve) that I got for my laptop. No real issues with that, other than I got tired of lugging my laptop around with me in the car during runs...Plus, my Technomotive software would occasionally lock up, and got in the habit of giving me errors when I tried to check/clear any CEL codes.

    So I got the bright idea to get a Palm and a serial Palm cable to use with it....Only problem is that it doesn't friggin' work. :rolleyes:

    It's one of the "Powered" cables like Pocketlogger sells (it's not a Pocketlogger cable, though). It has three spade connectors on the ends that plug onto the diagnostic port, plus a male connector that plugs into the fuse panel. I have everything hooked up correctly - I even double checked to make sure, per the image below.

    When I turn on my Palm and click MMCD, I go to "Test" just to verify that everything is hooked up properly, and I get the dreaded "Serial Comm Error". I tried to log a couple of very basic random things (BATT, RPM, and Injector Pulse I believe) and nada. It will sometimes give me a reading for "Coolant Temperature" and/or "Air Temperature" but I don't even think they're accurate.

    I'm using MMCD 1.8g (the 'new' one) and a Palm m125 with the latest version of PalmOS.

    I'm worried that I may have accidentally let one of the connectors touch another one of the diagnostic pins during install (it's dark and cramped down there, and I think I accidentally halfway plugged one of the wires onto pin 11 :toobad: ). Did I maybe break something? :(

    The logger cable supposedly "worked fine" when tested by the guy that made the cable for me on his car.

    Any input would be appreciated. I'm getting frustrated. Steve, I just should have had you make me a cable for my new Palm. :coy: Lesson learned (and I still may need to do that yet, if I can't get this working).
     

    Attached Files:

  2. Boost95

    Boost95 Proven Member

    360
    0
    Joined Oct 21, 2004
    Wilkes Barre, Pennsylvania
    I got the same code. Did you ever find out your problem?
     
  3. ericmetcalf11

    ericmetcalf11 Proven Member

    48
    1
    Joined Jan 7, 2004
    La Grange Park, Illinois
    Just sounds like something isn't plugged in right. I don't think you can break anything by plugging it into the wrong diagnostic port, either.

    First make sure you have power from that fuse port. Put the key in the "on" position and use a meter or test light to make sure your getting power from it. If you can't test it, you could take out one of the fuses (because you know there is power from it) and plug into that.

    -Eric
    no sig
     

Share This Page

Support Vendors who Support the DSM Community
ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory