The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support Kiggly Racing
Please Support STM Tuned

apexi turbo timer install problem

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

BE4TNUT

20+ Year Contributor
87
0
Mar 9, 2003
MassachusettsUS
Ok i got the turbo timer and the wiring harness to make things easier for myself. Hooked in the harness, connected the e-brake wire, and grounded it to the cars ECU. Turn it on and it works, set it to test it, shut the car off and the car shuts off and the timer is counting down. thats not supposed to happen... It works when the ignition is on accessories but when the ignition switches off the car turns off. Anyone know anything that I may have done wrong? its the Greddy harness for the 1G that could be it but i dont know. Should I switch to the HKS harness to try?'

BE4TNUT
:dsm:
 
Did u ever fix this? If not maybe instead of just turning car on/off then seeing if it works, you should actually drive the car for a bit. Apexi's tt works from the O2's.
 
It has been hooked up for a long time now. It reads the O2 and the battery output just fine, just wont time the car for some reason, I havent had a chance to try a different harness but im going to very soon.

BE4TNUT
 
i have an apexi timer and it does the count down everytime you turn the car off whether its been driven or just turned on for the hell of it.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top