The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support Morrison Fabrications
Please Support Rix Racing
Malrun

Latest activityPostingsVehiclesAbout

    • Malrun
      Yes, I see the 5sec cel and Boost Gauge goes to 0. I'll check the USB functions
    • Malrun
      That's where I'm afraid it could be the ecm. Nothing standing out that it's messed up. The car runs on its own, not the best but it does. The chance of the cord being messed up is highly unlikely. The previous owner shipped me on from ECMTuning.
    • Malrun
      https://www.ecmtuning.com/wiki/usb2comport Above the first image is the download for USB Edit. It shows the location of your ports and you force the computer to use the driver to whatever ports you set them in regedit.I had an alienware...
    • Malrun
      That's what I'm experiencing, for the past 2 hours after you wrote that, I've been in powershell and other stuff trying to get it my coms to match. usbedit has it listed at Com3 and the pc device manager is at com5. Apparently they did away with...
    • Malrun
      I've only seen a few posts about Windows 11 and ECMLink. That's why I'm thinking I need an older computer. Only $40 for a local XP laptop. I'm at that point where it's worth a shot
    • Malrun
      I got mine running! But it sounds like a lawnmower.
    • Malrun
      90 Eagle Talon with ECMLink V3Windows 11 home edition laptop (brand new just for tuning)I hate to write this post because I'm sure you're all tired of seeing this title.I bought this car with ECMLink V3 installed.Tested the wires to the...
    • Malrun
      I checked the resistor pack yesterday and they read 5.6-5.8. Injectors have continuity back to the ECU. I also checked if the one wire was getting voltage from the battery and they were.Ok, A lot going on in that link. I'll try to repair the...
    • Malrun
      Malrun replied to the thread Resolved 92 ECU in 90 Talon.
      Thank you for your help. I think I found the reason for no start up and made a separate post on what I just found: 1G Found a kill switch linked to MPI. It's the cause of my issues?I was confused on the write up I posted with a non 90 ecu in a...
    • Malrun
      Malrun reacted to 19Eclipse90's post in the thread Resolved 92 ECU in 90 Talon with Like Like.
      Yep, the smaller one is for the noise filter. Without the noise filter, your tach will not function. Again, separate issue from a no-start.These are some different versions of the noise filter. It was originally mounted to the intake...
    • Malrun
      Issue has been resolved by removing the killswitch and repairing the connectionCar: 90 Talon TSIThis stimmed off of 1 sometimes 3 injectors firing but never 4. Took off the CAS with ignition on and spun it to just one injector firing. Before...
      • 445901684_1042225447905796_1775308078096949083_n.jpg
      • 447630978_346316068217270_4969465154252857868_n.jpg
      • 447608562_987995935851738_365859601693364928_n.jpg
      • 441879095_1862006574274931_1574869040926051919_n.jpg
      • 447638053_1624437261644782_318651227906520009_n.jpg
    • Malrun
      Malrun replied to the thread Resolved 92 ECU in 90 Talon.
      Good to hear, that's all I needed to know on that part.The car is a 4pin coil pack. Cluster is a 90.2 connectors are unplugged behind the manifold. The big one had a Black/Green and a Blue/yellow wire to it. The smaller one that looks like...
      • 448076537_1033707104762012_4046846643309949759_n.jpg
    • Malrun
      Malrun reacted to 19Eclipse90's post in the thread Resolved 92 ECU in 90 Talon with Like Like.
      That ECU part number was from a ‘93 model year AWD car with manual transmission. By swapping the wires at ECU pins 6 and 14, the ECU should be compatible with the 1990 electronics to start and drive the car.The tachometer is a separate issue...
    • Malrun
      Took her out for my weekly short drive and got it dialed in really well, finally. Only running about 27 psi but now it's time to turn her up. Also tried my first rolling anti lag and holy hell that was fun.Snapped a quick pic when I parked her.
    • Malrun
      Found out about an hour ago the ECU in my car is a MD193299. The ECU has a ECMLink V3.I found this by digging into why ECMLink isn't connecting. It's not a 90. And that's a different problem.Earlier in my time on the forum, I posted my tach...
    • Malrun
      Malrun replied to the thread 1G Car almost turns over.
      I can't get ECMLink to connect. I'll try again tomorrow. Once I get logs, I'll throw them here.
    • Malrun
      Spent hours trying to get the ECMlink to work. I bought a cheap laptop from Walmart with high hopes. Ended up frustrated but tomorrow afternoon I'll get back to it.
      • 1000002860.jpg
    • Malrun
      Malrun replied to the thread 1G Car almost turns over.
      You might be on to something with the TPS. The harness that attaches to the back side of the Throttle Body was disconnected when we drove the car onto the trailer. I didn't know what I was plugging back in until I looked up the part just now...
    • Malrun
      Malrun replied to the thread 1G Car almost turns over.
      Did a boost leak test and no issues.
    • Malrun
      Malrun replied to the thread 1G Car almost turns over.
      this is one thing I looked at and didn't actually buy. I'll get one now. Thanks
  • Loading…
  • Loading…
  • Loading…
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned
Back
Top