The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support ExtremePSI
Please Support Morrison Fabrication

[RESOLVED] hard to steer standing still

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

xreaction122

15+ Year Contributor
258
0
Oct 28, 2007
Albany, New_York
okay i picked up my 3rd baby last week(96 TSi awd) and i noticed that when the car is standing still, and when i try to steer, its hard to explain but ill try my best. its like someone is kicking the counter way i try to steer. its weird..it has a brand new PS belt, fluid is full.
no problem taking turns. tie rod ends are brand new. alignment was done a month ago.

any ideas?WTF
 
ahh..tried it a couple times but no good :(

its weird. the minute the car starts rolling, it goes away!?
 
Just to confirm, bleed the hydraulics by turning all the way against the stop, and then push just a little harder as you bring the revs up to about 3000. You should hear the bypass function as you do this. Hold it against the stop for about five seconds, and do it a couple of times in both directions.
 
Just to confirm, bleed the hydraulics by turning all the way against the stop, and then push just a little harder as you bring the revs up to about 3000. You should hear the bypass function as you do this. Hold it against the stop for about five seconds, and do it a couple of times in both directions.

im a bit confused. so i slowly rev to 3000 and stay there while im performing this?
 
a little update on the post...i tried going lock to lock while topping out the PS fluid once again and i did see air coming out of the system. but the problem wasnt air..
when i was turning the steering wheel, the PS pully and the belt just stops if i try to move it! that was the resistance("kicking") i was mentioning a couple days ago.

im going to try to tighten the belt but thats all i can come up with..
whats wrong!!:(
 
your pump may be about to take a crap based on your discription of how the pulley and belt was locking and releasing your pump bearings may be bad
 
problem solved. well almost..the belt was not tight enough so i tightened it back but it keeps getting loose every once in a week..so im looking into replacing the pully again.
:beatentodeath:
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top