The Top DSM Community on the Web

For 1990-1999 Mitsubishi Eclipse, Eagle Talon, Plymouth Laser, and Galant VR-4 Owners. Log in to remove most ads.

Please Support ExtremePSI
Please Support Rix Racing

Having problems with my boost. Need help fast

This site may earn a commission from merchant
affiliate links, including eBay, Amazon, and others.

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

FlipSyde94AWD

Probationary Member
4
0
Jan 1, 2003
Grand_Forks_ND
I Just purchased a 90 TSI FWD after selling my 92 TSI AWD. The new car had a blown motor and I ended up getting it for a really cheap price. I have owned it for about three months now and just recently put it all back together. It has a rebuilt head and all of the free mods. (K&N filter, hacked mas, Home made intake, modified BCS, and 2 1/2 catback exhaust. THe car run great. My only problem is that my after market boos gauge tells me that I'm only running about 9PSI of boost in first and second gear, while in third and and fourth I can only get her up to 8PSI. Fifth gear really sucks because I can't get her to go past 7PSI. I know the car can handle alot more but I thought that when you add mods the boost goes up too. I was expecting at least 12PSI through all the gears. I have a MBC I just haven't installed it yet. I'll probably install it as soon as I find out what's wrong. Test and tune is this Saturday and I really wanted this problem fixed before then. Also what's a good RPM to launch at with a FWD? I used to launch my AWD at 4500 by just dropping the clutch but I heard you can slide the clutch with a FWD to avoid wheel hop/Spin. As you can see I'm still new to the FWD stuff. I appreciate any help you all can offer.
Thanks,
Ed
 
good rpm is about 4k,depending on clutch too,then just slip it hard and fast while trying to maintain as much traction as possible. sounds to me like you may have a boost leak..
 
I found out what was wrong.:D It ended up being the homemade intake pipe. The BOV return pipe had a hole in it. I just put some of the orange high temp RTV and bamm back up to 12PSI of boost. Thanks for the input regarding launching AllWheel TSI. I do have another question though, when I'm in first and I start to get on the gas my front wheels start to squeel like they want to peel out. I know I don't need new tires because my front ones are brand new and if it's starting to peel out with me already rolling wouldn't it be worse when I launch with higher boost? Don't get me wrong it sounds cool when driving around with friends but not so great when your stuck at the tree and the guy your going against is already half way down the track.
 
Support Vendors who Support the DSM Community
Boosted Fabrication ECM Tuning ExtremePSI Fuel Injector Clinic Innovation Products Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications MyMitsubishiStore.com RixRacing RockAuto RTM Racing STM Tuned

Latest posts

Build Thread Updates

Vendor Updates

Latest Classifieds

Back
Top