1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

CEL - Randomly Runs on 3 Cylinders

Posted by Clinical, Aug 10, 2012

Please Support Rix Racing
Please Support Rix Racing
  1. Clinical

    Clinical Proven Member

    578
    7
    Joined Nov 15, 2009
    Cedar Falls, Iowa
    So I bought my 92 GST about 3 weeks ago.
    114k miles, bone stock and clean car for $1200.

    When I was letting it run looking around it started running on 3 cylinders. Was an older guy and you could tell the car had sat he just wanted it gone and had never had it only run on 3 cylinders - then while playing with wires and such it suddenly went back to being on 4cylinders. I test drove it, drove great.

    Drove it halfway home started running on 3 cylinders. Got it home and it was running on 4 cylinders again - put new plug wires on it - last 2 weeks it has always been fine.

    Then tonight it starts running on 3cylinders again.

    Also I'm not sure if its related but after starting it - usually about 20-30 seconds afterwards the CEL will come on. Has a new O2 sensor.

    Just wondering if this sounds like it could be a coil pack since I've had a somewhat similar issue on my old 1g and it was the coil pack. Or does this sound like it could be an injector?

    Any ideas of where to start?
     

    Street Build 3K  0

    1994 Eagle Talon TSi AWD
    11.653 @ 119.06 · 1G DSM
    Loading...
  2. iugrad92turbo

    iugrad92turbo Proven Member

    10,472
    393
    Joined May 22, 2007
    Kalamazoo, Michigan
    Whats the code ?
     

    6K  4

    1992 Eagle Talon TSi
    awd · manual · 1G DSM
    Loading...
  3. Clinical

    Clinical Proven Member

    578
    7
    Joined Nov 15, 2009
    Cedar Falls, Iowa
    Don't know need to check it but dont have a tester to check it, it's down at our shop which is about a 15-20 minute drive and probably wont be down there for about a week unless it gets so bad it isnt drivable but its never gotten any worse.

    Mainly just hoping to see if anyone has had a similar issue and what their solutions could of been.
     

    Street Build 3K  0

    1994 Eagle Talon TSi AWD
    11.653 @ 119.06 · 1G DSM
    Loading...
  4. iugrad92turbo

    iugrad92turbo Proven Member

    10,472
    393
    Joined May 22, 2007
    Kalamazoo, Michigan
    With no code hard to say, could be a coil, wires, plugs with a car you just got you really never know til you dig into it and learn more about the condition of it.
     

    6K  4

    1992 Eagle Talon TSi
    awd · manual · 1G DSM
    Loading...
  5. Lou98GSX

    Lou98GSX Proven Member

    663
    47
    Joined Mar 13, 2004
    Carmel, New York
    how does the car behave when you drive it does it break up misfire if it does then it could be a coil . if it just feels rough at idle then i would say injector
     
  6. Clinical

    Clinical Proven Member

    578
    7
    Joined Nov 15, 2009
    Cedar Falls, Iowa
    it just runs on 3 cylinders, so it idles rough and drives rough , it doesnt change its always just plain running on 3 cylinders when its doing it.
     

    Street Build 3K  0

    1994 Eagle Talon TSi AWD
    11.653 @ 119.06 · 1G DSM
    Loading...
  7. Lou98GSX

    Lou98GSX Proven Member

    663
    47
    Joined Mar 13, 2004
    Carmel, New York
    while its running you can try pulling one ignition wire at a time and the cylinder that doesn't change the idle is the one that is misfiring . you should use ignition wire pliers . when you find out what cylinder it is you can shut the engine off. with the wire disconnected put a small screwdriver or if you have an extra plug put that on the wire and hold the plug up against any metal surface have a helper start the engine . if you see a spark then its firing and its not an ignition problem. also do a compression check if that is ok then i would say you have a bad injector
     
  8. zerq

    zerq Proven Member

    47
    0
    Joined Mar 13, 2012
    fairhope, Alabama
    Zombie post!!!

    Ok, my car is doing the exact same thing. Was it ever figured out?
    I've swapped injectors and it went from #2 being the bad cylinder to #3. (Conpletely different set of injectors, not just moved around).
     
  9. triggerx

    triggerx Proven Member

    342
    2
    Joined Aug 15, 2009
    Gilbert, Arizona
    I would recommend trying a different ECU, if you have one around. Also because these cars are so old, I know that a lot of our electrical pigtails that s
    nap to the injector dont fit as snug as they should.

    However I definitely suggest swapping in a ECU, they do go bad.

    Ive had this exact same thing happen to me a long time ago, tried different injectors, fixed the connections, but it ended up being the ECU. Its always good to keep a spare around for troubleshooting anyhow
     
  10. zerq

    zerq Proven Member

    47
    0
    Joined Mar 13, 2012
    fairhope, Alabama
    I put in my EPROM/v3 ECU (has a blown chip for the ISC) started up and idled fine then it dropped 2 cylinders. I went to misc and its #2 and #3. I know the coilpack works like 2 alternating sides. Is 2 and 3 controlled by the same one on the coilpack? I'm going to google it up right now but thought I'd post up anyways LOL

    I also have a spare transistor which didn't seem to fix it.
     

Share This Page

Support Vendors who Support the DSM Community
Archer Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RixRacing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory WheelWell.com