1. Join the Community!

    DSMtuners is a massive archive of DSM information - but more importantly, it's a COMMUNITY! Join in and participate with other DSMers, and invite all of your DSM friends to make this place their home. Chat with others, create a build thread, post questions and answers. Get involved! Logging in will also remove many of the advertisements, along with this notice. ;)

2003 Mitsubishi Eclipse 2.4l 4G64 - P0171 + readiness monitors will not set.

Posted by jazzie366, Aug 20, 2019

Please Support ExtremePSI
Please Support STM Tuned
  1. jazzie366

    jazzie366 Probationary Member

    1
    0
    Joined Aug 20, 2019
    mahwah, New Jersey
    Hello all, I have a the aforementioned 2003 Mitsubishi Eclipse. It will not pass any monitors when going through a drive cycle, and it will also throw the code P0171. I am a fully certified technician, and this thing is throwing me a curve ball. I have the P0171 narrowed down to a leaking throttle body, the seals on the blade shaft are leaking and the whole unit must be replaced. Now, as for the monitors not setting, this is new. I used to be able to drive it lightly and keep my foot out of it and it would pass inspection no problem. However, it's running really lean currently, even though the throttle body leak is minimal, and it runs lean at any throttle position. I have replaced the following to attempt at remedying this: Fuel pump, MAF sensor, MAP sensor, TPS sensor, and I have re-tubed the entire engine with new vacuum hosing to be sure. I also replaced the EGR and EGR solenoid. Still no luck, runs like garbage all the time, fuel trims are very high, usually +10% - +20% which is quite high and well above the 12% threshold to set the code. The car also lacks a lot of power. I cannot pinpoint the source of this and am at my wits end. Anyone have any advice for me? All is greatly appreciated, thanks.

    P.S. I am working with a Autel MaxiCom MK808 which is a 2-way diagnostic scan tool. I can test certain control systems.
     
  2. ThunderChild

    ThunderChild Supporting VIP

    2,518
    683
    Joined Jan 5, 2012
    Rathdrum, Idaho
    Have you checked/replaced the fuel filter? This sounds like classic clogged fuel flow, so filter/injectors...
     

    Street Build 165  3

    1990 Plymouth Laser N/T
    fwd · manual · 1G DSM

    257  8

    1987 Toyota Pickup/Hilux
    awd · manual · Misc Vehicles

    Street Build 793  7

    1997 Mitsubishi Eclipse Spyder GST
    fwd · manual · 2G DSM

    Street Build 1K  1

    1992 Eagle Talon TSi AWD
    manual · 1G DSM

    Street Build 2K  10

    1992 Eagle Talon TSi AWD
    awd · manual · 1G DSM
    Loading...
  3. mitsubishikid

    mitsubishikid Proven Member

    810
    170
    Joined Jun 8, 2009
    Turlock, California
    Did you try cleaning or replacing the o2 sensors yet they might be faulty also fix the throttlebody leak I have heard of the actual pipe style intakes on these models cracking loose under the throttle body on the 3g eclipses, and a lot of owners swap it for the cast outlander intake.
     

    929  0

    1990 Eagle Talon TSi AWD
    manual · 1G DSM
    Loading...

Share This Page

Support Vendors who Support the DSM Community
Archer Fabrication ECM Tuning ExtremePSI Feal Suspension Fuel Injector Clinic Jacks Transmissions JNZ Tuning Kiggly Racing Morrison Fabrications OHM Racing RockAuto SouthBay Fuel Injectors STM Tuned Track Decals Track Sculptures VR Speed Factory WheelWell.com White Shed Speed